Named Data Networking ( NDN ) (verwandt mit Content-Centric Networking (CCN), Content-Based Networking, Data-Oriented Networking oder Information-Centric Networking (ICN)) ist eine vorgeschlagene Internetarchitektur der
Kategorie
Internet protocols
65 Artikel
In der Computernetzwerktechnik ist das User Datagram Protocol ( UDP ) eines der Kernprotokolle der Internetprotokollfamilie.
Die Diensterkennung ist der Prozess der automatischen Erkennung von Geräten und Diensten in einem Computernetzwerk . Sie zielt darauf ab, den manuellen Konfigurationsaufwand für Benutzer und Administratoren zu reduzieren.
Das Service Location Protocol ( SLP , srvloc ) ist ein Protokoll zur Dienstfindung , das es Computern und anderen Geräten ermöglicht, Dienste in einem lokalen Netzwerk ohne vorherige Konfiguration zu finden.
DNSCrypt ist ein Netzwerkprotokoll , das den DNS-Verkehr ( Domain Name System ) zwischen dem Computer des Benutzers und rekursiven Nameservern authentifiziert und verschlüsselt .
Das Domain Name System ( DNS ) ist ein hierarchischer und verteilter Namendienst , der ein Benennungssystem für Computer , Dienste und andere Ressourcen im Internet und anderen IP -Netzwerken bereitstellt.
Das Wireless Application Protocol ( WAP ) ist ein veralteter technischer Standard für den Informationszugriff über Mobilfunknetze .
Das Simple Certificate Enrollment Protocol (SCEP) wird im informativen RFC 8894 beschrieben .
In der Informatik bezeichnet Endianness die Reihenfolge, in der Bytes innerhalb eines Wortdatentyps über ein Datenübertragungsmedium übertragen oder im Computerspeicher adressiert werden , wobei nur die Byte- Wichtigkeit
In der Computernetzwerktechnik sind das Name/Finger-Protokoll und das Finger-Benutzerinformationsprotokoll einfache Netzwerkprotokolle zum Austausch von benutzerorientierten Status- und Benutzerinformationen.
Das Host Identity Protocol (HIP) ist eine Technologie zur Hostidentifizierung für Internetprotokoll- Netzwerke (IP-Netzwerke), wie beispielsweise das Internet .
Das Internet Control Message Protocol Version 6 ( ICMPv6 ) ist die Implementierung des Internet Control Message Protocol (ICMP) für das Internet Protocol Version 6 (IPv6).
Das Identifier-Locator Network Protocol ( ILNP ) ist ein Netzwerkprotokoll , das die beiden Funktionen von Netzwerkadressen – die Identifizierung von Netzwerkendpunkten und die Unterstützung des Routings – trennt , indem
IGMP-Snooping ist das Abhören des IGMP-Netzwerkverkehrs ( Internet Group Management Protocol ), um die Zustellung von IP-Multicasts zu steuern .
Die Internetprotokollfamilie , allgemein bekannt als TCP/IP , ist ein Rahmenwerk zur Organisation der im Internet und ähnlichen Computernetzwerken verwendeten Kommunikationsprotokolle nach funktionalen Kriterien.
Das InterPlanetary File System ( IPFS ) ist ein Protokoll , ein Hypermedia- und Dateiaustauschnetzwerk , das Daten mithilfe einer verteilten Hashtabelle zur Speicherung von Anbieterinformationen austauscht.
Internet Protocol Flow Information Export (IPFIX) ist ein IETF- Protokoll und zugleich der Name der IETF- Arbeitsgruppe, die dieses Protokoll definiert.
IP-Multicast ist eine Methode, um Internetprotokoll- Datagramme (IP- Datagramme) in einer einzigen Übertragung an eine Gruppe interessierter Empfänger zu senden.
IPFC steht für Internet Protocol over Fibre Channel . Es regelt eine Reihe von Standards, die im Januar 2006 für die Adressauflösung ( ARP ) und die Übertragung von IPv4- und IPv6 -Netzwerkpaketen über ein
In der Informatik ist Internet Protocol Security ( IPsec ) eine sichere Netzwerkprotokollfamilie , die Datenpakete authentifiziert und verschlüsselt, um eine sichere, verschlüsselte Kommunikation zwischen zwei Computern
Intermediate System to Intermediate System ( IS-IS , auch ISIS geschrieben ) ist ein Link-State Interior Gateway Protocol (IGP) zum Austausch von Routing-Informationen innerhalb eines Netzwerks.
Die statische Kontextheaderkomprimierung (SCHC) ist ein Standardmechanismus zur Komprimierung und Fragmentierung, der von der IPv6 over LPWAN-Arbeitsgruppe der IETF definiert wurde .
L4S (für Low Latency, Low Loss and Scalable Throughput ) ist ein IETF -Netzwerkprotokoll und eine Technologie zur Staukontrolle, die entwickelt wurde, um gleichzeitig die Netzwerklatenz und die Paketverlustrate durch
Das Lightweight Access Point Protocol ( LWAPP ) ist ein Protokoll, mit dem mehrere WLAN- Zugangspunkte gleichzeitig gesteuert werden können.
Link -Local Multicast Name Resolution ( LLMNR ) ist ein Protokoll, das auf dem DNS-Paketformat basiert und es IPv4- und IPv6- Hosts ermöglicht, die Namensauflösung für Hosts im selben lokalen Netzwerk durchzuführen.
Dies ist eine Übersicht über die in Zonendateien des Domain Name Systems (DNS) zulässigen Resource Records (RRs) . Sie enthält auch Pseudo-RRs.
↑ Polgar, Susan (2005). „Das neue Zeitalter des Internetschachs“ (PDF) . Susan Polgar über Schach . CyberCafes . Abgerufen am 18. September 2022 .
Der Begriff Listserv (vom eingetragenen Markenlizenznehmer L-Soft International, Inc.
MacIP ist ein Standard zur Kapselung von IP -Paketen im AppleTalk Datagram Delivery Protocol (DDP), da LocalTalk ausschließlich AppleTalk überträgt (im Gegensatz zu Ethernet, das mehrere Protokolle höherer Schichten
Die Multipurpose Transaction Protocol(MTP)-Software ist einproprietäresTransportprotokoll(OSI-Schicht 4Transmission Control Protocol(TCP)-Transportprotokolleine überlegene Leistung und Zuverlässigkeit bietet .
Das Micro Transport Protocol ( μTP , manchmal uTP ) ist eine offene, auf dem User Datagram Protocol (UDP) basierende Variante des BitTorrent Peer-to-Peer-Dateiübertragungsprotokolls .

Net-SNMP ist eine Software-Suite zur Verwendung und Bereitstellung des SNMP- Protokolls (v1, v2c und v3 sowie des AgentX- Subagentenprotokolls).
Network File System ( NFS ) ist ein verteiltes Dateisystemprotokoll , das ursprünglich 1984 von Sun Microsystems (Sun) entwickelt wurde .
Network Data Representation (NDR) ist eine Implementierung der Darstellungsschicht im OSI-Modell . Sie wird für DCE/RPC und Microsoft RPC (MSRPC) verwendet.
Open Network for Digital Commerce ( ONDC ) ist eine staatliche Technologieinitiative des indischen Ministeriums für die Förderung von Industrie und Binnenhandel (DPIIT) zur Förderung eines dezentralen, offenen
Das Parallel Line Internet Protocol ( PLIP ) ist ein Computernetzwerkprotokoll für die direkte Kommunikation zwischen Computern über den Parallelport , der normalerweise für Verbindungen zu einem Drucker verwendet wird.
In Computernetzwerken ist ein Port ein Kommunikationsendpunkt . Auf Softwareebene innerhalb eines Betriebssystems ist ein Port ein logisches Konstrukt, das einen bestimmten Prozess oder einen Netzwerkdienst identifiziert
Das Port Control Protocol ( PCP ) ist ein Netzwerkprotokoll , das es Hosts in IPv4- oder IPv6 -Netzwerken ermöglicht , die Übersetzung und Weiterleitung eingehender IPv4- oder IPv6 -Pakete durch einen vorgelagerten
Die Protokollkriege waren eine langjährige Debatte in der Informatik , die von den 1970er- bis in die 1990er-Jahre andauerte.
Der Remote Authentication Dial-In User Service ( RADIUS ) ist ein Netzwerkprotokoll, das die zentrale Authentifizierung, Autorisierung und Abrechnung ( AAA ) von Benutzern ermöglicht, die sich mit einem Netzwerkdienst
RadSec ist ein Protokoll zum Transport von RADIUS- Datagrammen über TCP und TLS .
Das Routing Information Protocol ( RIP ) ist eines der ältesten Distanzvektor-Routingprotokolle und verwendet die Hop-Anzahl als Routingmetrik .
Das Stream Control Transmission Protocol (SCTP) besitzt eine einfachere grundlegende Paketstruktur als TCP . Jedes Paket besteht aus zwei grundlegenden Abschnitten:
Das Serial Line Internet Protocol ( SLIP ) ist eine Kapselung des Internetprotokolls , die für die Kommunikation über serielle Schnittstellen und Routerverbindungen entwickelt wurde . Es ist in RFC 1055 dokumentiert .
Das Simple Network Management Protocol ( SNMP ) ist ein Internetstandardprotokoll zum Sammeln und Organisieren von Informationen über verwaltete Geräte in IP- Netzwerken und zum Ändern dieser Informationen, um das
SMART Multicast ist eine experimentelle Methode für sicheres und zuverlässiges IP-Multicast . Sie ermöglicht es, IP-Datagramme an eine unbegrenzte Anzahl von Empfängern weiterzuleiten.
SOCKS ist ein Internetprotokoll , das Netzwerkpakete zwischen Client und Server über einen Proxy-Server austauscht .
SPDY (ausgesprochen „Speedy“) ist ein veraltetes, offenes Kommunikationsprotokoll zur Übertragung von Webinhalten . SPDY bildete die Grundlage für die HTTP/2 -Spezifikation.
Die Spezifikationen für Weltraumkommunikationsprotokolle ( SCPS ) sind eine Reihe von Erweiterungen bestehender und neuer Protokolle, die vom Beratenden Komitee für Weltraumdatensysteme (CCSDS) entwickelt wurden, um die
In der Informatik ist Syslog ( ausgesprochen / ˈsɪslɒɡ / ) ein Standard für die Protokollierung von Meldungen .
T.38 ist eine ITU- Empfehlung zur Ermöglichung der Faxübertragung über IP -Netzwerke (FoIP) in Echtzeit.
Tinc ist ein Open-Source- Protokoll und eine Software-Implementierung für selbstroutingfähige Mesh-Netzwerke , die für komprimierte und verschlüsselte virtuelle private Netzwerke (VPNs) verwendet wird.
Traversal Using Relays around NAT ( TURN ) ist ein Protokoll , das Multimedia-Anwendungen beim Umgehen von Netzwerkadressübersetzern (NAT) oder Firewalls unterstützt.
Das TaZmen Sniffer Protocol (TZSP) ist ein Kapselungsprotokoll , das zum Einkapseln anderer Protokolle verwendet wird.
Eine UDP-Helper-Adresse ist eine spezielle Routerkonfiguration , die verwendet wird, um Broadcast -Netzwerkverkehr von einem Client- Rechner in einem Subnetz an einen Server in einem anderen Subnetz weiterzuleiten .
RFC 8657 RFC 8737 RFC 8738 RFC 8739 RFC 8823 RFC 9115 RFC 9444 RFC 9447 RFC 9448 RFC 9538 RFC 9773 RFC 9799 RFC 9891
Ein Uniform Resource Identifier ( URI ), früher Universal Resource Identifier , ist eine eindeutige Zeichenfolge, die eine abstrakte oder physische Ressource identifiziert, : 1 wie beispielsweise Ressourcen auf einer
Usenet ( / ˈjuːznɛt / ) , kurz für User 's Network , ist ein weltweites , verteiltes Diskussionssystem für Computer. Es wurde aus der allgemeinen Unix-zu-Unix-Copy ( UUCP) -Architektur für Einwahlverbindungen entwickelt .
Variantenobjekte im Kontext von HTTP sind Objekte, die von einem Ursprungsinhaltsserver in einer bestimmten Art der übertragenen Datenvariation bereitgestellt werden (z. B.
In der Telekommunikation und Computernetzwerktechnik bezeichnet verbindungsorientierte Kommunikation ein Kommunikationsprotokoll, bei dem vor der Übertragung von Daten eine Kommunikationssitzung oder eine semipermanente
WebTorrent ist ein in JavaScript geschriebener Peer-to-Peer (P2P) -Streaming -Torrent-Client , der BitTorrent -Funktionen direkt in Webbrowsern ermöglicht .
WHOIS (ausgesprochen wie „Wer ist“) ist ein Abfrage- und Antwortprotokoll , das für Abfragen von Datenbanken verwendet wird, die die registrierten Benutzer oder Inhaber einer Internetressource speichern .
Die Time-to-Live ( TTL ) oder Hop-Limitierung ist ein Mechanismus, der die Lebensdauer von Daten in einem Computer oder Netzwerk begrenzt.
Certificate Management over CMS (CMC) ist ein vom IETF veröffentlichter Internetstandard , der Transportmechanismen für die Cryptographic Message Syntax (CMS) definiert.
Gemini (oder Project Gemini ) ist ein Anwendungsschicht- Internetkommunikationsprotokoll für den Zugriff auf entfernte Dokumente, ähnlich wie HTTP und Gopher .