Ein Frame ist eine digitale Datenübertragungseinheit in Computernetzwerken und der Telekommunikation . In paketvermittelten Systemen ist ein Frame ein einfacher Container für ein einzelnes Netzwerkpaket . In anderen Telekommunikationssystemen ist ein Frame eine sich wiederholende Struktur, die Zeitmultiplexverfahren unterstützt .
Ein Frame enthält typischerweise Frame-Synchronisationsmerkmale , bestehend aus einer Bit- oder Symbolfolge, die dem Empfänger den Anfang und das Ende der Nutzdaten innerhalb des empfangenen Symbol- oder Bitstroms signalisiert. Ist ein Empfänger während der Frame-Übertragung mit dem System verbunden, ignoriert er die Daten, bis er eine neue Frame-Synchronisationssequenz erkennt.
Paketvermittlung
Im OSI-Modell der Rechnernetze ist ein Frame die Protokolldateneinheit der Sicherungsschicht . Frames entstehen durch die letzte Kapselungsschicht, bevor die Daten über die Bitübertragungsschicht übertragen werden. [ 1 ] Ein Frame ist „die Übertragungseinheit eines Sicherungsschichtprotokolls und besteht aus einem Sicherungsschicht-Header, gefolgt von einem Paket.“ [ 2 ] Zwischen den einzelnen Frames befindet sich jeweils eine Lücke (Interframe Gap) . Ein Frame ist eine Bitfolge, die sich im Allgemeinen aus Frame-Synchronisationsbits, der Paketnutzlast und einer Frame-Prüfsequenz zusammensetzt . Beispiele hierfür sind Ethernet-Frames , Wi-Fi- Frames, 4G- Frames, Point-to-Point-Protokoll- Frames (PPP), Fibre-Channel-Frames und V.42- Modem-Frames.
Häufig sind Frames unterschiedlicher Größe ineinander verschachtelt. Beispielsweise werden bei der Verwendung des Point-to-Point-Protokolls (PPP) über asynchrone serielle Kommunikation die acht Bits jedes einzelnen Bytes durch Start- und Stoppbits umrahmt [ 3 ] [ 4 ] , die Nutzdatenbytes eines Netzwerkpakets durch Header und Footer, und mehrere Pakete können durch Frame-Grenzoktette umrahmt werden [ 5 ] .
Zeitmultiplex
In der Telekommunikation, insbesondere bei den Varianten Zeitmultiplex (TDM) und Zeitmultiplex-Mehrfachzugriff (TDMA), ist ein Frame ein zyklisch wiederholter Datenblock, der aus einer festen Anzahl von Zeitschlitzen besteht – einem für jeden logischen TDM-Kanal bzw. TDMA-Sender. In diesem Kontext ist ein Frame typischerweise eine Einheit der physikalischen Schicht. Beispiele für TDM-Anwendungen sind SONET/SDH und der leitungsvermittelte B-Kanal von ISDN , während TDMA-Beispiele die leitungsvermittelte Datenübertragung (CSD) sind , die in frühen Mobilfunkdiensten verwendet wurde. Auch im Zeitduplexverfahren (TDMA) ist ein Frame eine Einheit , bei dem das mobile Endgerät in einigen Zeitschlitzen sendet und in anderen empfängt.
Siehe auch
Referenzen
- ^ „Sicherungsschicht (Schicht 2)“ . Der TCP/IP-Leitfaden. 20.09.2005 . Abgerufen am 31.01.2010 .
- ^ R. Braden (Hrsg.). (Oktober 1989). Anforderungen an Internet-Hosts – Kommunikationsschichten . Network Working Group. doi : 10.17487/RFC1122 . STD 3. RFC 1122 .Internet Standard 3. Aktualisiert durch RFC 1349 , 4379 , 5884 , 6093 , 6298 , 6633 , 6864 , 8029 und 9293 .
- ^ David S. Lawyer und Greg Hankins. „Serial HOWTO“. Abschnitt „20.4 Byte-Formatierung (Framing)“ . 2011. Zitat: „… ein Startbit und ein Stoppbit, um den Anfang und das Ende eines Bytes zu markieren. Dies wird als Framing bezeichnet … Verwechseln Sie diese Art des Framings nicht mit dem Framing, das für ein Byte-Paket in einem Netzwerk verwendet wird.“
- ^ MATLAB Externe Schnittstellen. Abschnitt „Serielles Datenformat“ . Zitat: „… ein Startbit … Paritätsbit … Stoppbit(s) … sogenannte Rahmenbits, da sie die Datenbits einrahmen.“
- ^ W. Simpson (Hrsg.). (Juli 1994). Das Point-to-Point-Protokoll (PPP) . Network Working Group. doi : 10.17487/RFC1661 . STD 51. RFC 1661 .Internetstandard 51. Ersetzt RFC 1548. Aktualisiert durch RFC 2153.
Ein Paket wird üblicherweise einem Frame zugeordnet; Ausnahmen bilden die Fragmentierung der Sicherungsschicht oder die Zusammenfassung mehrerer Pakete in einem einzigen Frame.