| HTTP |
|---|
| Anfragemethoden |
| Kopfzeilenfelder |
| Antwortstatuscodes |
| Sicherheitszugriffskontrollmethoden |
| Sicherheitslücken |
Der HTTP -Statuscode 403 bedeutet, dass der Zugriff auf die angeforderte Ressource verboten ist. Der Server hat die Anfrage verstanden, wird sie aber nicht ausführen, selbst wenn sie korrekt war.
Spezifikationen
HTTP 403 stellt einen anderen Fehlerfall dar als HTTP 401. Während HTTP 401 zurückgegeben wird, wenn sich der Client nicht authentifiziert hat und impliziert, dass nach erfolgreicher Authentifizierung eine Antwort erfolgen kann, wird HTTP 403 zurückgegeben, wenn dem Client der Zugriff auf die Ressource trotz Authentifizierung verweigert wird, beispielsweise aufgrund unzureichender Berechtigungen des authentifizierten Kontos. [ a ]
Fehler 403: „Der Server hat die Anfrage verstanden, verweigert aber deren Autorisierung.“ [ 1 ] : §15.5.4
Fehler 401: „Der Statuscode 401 (Nicht autorisiert) bedeutet, dass die Anfrage nicht bearbeitet werden konnte, da für die Zielressource keine gültigen Anmeldeinformationen vorliegen.“ [ 1 ] : §15.5.2
Der Apache -Webserver gibt den Statuscode 403 Forbidden zurück, wenn Anfragen an URL- Pfade [ 2 ] gesendet werden, die Dateisystemverzeichnissen entsprechen , und wenn die Verzeichnisauflistung auf dem Server deaktiviert ist und keine Directory-Index -Direktive vorhanden ist, die eine vorhandene Datei für den Browser angibt. Manche Administratoren konfigurieren die Mod-Proxy- Erweiterung für Apache, um solche Anfragen zu blockieren; auch dies führt zu einem Statuscode 403 Forbidden. Microsoft IIS reagiert analog, wenn die Verzeichnisauflistung auf diesem Server verweigert wird. Bei WebDAV gibt der Server den Statuscode 403 Forbidden zurück, wenn der Client eine PROPFIND-Anfrage gesendet, aber den erforderlichen Depth-Header nicht oder einen Depth-Header mit dem Wert „unendlich“ übermittelt hat. [ 2 ]
Beispiele

Kundenanfrage:
GET /hello.html HTTP / 1.1 Host : www.example.orgServerantwort:
HTTP / 1.1 403 Forbidden Content-Type : text/html<html> <head> <title> 403 Forbidden </title> </head> <body> <h1> Forbidden </h1> <p> Sie haben keine Berechtigung , auf /hello.html auf diesem Server zuzugreifen . </p> </body> </html>Siehe auch
Anmerkungen
- ^ Siehe #Substatus-Fehlercodes für IIS für mögliche Gründe, warum ein Webserver die Bearbeitung einer Anfrage verweigern könnte.
Referenzen
- ^ a b R. Fielding ; M. Nottingham; J. Reschke, Hrsg. (Juni 2022). HTTP-Semantik . Internet Engineering Task Force . doi : 10.17487/RFC9110 . ISSN 2070-1721 . STD 97. RFC 9110 .Internetstandard 97. Ersetzt RFC 2818 , 7230 , 7231 , 7232 , 7233 , 7235 , 7538 , 7615 und 7694. Aktualisiert RFC 3864 .
- ^ a b „HTTP Extensions for Web Distributed Authoring and Versioning (WebDAV)“ . IETF . Juni 2007. Archiviert vom Original am 3. März 2016. Abgerufen am 12. Januar 2016 .