Henrik Frystyk Nielsen (* 1969) ist ein dänischer Ingenieur und Informatiker. Er ist vor allem für seine Pionierarbeit am World Wide Web und seine anschließenden Arbeiten an Computernetzwerkprotokollen bekannt .
Biographie
Henrik Frystyk Nielsen wurde am 1. August 1969 in Kopenhagen , Dänemark , geboren . [ 1 ]
Frystyk Nielsen erhielt im August 1994 einen Master-Abschluss in Telekommunikationstechnik von der Universität Aalborg in Dänemark. [ 2 ]
Frystyk Nielsens Web-Arbeit begann am CERN , wo er Tim Berners-Lees erster Doktorand wurde und sich ein Büro mit Håkon Wium Lie , dem Miterfinder von Cascading Style Sheets (CSS) , teilte . Gemeinsam entwickelten sie den Webbrowser Arena . Zu dieser Zeit begann er die Zusammenarbeit mit Berners-Lee und schloss sich später Roy Fielding und anderen an. 1994 lud Berners-Lee Frystyk Nielsen ein, dem technischen Personal des neu gegründeten World Wide Web Consortiums ( W3C ) beizutreten. Er trat dem W3C-Team im März 1995 bei und setzte seine Arbeit an HTTP und anderen Webprotokollthemen wie dem Line Mode Browser und libwww fort . [ 2 ] [ 3 ]
Frystyk Nielsen war einer der Hauptautoren der 1996 veröffentlichten Spezifikationen des Hypertext Transfer Protocol (HTTP). [ 4 ] Anschließend leitete er die Entwicklung einer „nächsten Generation“ namens HTTP 1.1, die 1999 veröffentlicht wurde. [ 5 ] Er verließ das W3C im Juli 1999. [ 6 ]
Frystyk Nielsen trat im August 1999 in den Dienst von Microsoft ein und begann mit der Arbeit an SOAP 1.1. Frühere SOAP-Versionen waren als XML-basiertes Objektserialisierungsprotokoll, wie beispielsweise XML-RPC, konzipiert . Durch die Beiträge von Frystyk Nielsen, Noah Mendelsohn und anderen entwickelte sich SOAP 1.1 jedoch zu einem schlanken, nachrichtenorientierten Protokoll für den Austausch semistrukturierter Informationen in einer stark dezentralen Umgebung. [ 7 ] Im Jahr 2000 schloss sich Frystyk Nielsen als Redakteur den Standardisierungsbemühungen von SOAP innerhalb der W3C XML Protocol Working Group an, aus denen schließlich SOAP 1.2 hervorging. [ 8 ]
Im Jahr 2003 startete Frystyk Nielsen zusammen mit George Chrysanthakopoulos ein Inkubationsprojekt mit dem Ziel, ein neues weborientiertes Anwendungsmodell und ein zugehöriges Programmiermodell für hochgradig parallele und verteilte Umgebungen zu entwickeln. Ein Ergebnis dieses Projekts ist DSSP , ein SOAP-basiertes Protokoll, das das Web- und HTTP-Modell um strukturierte Datenmanipulation und Ereignisbenachrichtigungen erweitert. Ende 2005 ging das Projekt in die Produktentwicklung über, als Frystyk Nielsen und Chrysanthakopoulos der neu gegründeten Microsoft Robotics Group beitraten. Im Juni 2006 wurde die erste Version des Microsoft Robotics Studio veröffentlicht. Frystyk Nielsen ist derzeit leitender Architekt im Team für angewandte KI bei Microsoft und arbeitet an der Integration von KI in Edge-Computing-Umgebungen. [ 9 ]
Referenzen
- ^ „Lebenslauf von Henrik Frystyk Nielsen“ . World Wide Web Consortium . 22.10.1998 . Abgerufen am 4.03.2013 .
- ^ a b Frystyk Nielsen, Henrik (24.04.1995). „Using the Library of Common Code“ . World Wide Web Consortium . Archiviert vom Original am 06.11.2012 . Abgerufen am 04.03.2013 .
- ^ „W3C Alumni“ . World Wide Web Consortium. 03.05.2012 . Abgerufen am 04.03.2013 .
- ^ T. Berners-Lee ; R. Fielding ; H. Frystyk (Mai 1996). Hypertext Transfer Protocol – HTTP/1.0 . Network Working Group. doi : 10.17487/RFC1945 . RFC 1945 .Informativ.
- ^ R. Fielding ; J. Gettys; J. Mogul; H. Frystyk ; L. Masinter ; P. Leach; T. Berners-Lee (August 1999). Hypertext Transfer Protocol – HTTP/1.1 . Network Working Group. doi : 10.17487/RFC2616 . RFC 2616 .Veraltet. Ersetzt durch RFC 7230 , 7231 , 7232 , 7233 , 7234 und 7235. Ersetzt RFC 2068. Aktualisiert durch RFC 2817 , 5785 , 6266 und 6585 .
- ^ „Henrik Frystyk Nielsen“ . Ehemalige persönliche Webseite . World Wide Web Consortium. 07.12.2006 . Abgerufen am 04.03.2013 .
- ^ Don Box et al. (08.05.2000). „Simple Object Access Protocol (SOAP) 1.1“ . World Wide Web Consortium . Abgerufen am 04.03.2013 .
- ^ „SOAP Version 1.2 Part 1: Messaging Framework (Second Edition)“ . World Wide Web Consortium. 27.04.2007 . Abgerufen am 04.03.2013 .
- ^ „KI am Netzwerkrand“ . Microsoft . 14.11.2018 . Abgerufen am 24.11.2018 .
Weiterführende Literatur
- Tim Berners-Lee ; Mark Fischetti (22.09.1999). Weaving the Web: The Original Design and Ultimate Destiny of the World Wide Web . Harper Collins Publishers . ISBN 0-06-251586-1Die
- Henrik Frystyk Nielsen et al. (24.06.1997). „Auswirkungen von HTTP/1.1, CSS1 und PNG auf die Netzwerkleistung“ . World Wide Web Consortium . Abgerufen am 04.03.2013 .