In Rechnernetzen bezeichnet die maximale Übertragungseinheit ( MTU ) die Größe der größten Protokolldateneinheit (PDU), die in einer einzelnen Netzwerkschicht -Transaktion übertragen werden kann. [ 1 ] : 25 Die MTU ist verwandt mit der maximalen Rahmengröße , die auf der Sicherungsschicht (z. B. Ethernet-Frame ) transportiert werden kann , jedoch nicht mit ihr identisch .
Eine größere MTU (Maximum Transmission Unit) reduziert den Overhead . Kleinere MTU-Werte können die Netzwerkverzögerung verringern . In vielen Fällen hängt die MTU von den zugrunde liegenden Netzwerkkapazitäten ab und muss manuell oder automatisch angepasst werden, um diese Kapazitäten nicht zu überschreiten. MTU-Parameter können in Verbindung mit einer Kommunikationsschnittstelle oder einem Standard auftreten. Einige Systeme bestimmen die MTU beim Verbindungsaufbau, z. B. mithilfe der Pfad-MTU-Erkennung .
Anwendbarkeit
MTUs (Maximum Transmission Units) werden in Kommunikationsprotokollen und Netzwerkschichten verwendet . Die MTU wird in Bytes oder Oktetten der größten PDU (Processing Data Unit) angegeben, die die Schicht weiterleiten kann. MTU-Parameter werden üblicherweise in Verbindung mit einer Kommunikationsschnittstelle ( Netzwerkkarte , serieller Port usw.) verwendet. Standards ( z. B. Ethernet ) können die Größe einer MTU festlegen; Systeme (z. B. serielle Punkt-zu-Punkt-Verbindungen) können die MTU jedoch auch beim Verbindungsaufbau bestimmen.
Die darunterliegenden Sicherungs- und Bitübertragungsschichten fügen den zu übertragenden Netzwerkdaten üblicherweise zusätzlichen Aufwand hinzu. Daher muss bei einer gegebenen maximalen Framegröße eines Mediums dieser Aufwand abgezogen werden, um die maximale Übertragungseinheit (MTU) des Mediums zu berechnen. Bei Ethernet beträgt die maximale Framegröße beispielsweise 1518 Byte, wovon 18 Byte auf den Aufwand für Header und Frame-Check-Sequenz entfallen . Daraus ergibt sich eine MTU von 1500 Byte.
Abwägungen
Eine größere MTU führt zu höherer Effizienz, da jedes Netzwerkpaket mehr Benutzerdaten transportiert, während der Protokoll-Overhead, wie z. B. Header oder zugrundeliegende Paketverzögerungen, konstant bleibt. Die daraus resultierende höhere Effizienz bedeutet einen verbesserten Durchsatz des Gesamtprotokolls. Eine größere MTU erfordert zudem die Verarbeitung von weniger Paketen für die gleiche Datenmenge. In manchen Systemen kann die Verarbeitung pro Paket einen kritischen Leistungsfaktor darstellen.
Dieser Vorteil hat jedoch auch Nachteile. Große Pakete belegen eine Verbindung länger als kleinere, was zu größeren Verzögerungen nachfolgender Pakete und somit zu höheren Netzwerkverzögerungen und -schwankungen führt . Beispielsweise blockiert ein 1500-Byte-Paket, das größte von Ethernet auf der Netzwerkschicht zulässige Paket, ein 14,4k-Modem für etwa eine Sekunde.
Große Pakete stellen auch bei Kommunikationsfehlern ein Problem dar. Ohne Vorwärtsfehlerkorrektur erfordert die Beschädigung eines einzelnen Bits in einem Paket die erneute Übertragung des gesamten Pakets, was kostspielig sein kann. Bei gleicher Bitfehlerrate sind größere Pakete anfälliger für Beschädigungen. Ihre größere Nutzlast verlängert die Dauer der erneuten Übertragung. Trotz der negativen Auswirkungen auf die Dauer der erneuten Übertragung können große Pakete die End-to-End-TCP-Performance insgesamt positiv beeinflussen. [ 2 ]
Internetprotokoll
Die Internetprotokollfamilie wurde so konzipiert, dass sie mit vielen verschiedenen Netzwerktechnologien funktioniert, die jeweils Pakete unterschiedlicher Größe verwenden können. Ein Host kennt zwar die MTU seiner eigenen Schnittstelle und möglicherweise auch die seiner Peers (aus den initialen Handshakes), aber er kennt anfänglich nicht die niedrigste MTU in einer Kette von Verbindungen zu anderen Peers. Ein weiteres potenzielles Problem besteht darin, dass Protokolle höherer Ebene Pakete erzeugen können, die selbst die lokale Verbindung nicht unterstützt.
IPv4 ermöglicht die Fragmentierung , wodurch das Datagramm in kleine Teile zerlegt wird, die jeweils so klein sind, dass sie eine festgelegte MTU-Beschränkung einhalten. Dieser Fragmentierungsprozess findet auf der Internetschicht statt . Die fragmentierten Pakete werden markiert, sodass die IP-Schicht des Zielrechners weiß, dass sie die Pakete wieder zum ursprünglichen Datagramm zusammensetzen muss.
Damit ein Datenpaket als empfangen gilt, müssen alle Teile ankommen. Geht ein Teil verloren, ist das gesamte Paket verloren.
Bei einer großen Anzahl fragmentierter Pakete oder Fragmente kann die Fragmentierung zu unnötigem Mehraufwand führen. Beispielsweise kann die maximale Übertragungseinheit (MTU) bei Tunneling-Szenarien geringfügig überschritten werden, da lediglich ein Header hinzugefügt wird. Obwohl die zusätzliche Datenmenge gering ist, muss jedes Paket nun in zwei Fragmenten gesendet werden, wobei das zweite Fragment nur sehr wenig Nutzdaten enthält. Es wird zwar die gleiche Nutzdatenmenge übertragen, aber jeder zwischengeschaltete Router muss doppelt so viele Pakete weiterleiten.
Das Internetprotokoll (IP) schreibt vor, dass Hosts IP-Datagramme von mindestens 576 Byte (für IPv4) bzw. 1280 Byte (für IPv6) verarbeiten können müssen. Dies schließt jedoch nicht aus, dass Sicherungsschichten mit einer kleineren MTU IP-Daten übertragen können. Gemäß der IPv6-Spezifikation muss beispielsweise eine Sicherungsschicht, die ein 1280 Byte großes IP-Datagramm nicht in einem einzigen Frame übertragen kann, einen eigenen Fragmentierungs- und Reassemblierungsmechanismus bereitstellen, der unabhängig vom IP-Fragmentierungsmechanismus ist. Dieser Mechanismus stellt sicher, dass das 1280 Byte große IP-Datagramm intakt an die IP-Schicht übermittelt werden kann.
MTUs für gängige Medien
Im Kontext des Internetprotokolls (IP) bezeichnet MTU die maximale Größe eines IP-Pakets , das ohne Fragmentierung über ein bestimmtes Medium übertragen werden kann. Die Größe eines IP-Pakets umfasst die IP-Header, jedoch nicht die Header der Sicherungsschicht. Bei einem Ethernet-Frame führt dies zu einem zusätzlichen Protokoll-Overhead von 18 Byte bzw. 22 Byte mit einem IEEE-802.1Q -Tag für VLAN-Tagging oder Dienstklassenkennzeichnung .
Die MTU (Maximum Transmission Unit) darf nicht mit der minimalen Datagrammgröße (am Stück oder in Fragmenten) verwechselt werden, die alle Hosts akzeptieren können müssen. Diese beträgt 576 Byte für IPv4 [ 1 ] :24 und 1280 Byte für IPv6 [ 3 ] :25 .
| Medien für IP-Transport | Maximale Übertragungseinheit (Bytes) | Anmerkungen |
|---|---|---|
| Internet IPv4 Pfad MTU | Mindestens 68, [ 1 ] : 24 maximal 64 KiB [ 1 ] : 12 | Systeme können Path MTU Discovery [ 4 ] verwenden , um die tatsächliche Pfad-MTU zu ermitteln. Routing von einer größeren MTU zu einer kleineren MTU führt zu IP-Fragmentierung . |
| Internet IPv6 Pfad MTU | Mindestens 1280, [ 3 ] maximal 64 KiB, optionale Jumbogramme gehen bis zu 4 GiB [ 5 ] | Systeme sollten die Pfad-MTU-Erkennung [ 3 ] verwenden , um die tatsächliche Pfad-MTU zu ermitteln, sofern die minimale MTU (1280 Byte) nicht überschritten wird. Jumbo-Pakete sind Pakete mit einer Jumbo-Payload-Option , die die Übertragung von Nutzdaten mit einer Länge zwischen 65.536 und 4.294.967.295 Oktetten ermöglicht. |
| X.25 | Mindestens 576 (Senden) oder 1600 (Empfangen) [ 6 ] | |
| Ethernet v2 | 1500 [ 7 ] | Nahezu alle IP-over-Ethernet-Implementierungen verwenden das Ethernet-II-Frame-Format . |
| Ethernet mit LLC und SNAP | 1492 [ 8 ] | |
| Ethernet- Jumbo-Frames | 1501–9202 [ 9 ] oder mehr [ 10 ] | Die Beschränkung variiert je nach Hersteller. Für eine korrekte Interoperabilität sollten Frames nicht größer sein als die maximale Framegröße, die von einem Gerät im Netzwerksegment unterstützt wird . [ 11 ] |
| PPPoE v2 | 1492 [ 12 ] | Ethernet II MTU (1500) abzüglich PPPoE-Header (8); Erweiterungen vorhanden |
| DS-Lite über PPPoE | 1452 | Ethernet II MTU (1500) abzüglich PPPoE-Header (8) und IPv6-Header (40) |
| PPPoE Jumbo-Frames | 1493–9190 oder mehr [ 13 ] | Ethernet Jumbo Frame MTU (1501–9198) ohne PPPoE-Header (8) |
| IEEE 802.11 Wi-Fi (WLAN) | 2304 [ 14 ] | Die maximale MSDU-Größe beträgt vor der Verschlüsselung 2304 Byte. WEP fügt 8 Byte hinzu, WPA-TKIP 20 Byte und WPA2-CCMP 16 Byte. Siehe auch Frame-Aggregationsmechanismen in 802.11n. |
| Token Ring (802.5) | 4464 | |
| FDDI | 4352 [ 4 ] |
Maximale Rahmengröße für Ethernet
Die IP-MTU und die maximale Ethernet-Framegröße werden separat konfiguriert. Bei der Konfiguration von Ethernet-Switches kann sich die MTU auf die maximale Ethernet-Framegröße beziehen. Bei Ethernet-Routern bezieht sich die MTU normalerweise auf die IP-MTU. Wenn Jumbo-Frames in einem Netzwerk zulässig sind, sollte die IP-MTU entsprechend erhöht werden.
Da das IP-Paket in einem Ethernet-Frame übertragen wird, muss dieser größer als das IP-Paket sein. Mit dem üblichen Overhead von 18 Byte für ungetaggte Ethernet-Frames und der 1500 Byte großen Nutzlast beträgt die maximale Framegröße 1518 Byte. Soll ein 1500 Byte großes IP-Paket über eine getaggte Ethernet-Verbindung übertragen werden, muss die maximale Framegröße aufgrund der größeren Größe eines 802.1Q-getaggten Frames 1522 Byte betragen. 802.3ac erhöht die standardmäßige maximale Framegröße für Ethernet, um dies zu ermöglichen.
Pfad-MTU-Erkennung
Das Internetprotokoll definiert die Pfad-MTU eines Internet-Übertragungspfads als die kleinste MTU, die von einem der Hops auf dem Pfad zwischen Quelle und Ziel unterstützt wird. Anders ausgedrückt: Die Pfad-MTU ist die maximale Paketgröße, die diesen Pfad ohne Fragmentierung durchlaufen kann.
Path-MTU-Ermittlung ist ein Verfahren zur Bestimmung der Pfad-MTU zwischen zwei IP-Hosts und ist sowohl für IPv4 [ 4 ] als auch für IPv6 [ 15 ] definiert . Dabei werden Pakete mit der Option „Don't Fragment“ (DF) im IP-Header gesendet. Geräte auf dem Pfad, deren MTU kleiner als die des Pakets ist, verwerfen diese Pakete und senden eine ICMP-Meldung „Ziel nicht erreichbar (Datagramm zu groß)“ zurück , die ihre MTU angibt. Mithilfe dieser Information kann der Quellhost seine angenommene Pfad-MTU entsprechend reduzieren. Dieser Vorgang wird wiederholt, bis die MTU so klein ist, dass der gesamte Pfad ohne Fragmentierung durchlaufen werden kann.
Standard-Ethernet unterstützt eine MTU von 1500 Byte, und Ethernet-Implementierungen mit Jumbo-Frames ermöglichen eine MTU von bis zu 9000 Byte. Grenzprotokolle wie PPPoE reduzieren diese jedoch. Die Pfad-MTU-Erkennung deckt die Differenz zwischen der von Ethernet-Endknoten gesehenen MTU und der Pfad-MTU auf.
Leider verwerfen immer mehr Netzwerke ICMP-Datenverkehr (beispielsweise um Denial-of-Service-Angriffe zu verhindern ), was die Pfad-MTU-Ermittlung beeinträchtigt. Die Pfad-MTU-Ermittlung auf Paketierungsschicht [ 16 ] [ 17 ] ist ein Verfahren, das robuster auf ICMP-Filterung reagiert. In einem IP-Netzwerk kann sich der Pfad von der Quell- zur Zieladresse aufgrund verschiedener Ereignisse ( Lastverteilung , Überlastung , Ausfälle usw.) ändern. Dies kann dazu führen, dass sich die Pfad-MTU während einer Übertragung ändert (manchmal wiederholt), was weitere Paketverluste verursachen kann, bevor der Host eine neue, zuverlässige MTU findet.
Ein Fehler bei der Pfad-MTU-Erkennung kann dazu führen, dass einige Standorte hinter falsch konfigurierten Firewalls nicht mehr erreichbar sind. Eine Verbindung mit nicht übereinstimmender MTU kann bei geringen Datenmengen funktionieren, bricht aber ab, sobald ein Host einen großen Datenblock sendet. Beispielsweise kann ein Client bei Internet Relay Chat ( IRC) die ersten Nachrichten bis einschließlich des ersten Pings (vom Server als Anti-Spoofing-Maßnahme gesendet) empfangen, danach aber keine Antwort mehr erhalten. Dies liegt daran, dass die vielen Willkommensnachrichten, die zu diesem Zeitpunkt gesendet werden, Pakete enthalten, die die Pfad-MTU überschreiten. Je nachdem, welchen Teil des Netzwerks man kontrolliert, kann man dieses Problem möglicherweise umgehen. Beispielsweise kann man die maximale Segmentgröße (MSS) im ersten Paket, das die TCP -Verbindung an der Firewall herstellt, ändern.
In anderen Kontexten
MTU wird manchmal verwendet, um die maximale PDU-Größe in anderen Kommunikationsschichten als der Netzwerkschicht zu beschreiben.
- Cisco Systems und MikroTik verwenden L2 MTU für die maximale Framegröße. [ 18 ] [ 19 ]
- Dell / Force10 verwenden MTU für die maximale Framegröße. [ 20 ]
- Hewlett-Packard verwendete für die maximale Framegröße, einschließlich des optionalen IEEE 802.1Q- Tags, lediglich die MTU . [ 21 ]
- Juniper Networks verwendet verschiedene MTU-Begriffe: Physical Interface MTU (L3-MTU plus ein nicht näher spezifizierter Protokoll-Overhead), Logical Interface MTU (konsistent mit der IETF-MTU) und Maximum MTU (maximale konfigurierbare Framegröße für Jumbo-Frames). [ 22 ]
Die Übertragung eines Pakets in einem physischen Netzwerksegment, das größer als die MTU des Segments ist, wird als Jabber bezeichnet . Dies wird fast immer durch fehlerhafte Geräte verursacht. [ 23 ] Netzwerk-Switches und einige Repeater-Hubs verfügen über eine integrierte Funktion zur Erkennung von Jabber-Ereignissen. [ 24 ] [ 25 ]
Referenzen
- ^ a b c d J. Postel , Hrsg. (September 1981). INTERNET PROTOCOL - DARPA INTERNET PROGRAM PROTOCOL SPECIFICATION . IETF . doi : 10.17487/RFC0791 . STD 5. RFC 791. IEN 128, 123, 111, 80, 54, 44, 41, 28, 26.Internetstandard 5. Ersetzt RFC 760. Aktualisiert durch RFC 1349 , 2474 und 6864 .
- ^ Murray, David; Terry Koziniec; Kevin Lee; Michael Dixon (2012). „Große MTUs und Internet-Performance“ . 2012 IEEE 13th International Conference on High Performance Switching and Routing . S. 82–87 . doi : 10.1109/HPSR.2012.6260832 . ISBN 978-1-4577-0833-6. S2CID 232321 .
- ^ a b c S. Deering ; R. Hinden (Juli 2017). Internet Protocol, Version 6 (IPv6) Specification . Internet Engineering Task Force . doi : 10.17487/RFC8200 . STD 86. RFC 8200 .Internet Standard 86. RFC 2460 veraltet .
- ^ a b c J. Mogul; S. Deering (November 1990). Path MTU Discovery . Network Working Group. doi : 10.17487/RFC1191 . RFC 1191 .Standardentwurf. RFC 1063 ist veraltet .
- ^ D. Borman; S. Deering ; R. Hinden (August 1999). IPv6 Jumbograms . Network Working Group. doi : 10.17487/RFC2675 . RFC 2675 .Vorgeschlagener Standard. Ersetzt RFC 2147 .
- ^ A. Malis; D. Robinson; R. Ullmann (August 1992). Multiprotocol Interconnect on X.25 and ISDN in the Packet Mode . Network Working Group. doi : 10.17487/RFC1356 . RFC 1356 .Standardentwurf. RFC 877 ist veraltet .
- ^ C. Hornig (April 1984). Ein Standard für die Übertragung von IP-Datagrammen über Ethernet-Netzwerke . Network Working Group. doi : 10.17487/RFC0894 . STD 41. RFC 894 .Internetstandard 41.
- ^ IEEE 802.3
- ^ Scott Hogg (2013-03-06), Jumbo Frames , Network World , archiviert vom Original am 2013-12-19 , abgerufen am 2013-08-05 ,
Die meisten Netzwerkgeräte unterstützen eine Jumbo-Frame-Größe von 9216 Bytes.
- ^ Juniper Networks (23.03.2020), Eigenschaften der physikalischen Schnittstelle , abgerufen am 01.05.2020
- ^ Joe St Sauver (04.02.2003). „Praktische Probleme im Zusammenhang mit 9K MTUs“ (PDF) . uoregon.edu. S. 67. Abgerufen am 15.12.2016 .
Sie müssen weiterhin sicherstellen, dass ALLE vorgelagerten Ethernet-Switches, einschließlich aller Switches in Ihrem Campus-Core-Netzwerk, ebenfalls Jumbo-Frame-fähig sind.
- ^ L. Mamakos; K. Lidl; J. Evarts; D. Carrel; D. Simone; R. Wheeler (Februar 1999). Ein Verfahren zur Übertragung von PPP über Ethernet (PPPoE) . Network Working Group. doi : 10.17487/RFC2516 . RFC 2516 .Informativ.
- ^ P. Arberg; D. Kourkouzelis; M. Duckett; T. Anschutz; J. Moisand (September 2006). Berücksichtigung einer maximalen Transit-/Empfangseinheit (MTU/MRU) größer als 1492 im Point-to-Point Protocol over Ethernet (PPPoE) . Network Working Group. doi : 10.17487/RFC4638 . RFC 4638 .Informativ.
- ^ 802.11-2012, Seite 413, Abschnitt 8.3.2.1; Seite 381 „Das Frame-Body-Feld hat eine variable Größe. Die maximale Größe des Frame-Bodys wird durch die maximale MSDU-Größe (2304 Oktette) zuzüglich der Länge des Mesh-Control-Felds (6, 12 oder 18 Oktette), falls vorhanden, der maximalen unverschlüsselten MMPDU-Größe ohne MAC-Header und FCS (2304 Oktette) oder der maximalen A-MSDU-Größe (3839 oder 7935 Oktette, abhängig von den Fähigkeiten der STA) zuzüglich jeglichen Overheads durch die Sicherheitskapselung bestimmt.“
- ^ J. McCann; S. Deering ; J. Mogul (Juli 2017). R. Hinden (Hrsg.). Path MTU Discovery for IP version 6. Internet Engineering Task Force . doi : 10.17487/RFC8201 . STD 87. RFC 8201 .Internet Standard 87. RFC 1981 veraltet .
- ^ M. Mathis; J. Heffner (März 2007). Packetization Layer Path MTU Discovery . Network Working Group. doi : 10.17487/RFC4821 . RFC 4821 .Vorgeschlagener Standard. Aktualisiert durch RFC 8899 .
- ^ G. Fairhurst; T. Jones; M. Tüxen; I. Rüngeler; T. Völker (September 2020). Packetization Layer Path MTU Discovery for Datagram Transports . Internet Engineering Task Force . doi : 10.17487/RFC8899 . ISSN 2070-1721 . RFC 8899 . Vorgeschlagener Standard. Aktualisiert RFC 4821 , 4960 , 6951 , 8085 und 8261 .
- ^ „Konfigurieren und Überprüfen der maximalen Übertragungseinheit auf Cisco Nexus-Plattformen“ . Cisco. 29.11.2016. Dokument-ID: 118994. Abgerufen am 04.01.2017 .
- ^ „MTU in RouterOS“ . MikroTik. 08.07.2022 . Abgerufen am 02.09.2022 .
- ^ „Konfiguration der MTU (Maximum Transmission Unit) für Jumbo-Frames auf Dell Networking Force10 Switches“ . Dell. 02.06.2016. Artikel-ID: HOW10713 . Abgerufen am 06.01.2017 .
- ^ „Jumbo Frames“. HP Networking 2910al Switches Management and Configuration Guide . Hewlett-Packard. November 2011. P/N 5998-2874.
- ^ „SRX Series Services Gateways for the Branch Physical Interface Modules Reference: MTU Default and Maximum Values for Physical Interface Modules “ . Juniper. 03.01.2014 . Abgerufen am 04.01.2017 .
- ^ jabber , The Network Encyclopedia , abgerufen am 28.07.2016
- ^ Schnittstellen anzeigen , Juniper Networks , abgerufen am 28.07.2016
- ^ IEEE 802.3 27.3.1.7 Empfangsfunktionsanforderungen für Jabber
Externe Links
- Marc Slemko (18. Januar 1998). „Path MTU Discovery and Filtering ICMP“ . Archiviert vom Original am 9. August 2011. Abgerufen am 2. September 2007 .
- MTU/RWin-Einstellungen für Orange-Breitbandnutzer anpassen
- Wie man den TCP-MSS-Wert mit iptables festlegt
- mturoute – ein Konsolenprogramm zur Behebung von MTU-Problemen