Mobile IP (oder MIP ) ist ein von der Internet Engineering Task Force (IETF) standardisiertes Kommunikationsprotokoll , das es Nutzern mobiler Geräte ermöglicht, sich zwischen verschiedenen Netzwerken zu bewegen und dabei ihre IP-Adresse beizubehalten. Mobile IP für IPv4 ist in RFC  5944 beschrieben , Erweiterungen sind in RFC 4721 definiert . Mobile IPv6 , die IP-Mobilitätsimplementierung für die nächste Generation des Internetprotokolls IPv6 , ist in RFC 6275 beschrieben .   

Einführung

Mobile IP ermöglicht ortsunabhängiges Routing von IP-Datagrammen im Internet. Jeder mobile Knoten wird unabhängig von seinem aktuellen Standort im Internet durch seine Heimatadresse identifiziert. Befindet sich ein mobiler Knoten außerhalb seines Heimatnetzwerks, wird ihm eine Care-of- Adresse zugewiesen , die seinen aktuellen Standort angibt. Seine Heimatadresse ist dann mit dem lokalen Endpunkt eines Tunnels zu seinem Heimatagenten verknüpft . Mobile IP legt fest, wie sich ein mobiler Knoten bei seinem Heimatagenten registriert und wie der Heimatagent Datagramme über den Tunnel an den mobilen Knoten weiterleitet .

Anwendungen

In vielen Anwendungen (z. B. VPN , VoIP ) können plötzliche Änderungen der Netzwerkverbindung und der IP-Adresse Probleme verursachen. Mobile IP wurde entwickelt, um eine nahtlose und kontinuierliche Internetverbindung zu gewährleisten.

Mobile IP findet am häufigsten Anwendung in kabelgebundenen und drahtlosen Umgebungen, in denen Benutzer ihre Mobilgeräte über mehrere LAN-Subnetze hinweg nutzen müssen. Beispiele hierfür sind das Roaming zwischen sich überlappenden drahtlosen Systemen, z. B. IP über DVB , WLAN , WiMAX und BWA .

Mobile IP ist in Mobilfunksystemen wie 3G nicht erforderlich, um Transparenz beim Wechsel von Internetnutzern zwischen Mobilfunkmasten zu gewährleisten, da diese Systeme über eigene Mechanismen für die Datenverbindungsschichtübergabe und das Roaming verfügen . Es wird jedoch häufig in 3G-Systemen eingesetzt, um eine nahtlose IP-Mobilität zwischen verschiedenen Paketdatenserver- Domänen (PDSN) zu ermöglichen.

Funktionsprinzipien

Ziel der IP-Mobilität ist es, die TCP-Verbindung zwischen einem mobilen und einem stationären Host aufrechtzuerhalten und gleichzeitig die Auswirkungen von Standortänderungen während der Bewegung des mobilen Hosts zu minimieren, ohne das zugrundeliegende TCP/IP-Protokoll ändern zu müssen. [ 1 ] Zur Lösung dieses Problems sieht der RFC einen Proxy-Agenten vor, der als Vermittler zwischen dem mobilen Host und dem zugehörigen Host fungiert.

Ein mobiler Knoten verfügt über zwei Adressen – eine permanente Heimatadresse und eine Care-of-Adresse (CoA), die dem Netzwerk zugeordnet ist, in dem sich der mobile Knoten befindet. Eine Mobile-IP-Implementierung umfasst zwei Arten von Entitäten:

  • Ein Home Agent (HA) speichert Informationen über mobile Knoten, deren permanente Heimatadresse sich im Netzwerk des Home Agents befindet. Der HA fungiert als Router im Heimnetzwerk eines mobilen Hosts (MH), der Datagramme tunnelt, um sie dem MH zuzustellen, wenn dieser sich außerhalb seines Heimnetzwerks befindet, und ein Standortverzeichnis (LD) für den MH verwaltet.
  • Ein Foreign Agent (FA) speichert Informationen über mobile Knoten, die sein Netzwerk besuchen. Foreign Agents veröffentlichen außerdem Care-of-Adressen, die von Mobile IP verwendet werden. Befindet sich kein Foreign Agent im Host-Netzwerk, muss das mobile Gerät selbst eine Adresse beziehen und diese veröffentlichen. Der FA fungiert als Router im besuchten Netzwerk eines mobilen Geräts (MH) und stellt diesem Routing-Dienste bereit, solange er registriert ist. Der FA detunnelt die vom HA des MH getunnelten Datagramme und stellt sie dem MH zu.

Die sogenannte Care of Address ist ein Endpunkt eines Tunnels zu einem MH für Datagramme, die an den MH weitergeleitet werden, während dieser sich nicht zu Hause befindet.

  • Adresse des ausländischen Vertreters: die Adresse eines ausländischen Vertreters, bei dem MH registriert ist
  • Mitbetreute Adresse: eine extern bezogene lokale Adresse, die eine Einrichtung für psychische Gesundheit erhält.

Ein mobiler Knoten (MN) ist dafür verantwortlich, festzustellen, ob er mit seinem Heimnetzwerk verbunden ist oder sich in einem fremden Netzwerk befindet. Heimnetzwerk- (HA) und Fremdnetzwerk-Komponenten (FA) senden ihre Anwesenheit in jedem Netzwerk, mit dem sie verbunden sind. Sie sind nicht allein für die Erkennung zuständig , sondern spielen lediglich eine Rolle. RFC 2002 legte fest, dass MN die Agentenerkennung nutzen, um diese Entitäten zu lokalisieren. Bei Verbindung mit einem fremden Netzwerk muss ein MN die von jedem ausländischen Agenten im Netzwerk angebotene Care-of-Address ermitteln.  

Ein Knoten, der mit dem mobilen Knoten kommunizieren möchte, verwendet dessen permanente Heimadresse als Zieladresse für den Versand von Datenpaketen. Da die Heimadresse logisch zum Netzwerk des Heimknotens gehört, leiten normale IP-Routing-Mechanismen diese Pakete an den Heimknoten weiter. Anstatt die Pakete an ein Ziel im selben Netzwerk wie der Heimknoten weiterzuleiten, leitet der Heimknoten sie über einen IP-Tunnel an die Zieladresse um , indem er das Datagramm mit einem neuen IP-Header unter Verwendung der Care-of-Adresse des mobilen Knotens kapselt.

Wenn ein mobiler Knoten als Sender fungiert, sendet er Pakete direkt an den anderen Kommunikationsknoten, ohne sie über den Home Agent zu leiten. Dabei verwendet er seine permanente Home-Adresse als Quelladresse für die IP-Pakete. Dies wird als Dreiecksrouting oder „Route Optimization“-Modus (RO) bezeichnet. Bei Bedarf kann der Foreign Agent Reverse Tunneling nutzen , indem er die Pakete des mobilen Knotens zum Home Agent tunnelt, der sie dann an den Kommunikationsknoten weiterleitet. Dies ist in Netzwerken erforderlich, deren Gateway-Router prüfen, ob die Quell-IP-Adresse des mobilen Hosts zu ihrem Subnetz gehört, oder das Paket andernfalls verwerfen. In Mobile IPv6 (MIPv6) ist Reverse Tunneling das Standardverhalten, während RO optional ist.

Entwicklung

Erweiterungen der Mobile IP-Technik, wie Mobile IPv6 [ 2 ] und Hierarchical Mobile IPv6 (HMIPv6), die in RFC 5380 [ 3 ] definiert sind, werden entwickelt, um die mobile Kommunikation unter bestimmten Umständen zu verbessern , indem die Prozesse sicherer und effizienter gestaltet werden.  

Schnelle Handover für Mobile IPv6 werden in RFC 5568 beschrieben .  

Forscher entwickeln Unterstützung für mobile Netzwerke, ohne dass – wie bei MIP – eine vorab bereitgestellte Infrastruktur erforderlich ist. Ein Beispiel hierfür ist das Interactive Protocol for Mobile Networking (IPMN), das Mobilität in einem herkömmlichen IP-Netzwerk bereits an den Netzwerkrändern durch intelligente Signalisierung zwischen IP-Endpunkten und Anwendungsschichtmodulen mit verbesserter Dienstqualität ermöglicht.

Forscher arbeiten zudem an der Entwicklung von Unterstützung für mobile Netzwerke zwischen ganzen Subnetzen mithilfe von Mobile IPv6. Ein Beispiel hierfür ist das Network Mobility Basic Support Protocol (NEMO) der IETF Network Mobility Working Group. NEMO ermöglicht die Mobilität ganzer mobiler Netzwerke, die sich bewegen und an verschiedene Punkte im Internet anbinden können. Das Protokoll ist eine Erweiterung von Mobile IPv6 und gewährleistet die Sitzungskontinuität für jeden Knoten im mobilen Netzwerk während dessen Bewegung.

Änderungen in IPv6 für mobiles IPv6

  • Eine Reihe von Mobilitätsoptionen, die in Mobilitätsmitteilungen aufgenommen werden sollen
  • Eine neue Option „Heimatadresse“ für die Kopfzeile „Zieloptionen“
  • Ein neuer Routing-Header vom Typ 2
  • Neue ICMPv6-Nachrichten (Internet Control Message Protocol for IPv6) zur Ermittlung der Heimnetzwerkagenten und zum Abrufen des Präfixes der Heimnetzwerkverbindung
  • Änderungen an Router-Erkennungsnachrichten und -optionen sowie zusätzliche Optionen zur Nachbarerkennung
  • Ausländische Agenten werden nicht mehr benötigt.

Definition der Begriffe

Heimnetzwerk
Das Heimnetzwerk eines Mobilgeräts ist das Netzwerk, in dem das Gerät seine identifizierende IP-Adresse (Heimadresse) empfängt.
Heimatadresse
Die Heimadresse eines Mobilgeräts ist die IP-Adresse, die dem Gerät innerhalb seines Heimnetzwerks zugewiesen ist.
Ausländisches Netzwerk
Ein Fremdnetzwerk ist das Netzwerk, in dem ein mobiler Knoten außerhalb seines Heimatnetzwerks operiert.
Care-of-Adresse
Die Care-of-Adresse eines Mobilgeräts ist die netzwerknative IP-Adresse des Geräts, wenn es in einem fremden Netzwerk betrieben wird.
Immobilienmakler
Ein Home Agent ist ein Router im Heimnetzwerk eines Mobilgeräts, der Datagramme tunnelt, um sie dem Mobilgerät zuzustellen, wenn dieses sich außerhalb des Heimnetzwerks befindet. Er verwaltet die aktuellen Standortinformationen (IP-Adresse) des Mobilgeräts. Er wird mit einem oder mehreren Foreign Agents verwendet.
Ausländischer Agent
Ein Foreign Agent ist ein Router, der Informationen über mobile Knoten speichert, die sein Netzwerk besuchen. Foreign Agents veröffentlichen außerdem Care-of-Addresses, die von Mobile IP verwendet werden.
Bindung
Eine Bindung ist die Verknüpfung der Wohnadresse mit einer Care-Adresse.

Siehe auch

Referenzen

  1. ^ Internetprotokoll
  2. ^ X. Pérez-Costa und H. Hartenstein. Eine Simulationsstudie zur Leistungsfähigkeit von Mobile IPv6 in einem WLAN-basierten Mobilfunknetz. Elsevier Computer Networks Journal, Sonderausgabe zur neuen Internetarchitektur, September 2002.
  3. ^ X.Pérez-Costa, M.Torrent-Moreno und H.Hartenstein. Eine Simulationsstudie zur Leistungsfähigkeit von hierarchischem mobilem IPv6. Archiviert am 06.03.2012 bei der Wayback Machine. In: Proceedings of the International Teletraffic Congress (ITC), Berlin, Deutschland, August 2003.