| Kommunikationsprotokoll | |
| Einführung | 1999 |
|---|---|
| RFCs | 2740 , 5340 , 6845 , 6860 , 7503 , 8362 ... |
Open Shortest Path First ( OSPF ) ist ein Routing-Protokoll für Internet-Protokoll (IP)-Netzwerke. Es verwendet einen Link-State-Routing- Algorithmus (LSR) und gehört zur Gruppe der Interior Gateway Protocols (IGPs), die innerhalb eines einzelnen autonomen Systems (AS) operieren .
OSPF sammelt Link-State-Informationen von verfügbaren Routern und erstellt eine Topologiekarte des Netzwerks. Diese Topologie wird der Internetschicht als Routingtabelle zur Verfügung gestellt , um Pakete anhand ihrer Ziel- IP-Adresse weiterzuleiten . OSPF unterstützt IPv4- und IPv6 -Netzwerke und ist in großen Unternehmensnetzwerken weit verbreitet . IS-IS , ein weiteres LSR-basiertes Protokoll, findet häufiger Anwendung in großen Dienstanbieternetzwerken .
OSPF Version 2, ursprünglich in den 1980er Jahren entwickelt, ist in RFC 2328 (1998) definiert. [ 1 ] Die Aktualisierungen für IPv6 sind als OSPF Version 3 in RFC 5340 (2008) spezifiziert. [ 2 ] OSPF unterstützt das CIDR-Adressierungsmodell ( Classless Inter-Domain Routing ).
| Internetprotokollfamilie |
|---|
| Anwendungsschicht |
| Transportschicht |
| Internetschicht |
| Verbindungsschicht |
Konzepte
OSPF ist ein Interior Gateway Protocol (IGP) zum Routing von IP-Paketen innerhalb einer einzelnen Routing-Domäne, beispielsweise eines autonomen Systems . Es sammelt Link-State-Informationen von verfügbaren Routern und erstellt eine Topologiekarte des Netzwerks. Diese Topologie wird der Internetschicht als Routing-Tabelle präsentiert , welche die Pakete ausschließlich anhand ihrer Ziel- IP-Adresse weiterleitet .
OSPF erkennt Änderungen in der Netzwerktopologie, wie z. B. Verbindungsabbrüche, und konvergiert innerhalb von Sekunden zu einer neuen, schleifenfreien Routingstruktur. [ 3 ] Es berechnet den kürzesten Pfadbaum für jede Route mithilfe eines auf dem Dijkstra-Algorithmus basierenden Verfahrens . Die OSPF-Routingrichtlinien für die Erstellung einer Routingtabelle werden durch die Verbindungsmetriken der jeweiligen Routing-Schnittstelle bestimmt . Kostenfaktoren können die Entfernung eines Routers ( Umlaufzeit ), der Datendurchsatz einer Verbindung oder die Verfügbarkeit und Zuverlässigkeit einer Verbindung sein, ausgedrückt als einfache, dimensionslose Zahlen. Dies ermöglicht einen dynamischen Lastausgleich zwischen Routen mit gleichen Kosten.
OSPF unterteilt das Netzwerk in Routing- Bereiche , um die Administration zu vereinfachen und die Nutzung von Datenverkehr und Ressourcen zu optimieren. Bereiche werden durch 32-Bit-Zahlen identifiziert, die entweder einfach dezimal oder häufig in der gleichen Oktett-basierten Punktdezimalnotation wie IPv4-Adressen dargestellt werden. Konventionsgemäß repräsentiert Bereich 0 (Null) oder 0.0.0.0 den Kern- oder Backbone- Bereich eines OSPF-Netzwerks. Während die Kennungen anderer Bereiche frei gewählt werden können, verwenden Administratoren häufig die IP-Adresse eines Hauptrouters in einem Bereich als Bereichskennung. Jeder weitere Bereich muss mit dem OSPF-Backbone-Bereich verbunden sein. Diese Verbindungen werden von einem Verbindungsrouter, dem sogenannten Bereichsgrenzrouter (ABR), verwaltet. Ein ABR verwaltet separate Link-State-Datenbanken für jeden von ihm bedienten Bereich und speichert zusammengefasste Routen für alle Bereiche im Netzwerk.
OSPF läuft über IPv4 und IPv6, verwendet aber kein Transportprotokoll wie UDP oder TCP . Es kapselt seine Daten direkt in IP-Pakete mit der Protokollnummer 89. Dies steht im Gegensatz zu anderen Routing-Protokollen wie dem Routing Information Protocol (RIP) und dem Border Gateway Protocol (BGP). OSPF implementiert eigene Funktionen zur Erkennung und Korrektur von Transportfehlern. OSPF verwendet außerdem Multicast- Adressierung zur Verteilung von Routeninformationen innerhalb einer Broadcast-Domäne. Es reserviert die Multicast-Adressen 224.0.0.5 (IPv4) und ff02::5 (IPv6) für alle SPF/Link-State-Router (AllSPFRouters) sowie 224.0.0.6 (IPv4) und ff02::6 (IPv6) für alle Designated Router (AllDRouters). [ 1 ] : 185 [ 2 ] : 57 Für Nicht-Broadcast-Netzwerke erleichtern spezielle Konfigurationsvorkehrungen die Nachbarerkennung. [ 1 ] OSPF-Multicast-IP-Pakete durchlaufen niemals IP-Router und legen nie mehr als einen Hop zurück. Das Protokoll kann daher als Sicherungsschichtprotokoll betrachtet werden, wird aber im TCP/IP-Modell häufig auch der Anwendungsschicht zugeordnet. Es verfügt über eine virtuelle Verbindungsfunktion, mit der ein Adjazenztunnel über mehrere Hops hinweg erstellt werden kann. OSPF über IPv4 kann sicher zwischen Routern arbeiten und optional verschiedene Authentifizierungsmethoden nutzen, um nur vertrauenswürdigen Routern die Teilnahme am Routing zu ermöglichen. OSPFv3 (IPv6) basiert auf der Standard-IPv6-Protokollsicherheit ( IPsec ) und verfügt über keine internen Authentifizierungsmethoden.
Für das Routing von IP-Multicast -Verkehr unterstützt OSPF das Multicast Open Shortest Path First (MOSPF)-Protokoll. [ 4 ] Cisco implementiert MOSPF nicht in seinen OSPF-Lösungen. [ 5 ] Protocol Independent Multicast (PIM) wird in Verbindung mit OSPF oder anderen IGPs häufig eingesetzt.
OSPF Version 3 führt Modifikationen an der IPv4-Implementierung des Protokolls ein. [ 2 ] Mit Ausnahme virtueller Verbindungen verwenden alle Nachbaraustausche ausschließlich IPv6-Link-Local-Adressierung. Das IPv6-Protokoll läuft pro Verbindung und nicht mehr subnetzbasiert . Sämtliche IP-Präfixinformationen wurden aus den Link-State-Advertisements und dem Hello- Discovery-Paket entfernt, wodurch OSPFv3 im Wesentlichen protokollunabhängig ist. Trotz der Erweiterung der IP-Adressierung auf 128 Bit in IPv6 basieren Area- und Router-IDs weiterhin auf 32-Bit-Zahlen.
Router-Beziehungen
| Netzwerktyp | Punkt-zu-Punkt (P2P) | Broadcast (Standard) | Nicht-Rundfunk-Mehrfachzugriff (NBMA) | Punkt zu Mehrpunkt | Punkt-zu-Mehrpunkt-Verbindung ohne Broadcast (P2MP-NB) | Passiv |
|---|---|---|---|---|---|---|
| Maximale Anzahl Router pro Netzwerk | 2 | Unbegrenzt | Unbegrenzt | Unbegrenzt | Unbegrenzt | n / A |
| Vollständiges Netz angenommen | Ja | Ja | Ja | NEIN | NEIN | n / A |
| Hallo-Timer (Standard Cisco) | 10 | 10 | 30 | 30 | 30 | n / A |
| Dead-Timer (Standard Cisco) | 40 | 40 | 120 | 120 | 120 | n / A |
| Wartezeit | 0 | gleich dem Totzeitgeber | gleich dem Totzeitgeber | 0 | 0 | n / A |
| Automatische Nachbarerkennung | Ja | Ja | NEIN | Ja | NEIN | n / A |
| Discovery- und Hello-Nachrichten werden gesendet an | 224.0.0.5 | 224.0.0.5 | Nachbar-IP | 224.0.0.5 | Nachbar-IP | n / A |
| Die Nachbarschaftskommunikation wird gesendet an | 224.0.0.5 | Unicast | Unicast | Unicast | Unicast | n / A |
| LSAs werden gesendet an | 224.0.0.5 | DR/BDR: 224.0.0.6 Alle: 224.0.0.5 | DR/BDR: 224.0.0.6 Alle: 224.0.0.5 | Unicast | Unicast | n / A |
| Nächster Hop IP | Peer | Originalrouter | Originalrouter | Nabe | Nabe | n / A |
| In OSPF importiert als | Stub und P2P | Transit | Transit | Stub und P2P | Stub und P2P | Stub |
OSPF unterstützt komplexe Netzwerke mit mehreren Routern, einschließlich Backup-Routern, um die Verkehrslast auf mehreren Verbindungen zu anderen Subnetzen auszugleichen. Benachbarte Router in derselben Broadcast-Domäne oder an den Enden einer Punkt-zu-Punkt-Verbindung kommunizieren über das OSPF-Protokoll. Router bilden Nachbarschaften, sobald sie einander erkannt haben. Diese Erkennung erfolgt, wenn sich ein Router in einem Hello -Paket identifiziert. Nach der Bestätigung wird ein bidirektionaler Zustand und die grundlegendste Beziehung hergestellt. Die Router in einem Ethernet- oder Frame-Relay- Netzwerk wählen einen Designated Router (DR) und einen Backup Designated Router (BDR) aus, die als Hubs fungieren, um den Datenverkehr zwischen den Routern zu reduzieren. OSPF verwendet sowohl Unicast- als auch Multicast-Übertragungsmodi, um Hello-Pakete und Link-State-Updates zu senden.
Als Link-State-Routingprotokoll etabliert und pflegt OSPF Nachbarschaftsbeziehungen zum Austausch von Routing-Updates mit anderen Routern. Die Tabelle der Nachbarschaftsbeziehungen wird als Adjazenzdatenbank bezeichnet . Zwei OSPF-Router sind Nachbarn, wenn sie demselben Subnetz angehören und dieselbe Bereichs-ID, Subnetzmaske, Timer und Authentifizierung verwenden. Im Wesentlichen ermöglicht die OSPF-Nachbarschaft zwei Routern, einander zu sehen und zu verstehen, aber nicht mehr. OSPF-Nachbarn tauschen keine Routing-Informationen aus – die einzigen ausgetauschten Pakete sind Hello-Pakete. OSPF-Adjazenzen werden zwischen ausgewählten Nachbarn gebildet und ermöglichen ihnen den Austausch von Routing-Informationen. Zwei Router müssen zunächst Nachbarn sein, bevor sie adjazent werden können. Zwei Router werden adjazent, wenn mindestens einer von ihnen Designated Router oder Backup Designated Router (in Multiaccess-Netzwerken) ist oder wenn sie über eine Punkt-zu-Punkt- oder Punkt-zu-Mehrpunkt-Verbindung miteinander verbunden sind. Für die Bildung einer Nachbarschaftsbeziehung zwischen den Schnittstellen muss sich die Beziehung im selben OSPF-Bereich befinden. Eine Schnittstelle kann zwar mehreren Bereichen zugeordnet werden, dies ist jedoch unüblich. Wird sie in einem zweiten Bereich konfiguriert, muss sie als sekundäre Schnittstelle eingerichtet werden.
Betriebsarten
OSPF kann auf einer Schnittstelle oder einem Netzwerk in den folgenden Konfigurationen unterschiedliche Betriebsmodi aufweisen:
- Punkt-zu-Punkt-Verbindung . Jeder Router macht sich durch periodisches Senden von Hello-Paketen per Multicast bemerkbar. Es wird kein designierter Router gewählt. Die Schnittstelle kann IP-unnummeriert sein (ohne zugewiesene eindeutige IP-Adresse).
- Broadcast (Standardeinstellung): Jeder Router macht sich durch periodisches Multicasten von Hello-Paketen bemerkbar.
- Nicht-Broadcast-Mehrfachzugriff mit Verwendung dedizierter Router. Eine statische Konfiguration kann erforderlich sein. Pakete werden als Unicast gesendet .
- Bei der Punkt-zu-Mehrpunkt-Verbindung behandelt OSPF Nachbarn als eine Sammlung von Punkt-zu-Punkt-Verbindungen. Es wird kein designierter Router gewählt. An jeden Nachbarn werden separate Hello-Pakete gesendet.
- Bei Point-to-Multipoint Non-Broadcast (P2MP-NB) wird kein designierter Router gewählt. Separate Hello-Pakete werden an jeden Nachbarn gesendet. Die Pakete werden als Unicast übertragen .
- Passiv, wird nur anderen Nachbarn mitgeteilt. Es wird keine Nachbarschaft im Netzwerk bekannt gegeben.
Indirekte Verbindungen
Virtuelle Verbindungen über virtuelle Verbindungen, Tunneling und Scheinverbindungen sind eine Form von Verbindungen, die über die Routing-Engine laufen und keine direkte Verbindung zum Remote-Host darstellen.
- Virtuelle Verbindungen: Die Pakete werden als Unicast gesendet . Sie können nur in Nicht-Backbone-Bereichen (jedoch nicht in Stub-Bereichen) konfiguriert werden. Die Endpunkte müssen ABRs sein; die virtuellen Verbindungen verhalten sich wie unnummerierte Punkt-zu-Punkt-Verbindungen. Die Kosten eines Intra-Area-Pfads zwischen den beiden Routern werden der Verbindung hinzugefügt.
- Virtuelle Verbindung über Tunneling (wie GRE und WireGuard ): Da OSPF virtuelle Verbindungen für Bereiche außerhalb des Backbones nicht unterstützt, bietet sich die Verwendung von Tunneling als Alternative an. [ 6 ] Bei Verwendung derselben IP-Adresse oder Router-ID erzeugt die Verbindung zwei gleichwertige Routen zum Ziel. [ 7 ]
- Scheinverbindung [ 8 ] : [ 9 ] [ 10 ] Eine Intra-Area-Verbindung, die zwei Standorte über das MPLS-VPN-Backbone verbindet und einer internen Intra-Area-„OSPF-Backdoor-Verbindung“ zwischen denselben beiden Standorten vorzuziehen ist. Eine Scheinverbindung ist nur erforderlich, wenn das MPLS-VPN-Backbone der OSPF-Backdoor-Verbindung vorgezogen wird.
Adjazenz-Zustandsautomat
Jeder OSPF-Router innerhalb eines Netzwerks kommuniziert über jede Verbindungsschnittstelle mit anderen benachbarten Routern, um den Zustand aller Nachbarschaften zu ermitteln. Jede dieser Kommunikationssequenzen stellt eine separate Konversation dar , die durch das Router-ID-Paar der kommunizierenden Nachbarn identifiziert wird. RFC 2328 spezifiziert das Protokoll zum Initiieren dieser Konversationen ( Hello-Protokoll ) und zum Aufbau vollständiger Nachbarschaften ( Datenbankbeschreibungspakete , Link-State-Anforderungspakete ). Im Verlauf durchläuft jede Router-Konversation maximal acht Zustände, die durch einen Zustandsautomaten definiert sind: [ 1 ] [ 11 ]
Änderungen der Nachbarstaaten

- Down: Der Zustand „ down“ repräsentiert den Ausgangszustand einer Konversation, wenn zwischen den Routern mit dem Hello-Protokoll noch keine Informationen ausgetauscht und gespeichert wurden.
- Versuch: Der Versuchszustand ist dem Ausfallzustand ähnlich , mit der Ausnahme, dass sich ein Router in diesem Zustand bemüht, eine Verbindung zu einem anderen Router herzustellen. Er wird jedoch nur in Nicht-Broadcast-Mehrfachzugriffsnetzen (NBMAs) verwendet.
- Init: Der Init- Status zeigt an, dass ein Hello-Paket von einem Nachbarn empfangen wurde, der Router aber noch keine bidirektionale Verbindung hergestellt hat.
- Zwei-Wege-Betrieb: Der Zwei-Wege -Betrieb signalisiert den Aufbau einer bidirektionalen Kommunikation zwischen zwei Routern. Dieser Zustand geht dem Aufbau einer Nachbarschaft unmittelbar voraus. Dies ist der niedrigste Zustand eines Routers, der als DR (Distributed Remote Router) in Betracht gezogen werden kann.
Datenbankaustausch

- Exchange start (exstart): Der exstart- Zustand ist der erste Schritt der Adjazenz zweier Router.
- Austausch: Im Austauschzustand sendet ein Router seine Link-State-Datenbankinformationen an den benachbarten Router. In diesem Zustand kann ein Router alle OSPF-Routing-Protokollpakete austauschen.
- Laden: Im Ladezustand fordert ein Router die neuesten Link-State-Advertisements (LSAs) von seinen Nachbarn an, die im vorherigen Zustand gefunden wurden.
- Vollständig: Der vollständige Status beendet die Kommunikation, sobald die Router vollständig benachbart sind und der Status in allen Router- und Netzwerk-LSAs angezeigt wird. Die Link-State-Datenbanken der Nachbarn sind vollständig synchronisiert.
Rundfunknetze
In Broadcast-Mehrfachzugriffsnetzen wird die Nachbarschaftsbeziehung dynamisch durch Multicast-Hello-Pakete an 224.0.0.5 hergestellt .
IP 192.0.2.1 > 224.0.0.5: OSPFv2, hallo IP 192.0.2.2 > 224.0.0.5: OSPFv2, hallo IP 192.0.2.1 > 192.0.2.2: OSPFv2, Datenbankbeschreibung IP 192.0.2.2 > 192.0.2.1: OSPFv2, Datenbankbeschreibung
Passives Netzwerk
Ein Netzwerk, in dem OSPF das Netzwerk ankündigt, aber OSPF keine Nachbarschaftsbeziehung aufbaut.
Nicht-Rundfunknetze
In einem Non-Broadcast Multiple-Access (NBMA)-Netzwerk wird eine Nachbarschaft durch das Senden von Unicast -Paketen an einen anderen Router hergestellt. Ein NBMA-Netzwerk kann mehr als zwei Router umfassen, Broadcast wird jedoch nicht unterstützt.
IP 192.0.2.1 > 192.0.2.2: OSPFv2, hallo IP 192.0.2.2 > 192.0.2.1: OSPFv2, hallo IP 192.0.2.1 > 192.0.2.2: OSPFv2, Datenbankbeschreibung IP 192.0.2.2 > 192.0.2.1: OSPFv2, Datenbankbeschreibung
Beispiele für nicht-öffentliche Netzwerke:
- Erfordert, dass alle Router im selben Netzwerk direkt miteinander kommunizieren können.
- Ein designierter Router wird für das Netzwerk ausgewählt.
- LSA wird für das Netzwerk generiert.
OSPF-Gebiete
Ein Netzwerk ist in OSPF- Bereiche unterteilt , die logische Gruppierungen zusammenhängender Hosts und Netzwerke darstellen. Jeder Bereich umfasst seinen Verbindungsrouter und verfügt über eine Schnittstelle für jede verbundene Netzwerkverbindung. Jeder Router verwaltet eine separate Link-State-Datenbank für den Bereich, deren Informationen vom Verbindungsrouter für das restliche Netzwerk zusammengefasst werden können. Dadurch ist die Topologie eines Bereichs außerhalb des Bereichs unbekannt. Dies reduziert den Routing-Verkehr zwischen den Teilen eines autonomen Systems.
Obwohl OSPF Tausende von Routern verwalten kann, besteht die Sorge, dass die Kapazität der Forwarding Information Base (FIB)-Tabelle bei Netzwerken mit vielen Routen und leistungsschwächeren Geräten an ihre Grenzen stößt. [ 12 ] Moderne Low-End-Router verfügen über ein ganzes Gigabyte RAM [ 13 ] , wodurch sie viele Router in einem Bereich 0 verwalten können. Viele Quellen [ 14 ] verweisen auf OSPF-Leitfäden von vor über 20 Jahren, in denen 64 MB RAM noch als beeindruckend galten.
Bereiche werden eindeutig durch 32-Bit-Zahlen identifiziert. Die Bereichskennungen werden üblicherweise in der von IPv4 bekannten Punktdezimalschreibweise dargestellt. Es handelt sich jedoch nicht um IP-Adressen, und sie können ohne Konflikt mit beliebigen IPv4-Adressen übereinstimmen. Die Bereichskennungen für IPv6-Implementierungen (OSPFv3) verwenden ebenfalls 32-Bit-Kennungen in derselben Notation. Wird die Punktnotation weggelassen, erweitern die meisten Implementierungen Bereich 1 zur Bereichskennung 0.0.0.1 , einige jedoch zu 1.0.0.0 .
Mehrere Anbieter ( Cisco , Allied Telesis , Juniper , Alcatel-Lucent , Huawei , Quagga) implementieren Totally Stubby Area und NSSA Totally Stubby Area für Stub- und Not-So-Stubby-Bereiche. Obwohl sie nicht in den RFC-Standards abgedeckt sind, gelten sie für viele als Standardfunktionen in OSPF-Implementierungen.
OSPF definiert mehrere Bereichstypen:
- Rückgrat
- Nicht-Backbone/regulär
- Stub
- Total stämmig
- Nicht so stämmig
- Überhaupt nicht so stämmig
- Transit
Rückgratbereich

Der Backbone-Bereich (auch als Bereich 0 oder Bereich 0.0.0.0 bezeichnet ) bildet den Kern eines OSPF-Netzwerks. Alle anderen Bereiche sind entweder direkt oder über andere Router mit ihm verbunden. OSPF erfordert dies, um Routing-Schleifen zu verhindern . [ 15 ] Das Inter-Area-Routing erfolgt über Router, die mit dem Backbone-Bereich und ihren jeweiligen zugehörigen Bereichen verbunden sind. Er bildet die logische und physische Struktur der OSPF-Domäne und ist allen Bereichen ungleich Null in der OSPF-Domäne zugeordnet. Der Begriff „Autonomous System Boundary Router“ (ASBR) ist in OSPF historisch bedingt, da mehrere OSPF-Domänen im selben, für das Internet sichtbaren autonomen System koexistieren können (RFC 1996). [ 16 ] [ 17 ]
Alle OSPF-Bereiche müssen mit dem Backbone-Bereich verbunden sein. Diese Verbindung kann jedoch über eine virtuelle Verbindung erfolgen. Angenommen, Bereich 0.0.0.1 hat eine physische Verbindung zu Bereich 0.0.0.0. Weiterhin angenommen, Bereich 0.0.0.2 hat keine direkte Verbindung zum Backbone, aber eine Verbindung zu Bereich 0.0.0.1. Bereich 0.0.0.2 kann eine virtuelle Verbindung über den Transitbereich 0.0.0.1 nutzen, um das Backbone zu erreichen. Damit ein Bereich als Transitbereich fungieren kann, muss er das Transit-Attribut besitzen und darf daher keinesfalls unvollständig sein.
Regelbereich

Ein regulärer Bereich ist ein Nicht-Backbone-Bereich (ungleich Null) ohne spezifische Merkmale, der zusammenfassende und externe LSAs generiert und empfängt. Der Backbone-Bereich ist ein spezieller Typ eines solchen Bereichs.
Stubbenbereich

- In Hello-Paketen ist das E-Flag nicht gesetzt , was bedeutet: „Externes Routing: nicht möglich“.
Ein Stub-Bereich empfängt keine Routenankündigungen von außerhalb des autonomen Systems (AS). Das Routing innerhalb dieses Bereichs basiert ausschließlich auf einer Standardroute . Ein ABR (Advanced Router Branch) löscht LSAs der Typen 4 und 5 von internen Routern, sendet ihnen die Standardroute 0.0.0.0 und fungiert selbst als Standardgateway . Dadurch werden die Größe der LSDB (Low-Stake Database) und der Routingtabelle für interne Router reduziert.
Modifikationen des Grundkonzepts der Stub-Area wurden von Systemanbietern implementiert, wie beispielsweise die Totally Stubby Area (TSA) und die Not-So-Stubby Area (NSSA), beides Erweiterungen in Routing-Geräten von Cisco Systems .
Völlig stummeliger Bereich

Ein vollständig eingeschränkter Bereich ähnelt einem Stub-Bereich. Im Gegensatz zu diesem Bereich sind jedoch keine Zusammenfassungsrouten und keine externen Routen möglich; das heißt, Inter-Area -Routen (IA-Routen) werden in vollständig eingeschränkten Bereichen nicht zusammengefasst. Der Datenverkehr kann den Bereich nur über eine Standardroute verlassen, die als einzige Typ-3-LSA im Bereich angekündigt wird. Da nur eine Route aus dem Bereich herausführt, muss der Routenprozessor weniger Routing-Entscheidungen treffen, was die Systemressourcenauslastung reduziert.
- Vereinzelt wird behauptet, dass ein TSA nur einen ABR haben kann. [ 18 ]
Nicht so stämmiger Bereich

- In Hello-Paketen ist das N-Flag auf HIGH gesetzt , was bedeutet: „NSSA: unterstützt“.
Ein nicht so stubby Bereich (NSSA) ist eine Art Stub-Bereich, der externe Routen autonomer Systeme importieren und an andere Bereiche senden kann, aber dennoch keine externen Routen autonomer Systeme von anderen Bereichen empfangen kann. [ 19 ]
NSSA ist eine Erweiterung der Stub-Area-Funktion, die das eingeschränkte Einfügen externer Routen in die Stub-Area ermöglicht. Eine Fallstudie simuliert eine NSSA, die das Stub-Area-Problem des fehlenden Imports externer Adressen umgeht. Sie visualisiert folgende Aktivitäten: Der ASBR importiert externe Adressen mit einem Typ-7-LSA, der ABR konvertiert ein Typ-7-LSA in Typ-5-LSA und leitet es an andere Areas weiter, der ABR fungiert für diese Areas als ASBR. Die ASBRs nehmen keine Typ-5-LSAs entgegen und konvertieren diese nicht in Typ-7-LSAs für die Area.
Gänsehaut gar nicht so kurze Bereich

Zusätzlich zur Standardfunktionalität einer NSSA übernimmt die „Totally Stubby“-NSSA die Attribute einer TSA. Das bedeutet, dass zusammenfassende Routen vom Typ 3 und 4 in diesem Bereich nicht geflutet werden. Es ist auch möglich, einen Bereich sowohl als „Totally Stubby“ als auch als „Not-So-Stubby“ zu deklarieren. Letzteres bedeutet, dass der Bereich nur die Standardroute von Bereich 0.0.0.0 empfängt, aber zusätzlich einen autonomen Systemgrenzrouter (ASBR) enthalten kann. Dieser ASBR empfängt externe Routing-Informationen und leitet sie in den lokalen Bereich sowie von dort in Bereich 0.0.0.0 weiter.
- Die Redistribution in einen NSSA-Bereich erzeugt einen speziellen LSA-Typ, bekannt als Typ 7, der nur in einem NSSA-Bereich existieren kann. Ein NSSA-ASBR generiert diesen LSA, und ein NSSA-ABR-Router übersetzt ihn in einen LSA vom Typ 5, der dann in die OSPF-Domäne propagiert wird.
Eine neu erworbene Tochtergesellschaft ist ein Beispiel dafür, wo es sinnvoll sein kann, einen Bereich gleichzeitig nicht so stubby und vollständig stubby zu gestalten, wenn der optimale Standort für einen ASBR am Rand eines vollständig stubby Bereichs liegt. In diesem Fall sendet der ASBR externe Routen in den vollständig stubby Bereich, wo sie für OSPF-Router verfügbar sind. In der Cisco-Implementierung können die externen Routen zusammengefasst werden, bevor sie in den vollständig stubby Bereich eingespeist werden. Generell sollte der ASBR keine Standardrouten im TSA-NSSA ankündigen, obwohl dies bei äußerst sorgfältiger Planung und Durchführung in den wenigen Sonderfällen, in denen eine solche Ankündigung sinnvoll ist, funktionieren kann.
Durch die Deklaration des gesamten Kurzstreckenbereichs als NSSA gelangen keine externen Routen vom Backbone, mit Ausnahme der Standardroute, in diesen Bereich. Externe Routen erreichen zwar den Bereich 0.0.0.0 über die TSA-NSSA, jedoch gelangen keine anderen Routen als die Standardroute in die TSA-NSSA. Router in der TSA-NSSA leiten den gesamten Datenverkehr an den ABR weiter, außer an Routen, die vom ASBR angekündigt werden.
Routertypen
OSPF definiert die folgenden sich überschneidenden Kategorien von Routern:
- Interner Router (IR)
- Bei einem internen Router gehören alle seine Schnittstellen demselben Bereich an.
- Area Border Router (ABR)
- Ein Area Border Router ( ABR) ist ein Router, der einen oder mehrere Bereiche mit dem Hauptnetzwerk verbindet. Er gilt als Mitglied aller Bereiche, mit denen er verbunden ist. Ein ABR speichert mehrere Instanzen der Link-State-Datenbank im Speicher, eine für jeden Bereich, mit dem er verbunden ist.
- Backbone-Router (BR)
- Ein Backbone-Router verfügt über eine Schnittstelle zum Backbone-Bereich. Backbone-Router können auch als Bereichsgrenzrouter fungieren, müssen es aber nicht.
- Autonomer Systemgrenzrouter (ASBR)
- Ein autonomer Systemgrenzrouter (ASBR) ist ein Router, der über mehrere Routing-Protokolle verbunden ist und Routing-Informationen mit Routern in anderen autonomen Systemen austauscht. ASBRs verwenden typischerweise auch ein externes Routing-Protokoll (z. B. BGP ) oder statische Routen oder beides. Ein ASBR verteilt Routen, die er von anderen, externen autonomen Systemen empfängt, innerhalb seines eigenen autonomen Systems. Ein ASBR erstellt externe LSAs für externe Adressen und sendet diese über ABRs an alle Bereiche. Router in anderen Bereichen verwenden ABRs als nächste Hops, um auf externe Adressen zuzugreifen. Anschließend leiten die ABRs die Pakete an den ASBR weiter, der die externen Adressen bekanntgegeben hat.
Der Routertyp ist ein Attribut eines OSPF-Prozesses. Ein physischer Router kann einen oder mehrere OSPF-Prozesse besitzen. Beispielsweise ist ein Router, der mit mehr als einem Bereich verbunden ist und Routen von einem BGP-Prozess empfängt, der mit einem anderen autonomen System (AS) verbunden ist, sowohl ein Bereichsgrenzrouter als auch ein autonomer Systemgrenzrouter.
Jeder Router besitzt eine Kennung, üblicherweise im punktierten Dezimalformat (z. B. 1.2.3.4) einer IP-Adresse. Diese Kennung muss in jeder OSPF-Instanz festgelegt werden. Ist sie nicht explizit konfiguriert, wird die höchste logische IP-Adresse als Router-Kennung verwendet. Da die Router-Kennung jedoch keine IP-Adresse ist, muss sie nicht Teil eines routbaren Subnetzes im Netzwerk sein und ist es oft auch nicht, um Verwechslungen zu vermeiden.
Nicht-Punkt-zu-Punkt-Netzwerk

In Netzwerken (gleiches Subnetz) mit folgenden Netzwerktypen:
- Übertragen
- Nicht-Rundfunk-Mehrfachzugriff (NBMA)
Ein System aus Designated Router (DR) und Backup Designated Router (BDR) dient zur Reduzierung des Netzwerkverkehrs, indem es eine Quelle für Routing-Updates bereitstellt. Dies geschieht mithilfe von Multicast-Adressen:
- 224.0.0.5 , alle Router in der Topologie werden auf dieser Multicast-Adresse lauschen.
- 224.0.0.6 , DR und BDR werden auf dieser Multicast-Adresse lauschen.
Der DR (Distributed Router) und der BDR (Behavior Distributed Router) verwalten eine vollständige Topologietabelle des Netzwerks und senden Aktualisierungen per Multicast an die anderen Router. Alle Router in einem Multi-Access-Netzwerksegment bilden eine Leader/Follower-Beziehung zum DR und BDR. Sie bauen Nachbarschaften ausschließlich zu diesen auf. Jedes Mal, wenn ein Router eine Aktualisierung sendet, sendet er diese an den DR und BDR über die Multicast-Adresse 224.0.0.6 . Der DR leitet die Aktualisierung dann an alle anderen Router im Bereich über die Multicast-Adresse 224.0.0.5 weiter . Dadurch müssen sich die Router nicht ständig gegenseitig aktualisieren, sondern erhalten alle Aktualisierungen aus einer einzigen Quelle. Die Verwendung von Multicast reduziert die Netzwerklast zusätzlich. DRs und BDRs werden in OSPF-Broadcast-Netzwerken immer eingerichtet bzw. gewählt. DRs können auch in NBMA-Netzwerken (Non-Broadcast Multi-Access) wie Frame Relay oder ATM gewählt werden. DRs oder BDRs werden nicht über Punkt-zu-Punkt-Verbindungen (wie z. B. eine Punkt-zu-Punkt-WAN-Verbindung) gewählt, da die beiden Router an beiden Enden der Verbindung vollständig benachbart sein müssen und die Bandbreite zwischen ihnen nicht weiter optimiert werden kann. DR- und Nicht-DR-Router entwickeln sich von bidirektionalen zu vollständig benachbarten Beziehungen durch den Austausch von DD-, Request- und Update-Nachrichten.
Designierter Router
Ein Designated Router (DR) ist die Router-Schnittstelle, die unter allen Routern eines bestimmten Multiaccess-Netzwerksegments ausgewählt wird, üblicherweise Broadcast-Multiaccess. Für die DR-Funktion in Non-Broadcast-Multiaccess -Medien (NBMA) können spezielle, oft herstellerabhängige Verfahren erforderlich sein. Es empfiehlt sich in der Regel, die einzelnen virtuellen Verbindungen eines NBMA-Subnetzes als separate Punkt-zu-Punkt-Verbindungen zu konfigurieren; die verwendeten Verfahren sind implementierungsabhängig.
Backup-Router
Ein Backup-Designated-Router (BDR) ist ein Router, der zum Designated Router wird, wenn der aktuell designierte Router ausfällt oder Probleme hat. Der BDR ist der OSPF-Router mit der zweithöchsten Priorität zum Zeitpunkt der letzten Wahl.
Ein Router kann Schnittstellen besitzen, die als DR (Designated Router) und als Backup Designated Router (BDR) festgelegt sind, sowie weitere, die nicht festgelegt sind. Falls in einem Subnetz kein Router als DR oder BDR fungiert, wird zunächst der BDR gewählt und anschließend der DR. [ 1 ] : 75
DR Andere
Ein Router, der weder als Designated Router (DR) noch als Backup Designated Router (BDR) ausgewählt wurde . Dieser Router bildet eine Nachbarschaft sowohl zum Designated Router (DR) als auch zum Backup Designated Router (BDR).
Bei anderen Nicht-(B)DR-Systemen endet die Adjazenz bei einem Zwei-Wege -Zustand.
Wahl des designierten Routers
Der DR wird anhand der folgenden Standardkriterien ausgewählt:
- Wenn die Prioritätseinstellung eines OSPF-Routers auf 0 gesetzt ist, bedeutet dies, dass er NIEMALS zu einem DR oder BDR werden kann.
- Wenn im Netzwerk kein DR vorhanden ist, warten die Routen, bis der Wartezeit-Timer abgelaufen ist.
- Wenn ein DR ausfällt und der BDR die Aufgaben übernimmt, findet eine weitere Wahl statt, um zu bestimmen, wer der Ersatz-BDR wird.
- Der Router, der die Hello-Pakete mit der höchsten Priorität sendet, gewinnt die Wahl.
- Bei gleicher Priorität zweier oder mehrerer Router gewinnt der Router mit der höchsten Router-ID (RID), der das Hello-Paket sendet. HINWEIS: Die RID ist die höchste logische (Loopback-)IP-Adresse, die auf einem Router konfiguriert ist. Ist keine logische/Loopback-IP-Adresse festgelegt, verwendet der Router die höchste IP-Adresse, die auf seinen aktiven Schnittstellen konfiguriert ist (z. B. wäre 192.168.0.1 höher als 10.1.1.2 ).
- Normalerweise wird der Router mit der zweithöchsten Prioritätsnummer zum BDR.
- Die Prioritätswerte liegen zwischen 0 und 255, [ 20 ] wobei ein höherer Wert die Wahrscheinlichkeit erhöht, dass es sich um DR oder BDR handelt.
- Wenn ein OSPF-Router mit höherer Priorität nach der Wahl online geht, wird er erst dann zum DR oder BDR, wenn (mindestens) der DR und der BDR ausfallen.
- Wenn der aktuelle DR ausfällt, wird der aktuelle BDR zum neuen DR und es findet eine Neuwahl statt, um einen anderen BDR zu finden. Wenn dann auch der neue DR ausfällt und der ursprüngliche DR wieder verfügbar ist, wird der zuvor gewählte BDR zum DR.
Routing-Aktualisierungsfluss
Wenn DR ein Routing-Update hat
- DR sendet LSU an 224.0.0.5
- BDR sendet LSUack an 224.0.0.5
- DR Other sendet LSUack an 224.0.0.6
Wenn BDR ein Routing-Update hat
- BDR sendet LSU an 224.0.0.5
- DR sendet LSUack an 224.0.0.5
- DR Other sendet LSUack an 224.0.0.6
Wenn DR Other ein Routing-Update hat
- DR Other sendet LSU an 224.0.0.6
- DR sendet LSA an 224.0.0.5
- BDR sendet LSUack an 224.0.0.5
- Nicht-Quellrouter, DR Andere senden LSUAck an 224.0.0.6
Protokollnachrichten
| 1 | 1 | 2 | 4 | 4 | 2 | 2 | 8 |
|---|---|---|---|---|---|---|---|
| Version 2 | Typ | Paketlänge | Router-ID | Bereichs-ID | Prüfsumme | AuType | Authentifizierung |
| 1 | 1 | 2 | 4 | 4 | 2 | 1 | 1 |
|---|---|---|---|---|---|---|---|
| Version 3 | Typ | Paketlänge | Router-ID | Bereichs-ID | Prüfsumme | Instanz-ID | Reserviert |
Im Gegensatz zu anderen Routing-Protokollen überträgt OSPF Daten nicht über ein Transportprotokoll wie das User Datagram Protocol (UDP) oder das Transmission Control Protocol (TCP). Stattdessen erstellt OSPF IP-Datagramme direkt und verwendet dabei die Protokollnummer 89 für das Feld „IP-Protokoll“ . OSPF definiert fünf verschiedene Nachrichtentypen für unterschiedliche Kommunikationsarten. Pro Frame können mehrere Pakete gesendet werden.
OSPF verwendet 5 Pakettypen:
- Hallo
- Datenbankbeschreibung
- Verbindungsstatusanfrage
- Linkstatusaktualisierung
- Verbindungsstatusbestätigung
Hallo Paket
| 24 | 4 | 2 | 1 | 1 | 4 | 4 | 4 | 4 |
|---|---|---|---|---|---|---|---|---|
| Kopfzeile | ||||||||
| Netzwerkmaske | Hallo Intervall | Optionen | Routerpriorität | Router-Totintervall | Designierte Router-ID | Backup-Router-ID | Nachbar-ID |
| 16 | 4 | 1 | 3 | 2 | 2 | 4 | 4 | 4 |
|---|---|---|---|---|---|---|---|---|
| Kopfzeile | ||||||||
| Schnittstellen-ID | Routerpriorität | Optionen | Hallo Intervall | Router-Totintervall | Designierte Router-ID | Backup-Router-ID | Nachbar-ID |
OSPF-Hello-Nachrichten dienen als Begrüßung, damit ein Router benachbarte Router in seinem lokalen Netzwerk erkennen kann. Die Nachrichten stellen Beziehungen zwischen benachbarten Geräten (sogenannte Adjazenzen) her und übermitteln wichtige Parameter für die Verwendung von OSPF im autonomen System oder Bereich. Im Normalbetrieb senden Router in regelmäßigen Abständen (dem Hello-Intervall ) Hello-Nachrichten an ihre Nachbarn. Erhält ein Router nach einer festgelegten Zeitspanne (dem Dead-Intervall ) keine Hello-Nachrichten mehr von einem Nachbarn, geht er davon aus, dass dieser ausgefallen ist.
Datenbankbeschreibung (DBD)
| 16 oder 24 | 2 | 1 | 1 | 1 | 4 | Variable |
|---|---|---|---|---|---|---|
| Kopfzeile | ||||||
| Schnittstellen-MTU | Hallo Intervall | Optionen | Flaggen | DD-Sequenznummer | LSA-Header |
Datenbankbeschreibungsnachrichten enthalten Beschreibungen der Topologie des autonomen Systems oder Bereichs. Sie übermitteln den Inhalt der Link-State-Datenbank (LSDB) für den Bereich von einem Router zum anderen. Die Übertragung einer großen LSDB kann das Senden mehrerer Nachrichten erfordern, indem das sendende Gerät als Leader-Gerät festgelegt wird und die Nachrichten nacheinander sendet. Der Follower (Empfänger der LSDB-Informationen) antwortet mit Bestätigungen.
Link-State-Pakete
| 24 | 4 | 4 | 4 |
|---|---|---|---|
| Kopfzeile | |||
| LS-Typ | Link State ID | Werberouter |
| 16 | 2 | 2 | 4 | 4 |
|---|---|---|---|---|
| Kopfzeile | ||||
| Reserviert | LS-Typ | Link State ID | Werberouter |
- Link-State-Anfrage ( LSR )
- Link-State-Anforderungsnachrichten werden von einem Router verwendet, um aktualisierte Informationen über einen Teil der LSDB von einem anderen Router anzufordern. Die Nachricht gibt die Verbindung(en) an, für die das anfragende Gerät aktuellere Informationen benötigt.
| 24 oder 16 | 4 | Variable |
|---|---|---|
| Kopfzeile | ||
| # LSAs | Liste der LSAs |
- Linkstatusaktualisierung ( LSU )
- Link-State-Update -Nachrichten enthalten aktualisierte Informationen über den Zustand bestimmter Verbindungen in der LSDB. Sie werden als Antwort auf eine Link-State-Anfrage gesendet und regelmäßig von Routern per Broadcast oder Multicast verbreitet. Ihr Inhalt dient der Aktualisierung der Informationen in den LSDBs der empfangenden Router.
| 24 oder 16 | Variable |
|---|---|
| Kopfzeile | |
| Liste der LSAs |
- Linkstatusbestätigung ( LSAack )
- Link-State-Bestätigungsnachrichten gewährleisten die Zuverlässigkeit des Link-State-Austauschprozesses, indem sie den Empfang einer Link-State-Update-Nachricht explizit bestätigen.
| LS-Typ | LS-Name | Generiert von | Beschreibung |
|---|---|---|---|
| 1 | Router-LSAs | Jeder interne Router innerhalb eines Bereichs | Die Link-State-ID des LSA vom Typ 1 ist die Ursprungsrouter-ID. Router-LSAs beschreiben die folgenden Schnittstellentypen:
|
| 2 | Netzwerk-LSAs | Der DR | |
| 3 | Zusammenfassung-LSAs | Das ABR | Um andere Bereiche über Inter-Area-Router zu informieren. Diese Routen können auch zusammengefasst werden. |
| 4 | ASBR-Zusammenfassung | Das ABR | Typ 4 beschreibt Routen zu AS-Grenzroutern außerhalb seines Bereichs. Der Area Border Router (ABR) generiert diese LSA, um andere Router in der OSPF-Domäne darüber zu informieren, dass der übereinstimmende Router ein Autonomous System Boundary Router (ASBR) ist, damit die von ihm gesendeten externen LSAs (Typ 5 / Typ 7) außerhalb seines eigenen Bereichs ordnungsgemäß aufgelöst werden können. |
| 5 | AS-external-LSAs | Die ASBR | LSAs enthalten Informationen, die von anderen Routing-Prozessen in OSPF importiert werden. Zusammen mit Typ 4 beschreiben sie den Weg zu einer externen Route. |
| 7 | NSSA-Werbung für externe Links | Das ASBR, innerhalb eines nicht allzu kurzen Bereichs | Typ-7-LSAs sind identisch mit Typ-5-LSAs. Typ-7-LSAs werden nur innerhalb des NSSA geflutet. Am Area Border Router werden ausgewählte Typ-7-LSAs in Typ-5-LSAs übersetzt und in das Backbone geflutet. |
| 8 | Link-LSA (v3) | Jeder interne Router innerhalb einer Verbindung | Weisen Sie allen anderen Routern im lokalen Netzwerk die Link-Local-Adresse des lokalen Routers zu. |
| 9 | Intra-Area-Prefix-LSAs (v3) | Jeder interne Router innerhalb eines Bereichs | Ersetzt einen Teil der Funktionalität von Router-LSAs; Stub-Netzwerksegment oder ein angeschlossenes Transit-Netzwerksegment. |
OSPF v2-Bereichstypen und akzeptierte LSAs
Nicht alle Gebietstypen verwenden alle LSAs. Nachfolgend finden Sie eine Matrix der akzeptierten LSAs.
| Innerhalb eines einzelnen Bereichs | Zwischenbereich | |||||
|---|---|---|---|---|---|---|
| Flächentyp | LSA 1 - Router | LSA 2 - Netzwerk | LSA 7 - NSSA extern | LSA 3 - Netzwerkübersicht | LSA 4 - ASBR-Zusammenfassung | LSA 5 - AS extern |
| Rückgrat | Ja | Ja | Nein, umgebaut zu einem Typ 5 durch die ABR | Ja | Ja | Ja |
| Nicht-Backbone | Ja | Ja | Nein, umgebaut zu einem Typ 5 durch die ABR | Ja | Ja | Ja |
| Stub | Ja | Ja | Nein, Standardroute | Ja | Nein, Standardroute | Nein, Standardroute |
| Total stämmig | Ja | Ja | Nein, Standardroute | Nein, Standardroute | Nein, Standardroute | Nein, Standardroute |
| Nicht so stämmig | Ja | Ja | Ja | Ja | Nein, Standardroute | Nein, Standardroute |
| Überhaupt nicht so stämmig | Ja | Ja | Ja | Nein, Standardroute | Nein, Standardroute | Nein, Standardroute |
Routing-Metriken
OSPF verwendet die Pfadkosten als grundlegende Routing-Metrik. Diese wurde im Standard so definiert, dass sie keinem Standardwert wie der Geschwindigkeit entspricht, damit der Netzwerkdesigner eine für das Design relevante Metrik wählen kann. In der Praxis werden die Pfadkosten durch Vergleich der Schnittstellengeschwindigkeit mit einer Referenzbandbreite für den OSPF-Prozess ermittelt. Die Kosten ergeben sich aus der Division der Referenzbandbreite durch die Schnittstellengeschwindigkeit (die Kosten für jede Schnittstelle können jedoch manuell angepasst werden). [ 23 ] [ 24 ] Die folgende Tabelle zeigt beispielhaft die Routing-Metrik bzw. die Kostenberechnung für eine Schnittstelle.
- Typ-1 LSA hat eine Feldgröße von 16 Bit (65.535 dezimal) [ 25 ] .
- Typ-3 LSA hat eine Feldgröße von 24 Bit (16.777.216 dezimal).
| Schnittstellengeschwindigkeit | Verbindungskosten | Verwendung | |
|---|---|---|---|
| Standard ( 100 Mbit/s ) | 200 Gbit/s | ||
| 800 Gbit/s | 1 | 1 | QSFP-DD112 |
| 200 Gbit/s | 1 | 1 | SFP-DD |
| 40 Gbit/s | 1 | 5 | QSFP+ |
| 25 Gbit/s | 1 | 8 | SFP28 |
| 10 Gbit/s | 1 | 20 | 10 GigE , üblich in Rechenzentren |
| 5 Gbit/s | 1 | 40 | NBase-T , WLAN-Router |
| 1 Gbit/s | 1 | 200 | gemeinsamer Gigabit-Port |
| 100 Mbit/s | 1 | 2000 | Low-End-Port |
| 10 Mbit/s | 10 | 20000 | Geschwindigkeit der 1990er Jahre. |
OSPF ist ein Protokoll der Schicht 3. Befindet sich ein Switch der Schicht 2 zwischen zwei Geräten, die OSPF verwenden, kann es vorkommen, dass die beiden Seiten eine andere Geschwindigkeit aushandeln. Dies kann zu einem asymmetrischen Routing auf der Verbindung führen (die Verbindung von Router 1 zu Router 2 könnte beispielsweise „1“ kosten, der Rückweg hingegen „10“), was unerwünschte Folgen haben kann.
Metriken sind jedoch nur dann direkt vergleichbar, wenn sie vom gleichen Typ sind. Man unterscheidet vier Arten von Metriken. In absteigender Reihenfolge ihrer Präferenz (beispielsweise wird eine Route innerhalb eines Gebiets unabhängig von der Metrik immer einer Route außerhalb des Gebiets vorgezogen) sind dies:
- Intra-area
- Inter-area
- Externer Typ 1, der sowohl die externen Pfadkosten als auch die Summe der internen Pfadkosten zum ASBR umfasst, der die Route ankündigt, [ 26 ].
- Externer Typ 2, dessen Wert ausschließlich den Kosten des externen Pfades entspricht,
OSPF v3
OSPF Version 3 führt Änderungen an der IPv4-Implementierung des Protokolls ein. [ 2 ] Trotz der Erweiterung der Adressen auf 128 Bit in IPv6 sind Bereichs- und Router-Identifikationen weiterhin 32-Bit-Zahlen.
Änderungen auf hoher Ebene
- Mit Ausnahme virtueller Verbindungen verwenden alle Nachbarknoten ausschließlich IPv6-Link-Local-Adressierung. Das IPv6-Protokoll läuft pro Verbindung und nicht basierend auf dem Subnetz .
- Sämtliche IP-Präfixinformationen wurden aus den Link-State-Advertisements und dem Hello- Discovery-Paket entfernt, wodurch OSPFv3 im Wesentlichen protokollunabhängig ist.
- Drei separate Flooding-Bereiche für LSAs:
- Link-lokaler Geltungsbereich: LSA wird nur auf der lokalen Verbindung und nicht darüber hinaus geflutet.
- Bereichsumfang: LSA wird in einem einzelnen OSPF-Bereich geflutet.
- AS-Bereich: LSA wird im gesamten Routing-Bereich verteilt.
- Verwendung von IPv6-Link-Local-Adressen für Nachbarerkennung und automatische Konfiguration.
- Die Authentifizierung wurde in den IP-Authentifizierungsheader verlagert.
Änderungen, die in OSPF v3 eingeführt und dann von den Anbietern auf v2 zurückportiert wurden.
- Explizite Unterstützung für mehrere Instanzen pro Link [ 27 ]
Änderungen des Paketformats
- Die OSPF-Versionsnummer wurde auf 3 geändert.
- Aus dem LSA-Header wurde das Optionsfeld entfernt.
- In Hello-Paketen und der Datenbankbeschreibung wird das Optionsfeld von 16 auf 24 Bit geändert.
- Im Hello-Paket wurden die Adressinformationen entfernt. Die Schnittstellen-ID wurde hinzugefügt.
- In Router-LSAs wurden zwei Optionsbits, das R-Bit und das V6-Bit , hinzugefügt.
- R-Bit : Ermöglicht es Multi-Homed-Hosts, am Routing-Protokoll teilzunehmen.
- V6-Bit : Spezialisiert das R-Bit.
- Fügen Sie eine Instanz-ID hinzu , die mehrere OSPF-Protokollinstanzen auf derselben logischen Schnittstelle ermöglicht.
Änderungen im LSA-Format
- Das LSA-Typfeld wird auf 16 Bit geändert.
- Unterstützung für den Umgang mit unbekannten LSA-Typen hinzufügen
- Drei Bits werden zur Codierung des Flooding-Bereichs verwendet.
- Bei IPv6 werden Adressen in LSAs als Präfix und Präfixlänge ausgedrückt .
- In Router-LSAs und Netzwerk-LSAs werden die Adressinformationen entfernt.
- Router-LSAs und Netzwerk-LSAs werden netzwerkprotokollunabhängig gestaltet.
- Es wird ein neuer LSA-Typ hinzugefügt, Link-LSA, der die Link-Local-Adresse des Routers an alle anderen Router weitergibt, die an die logische Schnittstelle angeschlossen sind, eine Liste von IPv6-Präfixen bereitstellt, die dem Link zugeordnet werden sollen, und Informationen senden kann, die die Fähigkeiten des Routers widerspiegeln.
- Die LSA-Typ-3-Zusammenfassungs-LSAs wurden in „Inter-Area-Prefix-LSAs“ umbenannt.
- Zusammenfassung LSA Typ-4: LSAs wurden in „Inter-Area-Router-LSAs“ umbenannt.
- Es wird eine Intra-Area-Prefix-LSA hinzugefügt, eine LSA, die alle IPv6-Präfixinformationen enthält.
OSPF über MPLS VPN

| Typ | Feldtyp | Teilwert | Name |
|---|---|---|---|
| Zwei-Oktett AS | 0x00 | 0x05 | OSPF-Domänenkennung |
| Vier-Oktett AS | 0x02 | 0x05 | OSPF-Domänenkennung |
| IPv4-Adresse | 0x01 | 0x05 | OSPF-Domänenkennung |
| IPv4-Adresse | 0x01 | 0x07 | OSPF-Routen-ID |
| Undurchsichtig | 0x03 | 0x06 | OSPF-Routentyp |
| 4 Byte | 1 Byte | 1 Byte |
|---|---|---|
| Bereichsnummer | Routentyp | Optionen |
Ein Kunde kann OSPF über ein MPLS- VPN nutzen , wobei der Dienstanbieter BGP oder RIP als internes Gateway-Protokoll verwendet . [ 8 ] Bei der Nutzung von OSPF über ein MPLS-VPN wird das VPN-Backbone Teil des OSPF-Backbone-Bereichs 0. In allen Bereichen werden isolierte Kopien des internen Gateway-Protokolls (IGP) ausgeführt.
Vorteile :
- Das MPLS-VPN ist für das OSPF-Standardrouting des Kunden transparent.
- Die Kundengeräte müssen lediglich OSPF unterstützen.
- Die Notwendigkeit von Tunneln ( Generic Routing Encapsulation , IPsec , WireGuard ) zur Verwendung von OSPF reduzieren.
Um dies zu erreichen, wird eine modifizierte OSPF-BGP-Umverteilung verwendet. Alle OSPF-Routen behalten den Quell-LSA-Typ und die Metrik bei. [ 29 ] [ 30 ] Um Schleifen zu vermeiden, setzt der Dienstanbieter optional ein DN-Bit [ 31 ] in den LSAs seiner Geräte, um anzuzeigen, dass eine Route bereits an die Kundengeräte gesendet wurde.
OSPF-Erweiterungen
Verkehrsplanung
OSPF-TE ist eine Erweiterung von OSPF, die die Ausdrucksstärke erhöht und so Traffic Engineering sowie die Nutzung in Nicht-IP-Netzwerken ermöglicht. [ 32 ] Mit OSPF-TE können mithilfe von undurchsichtigen LSAs , die Typ-Längen-Wert- Elemente enthalten, mehr Informationen über die Netzwerktopologie ausgetauscht werden . Diese Erweiterungen ermöglichen es OSPF-TE, vollständig außerhalb des Datenbandes des Netzwerks zu arbeiten. Dadurch kann es auch in Nicht-IP-Netzwerken, wie beispielsweise optischen Netzwerken, eingesetzt werden.
OSPF-TE wird in GMPLS -Netzwerken verwendet, um die Topologie zu beschreiben, über die GMPLS-Pfade aufgebaut werden können. Sobald GMPLS über die vollständige Netzwerkkarte verfügt, verwendet es seine eigenen Pfadaufbau- und Weiterleitungsprotokolle.
Im Resource Reservation Protocol (RSVP) wird OSPF-TE verwendet, um RSVP-signalisierte Bandbreitenreservierungen für Label-Switched-Pfade innerhalb der Link-State-Datenbank aufzuzeichnen und zu verbreiten.
Optische Weiterleitung
RFC 3717 dokumentiert die Funktionsweise des optischen Routings für IP auf Basis von Erweiterungen zu OSPF und IS-IS. [ 33 ]
Multicast Open Shortest Path First
Das Multicast Open Shortest Path First (MOSPF)-Protokoll ist eine Erweiterung von OSPF zur Unterstützung von Multicast-Routing. MOSPF ermöglicht es Routern, Informationen über Gruppenzugehörigkeiten auszutauschen.
Bemerkenswerte Implementierungen
- Allied Telesis implementiert OSPFv2 und OSPFv3 in Allied Ware Plus (AW+).
- Arista Networks implementiert OSPFv2 und OSPFv3.
- BIRD implementiert sowohl OSPFv2 als auch OSPFv3.
- Cisco IOS und NX-OS
- Cisco Meraki
- D-Link implementiert OSPFv2 auf dem Unified Services Router.
- Dells FTOS implementiert OSPFv2 und OSPFv3.
- ExtremeXOS
- FRRouting , der Nachfolger von Quagga
- GNU Zebra , eine GPL -Routing-Suite für Unix-ähnliche Systeme
- Juniper Junos
- NetWare implementiert OSPF in seinem Multi-Protocol-Routing-Modul.
- OpenBSD beinhaltet OpenOSPFD , eine OSPFv2-Implementierung.
- Quagga , ein Fork von GNU Zebra für Unix-ähnliche Systeme
- Windows NT 4.0 Server, Windows 2000 Server und Windows Server 2003 implementierten OSPFv2 im Routing- und RAS-Dienst , obwohl die Funktionalität in Windows Server 2008 entfernt wurde .
- XORP , eine Routing-Suite, die RFC2328 (OSPFv2) und RFC2740 (OSPFv3) sowohl für IPv4 als auch für IPv6 implementiert.
Anwendungen
OSPF ist ein weit verbreitetes Routing-Protokoll, das ein Netzwerk innerhalb weniger Sekunden konvergieren und schleifenfreie Pfade gewährleisten kann. Es bietet zahlreiche Funktionen, die die Festlegung von Richtlinien für die Routenverteilung ermöglichen, beispielsweise für lokale Routen, zur Lastverteilung oder für den selektiven Routenimport. IS-IS hingegen lässt sich für einen geringeren Overhead in einem stabilen Netzwerk optimieren, wie es in ISP-Netzwerken häufiger anzutreffen ist als in Unternehmensnetzwerken. Historische Umstände führten dazu, dass IS-IS zum bevorzugten IGP für ISPs wurde. Heutzutage entscheiden sich ISPs jedoch möglicherweise für die Nutzung der Funktionen der mittlerweile effizienten OSPF-Implementierungen [ 34 ] , nachdem sie die Vor- und Nachteile von IS-IS in Service-Provider-Umgebungen abgewogen haben [ 35 ] .
OSPF bietet im Vergleich zu anderen IGPs eine bessere Lastverteilung auf externen Verbindungen. Wird die Standardroute zu einem ISP von mehreren ASBRs als externe Route vom Typ I mit denselben externen Kosten in OSPF eingespeist, wählen andere Router den ASBR mit den geringsten Pfadkosten von ihrem Standort aus. Dies lässt sich durch Anpassen der externen Kosten weiter optimieren. Wird die Standardroute von verschiedenen ISPs mit unterschiedlichen externen Kosten als externe Route vom Typ II eingespeist, wird die Route mit den geringeren Kosten zum primären Ausgang und die mit den höheren Kosten dient lediglich als Backup.
Siehe auch
Referenzen
- ^ a b c d e J. Moy (April 1998). OSPF Version 2 . Network Working Group. doi : 10.17487/RFC2328 . STD 54. RFC 2328 .Internetstandard 54. Ersetzt RFC 2178. Aktualisiert durch RFC 5709 , 6549 , 6845 , 6860 , 7474 und 8042 .
- ^ a b c d R. Coltun; D. Ferguson; J. Moy (Juli 2008). A. Lindem (Hrsg.). OSPF für IPv6 . IETF Network Working Group. doi : 10.17487/RFC5340 . RFC 5340 .Vorgeschlagener Standard. Ersetzt RFC 2740. Aktualisiert durch RFC 6845 , 6860 , 8362 , 7503 und 9454.
- ^ OSPF Convergence , 6. August 2009, archiviert vom Original am 5. August 2016 , abgerufen am 13. Juni 2016
- ^ J. Moy (März 1994). Multicast Extensions to OSPF . Network Working Group. doi : 10.17487/RFC1584 . RFC 1584 .Historisch.
- ^ IP Routing: OSPF Configuration Guide , Cisco Systems , archiviert vom Original am 10. August 2016 , abgerufen am 13. Juni 2016 ,
Cisco-Router unterstützen kein LSA Type 6 Multicast OSPF (MOSPF) und generieren Syslog-Meldungen, wenn sie solche Pakete empfangen.
- ^ „[Junos] GRE-Konfigurationsbeispiel – Juniper Networks“ . kb.juniper.net . Archiviert vom Original am 28. November 2021. Abgerufen am 28. November 2021 .
- ^ „Generic Routing Encapsulation (GRE) | Interfaces User Guide for Switches | Juniper Networks TechLibrary“ . www.juniper.net . Archiviert vom Original am 28. November 2021. Abgerufen am 28. November 2021 .
- ^ a b E. Rosen; P. Psenak; P. Pillay-Esnault (Juni 2006). OSPF als Provider/Customer Edge Protocol für BGP/MPLS IP Virtual Private Networks (VPNs) . Network Working Group. doi : 10.17487/RFC4577 . RFC 4577 .Vorgeschlagener Standard. Aktualisiert RFC 4364 .
- ^ „Verständnis von OSPF-Sham-Links – Technische Dokumentation – Support – Juniper Networks“ . www.juniper.net . Archiviert vom Original am 14. November 2021. Abgerufen am 14. November 2021 .
- ^ „IP-Routing: OSPF-Konfigurationsleitfaden, Cisco IOS Release 15SY – OSPF-Sham-Link-Unterstützung für MPLS-VPN [Cisco IOS 15.1SY]“ . Cisco . Archiviert vom Original am 1. November 2021. Abgerufen am 14. November 2021 .
- ^ „OSPF Neighbor States“ . Cisco . Archiviert vom Original am 26. Oktober 2018. Abgerufen am 28. Oktober 2018 .
- ^ „Sendung 134 – OSPF-Design Teil 1 – Die Entlarvung des Mythos der Mehrbereichs-OSPF“ . Packet Pushers. Archiviert vom Original am 2. Juni 2021. Abgerufen am 2. Februar 2021 .Podcast widerlegt Empfehlung für 50 Router in altem Cisco-Artikel
- ^ Der Mikrotik RB4011 verfügt beispielsweise über 1 GB RAM. Archiviert am 16. August 2021 in der Wayback Machine , mikrotik.com, abgerufen am 1. Februar 2021.
- ^ „Goldene Regeln für die Gestaltung von Stub-Bereichen“ . Groupstudy.com. Archiviert vom Original am 31. August 2000. Abgerufen am 30. November 2011 .64 MB RAM waren im Jahr 2020 für OSPF eine große Sache.
- ^ Doyle, Jeff (10. September 2007). „Meine Lieblings-Interviewfrage“ . Network World . Archiviert vom Original am 28. Dezember 2021. Abgerufen am 28. Dezember 2021 .
- ^ ( ASGuidelines 1996 , S. 25)
- ^ J. Hawkinson; T. Bates (März 1996). Richtlinien für die Erstellung, Auswahl und Registrierung eines autonomen Systems (AS) . Network Working Group. doi : 10.17487/RFC1930 . BCP 6. RFC 1930 .Best Current Practice 6. Aktualisiert durch RFC 6996 und 7300 .
- ^ „Goldene Regeln für die Gestaltung von Stub-Bereichen“ . Groupstudy.com. Archiviert vom Original am 31. August 2000. Abgerufen am 30. November 2011 .Dies trifft nicht unbedingt zu. Wenn mehrere ABRs vorhanden sind, wie es beispielsweise für Hochverfügbarkeit erforderlich sein kann, senden Router innerhalb des TSA den Nicht-Intra-Area-Datenverkehr an den ABR mit der niedrigsten Intra-Area-Metrik (den nächstgelegenen ABR). Dies erfordert jedoch eine spezielle Konfiguration.
- ^ P. Murphy (Januar 2001). Die OSPF Not-So-Stubby Area (NSSA) Option . Network Working Group. doi : 10.17487/RFC3101 . RFC 3101 .Vorgeschlagener Standard. Ersetzt RFC 1587 .
- ^ „Cisco IOS IP Routing: OSPF Command Reference“ (PDF) . Cisco Systems . April 2011. Archiviert vom Original (PDF) am 25. April 2012.
- ^ „juniper configureing-ospf-areas“ . Juniper Networks . 18. Januar 2021. Archiviert vom Original am 23. Oktober 2021. Abgerufen am 23. Oktober 2021 .
- ^ „OSPF Areas Explained“ . Packet Coders . 23. Januar 2019. Archiviert vom Original am 23. Oktober 2021. Abgerufen am 23. Oktober 2021 .
- ^ „Referenzbandbreite (Protokolle OSPF) | Junos OS | Juniper Networks“ . www.juniper.net . Abgerufen am 26. März 2025 .
- ^ Anpassung der OSPF-Kosten (Archiviert am 14. April 2021 in der Wayback Machine , OReilly.com)
- ^ „OSPF Stub Router Advertisement“ . IETF Datatracker . Internet Engineering Task Force. Juni 2001. Archiviert vom Original am 23. Oktober 2021. Abgerufen am 23. Oktober 2021 .
- ^ Ob eine externe Route auf einem Typ-5-LSA oder einem Typ-7-LSA (NSSA) basiert, hat keinen Einfluss auf ihre Präferenz. Siehe RFC 3101, Abschnitt 2.5.
- ^ „Sekundär (Protokolle OSPF) – TechLibrary – Juniper Networks“ . www.juniper.net . Archiviert vom Original am 7. November 2021. Abgerufen am 7. November 2021 .
- ^ „Border Gateway Protocol (BGP) Extended Communities“ . www.iana.org . Archiviert vom Original am 28. November 2021. Abgerufen am 28. November 2021 .
- ^ „MPLS VPN OSPF PE- und CE-Unterstützung“ . Cisco . Archiviert vom Original am 28. November 2021. Abgerufen am 28. November 2021 .
- ^ Cisco. „Verwendung von OSPF in einer MPLS-VPN-Umgebung“ (PDF) . Archiviert (PDF) vom Original am 10. Oktober 2022. Abgerufen am 28. November 2021 .
- ^ E. Rosen; P. Psenak; P. Pillay-Esnault (Juni 2006). Verwendung eines Link-State-Advertisement-Optionsbits (LSA) zur Verhinderung von Schleifen in BGP/MPLS-IP-VPNs . Network Working Group. doi : 10.17487/RFC4576 . RFC 4576 .Vorgeschlagener Standard.
- ^ Katz, D.; Yeung, D. (September 2003). Traffic Engineering (TE) Extensions to OSPF Version 2. The Internet Society. doi : 10.17487/RFC3630.OSPF -TEextensions . Abgerufen am 28. September 2007 .Archiviert am 14. Februar 2012 in der Wayback Machine
- ^ B. Rajagopalan; J. Luciani; D. Awduche (März 2004). IP über optische Netzwerke: Ein Rahmenwerk . Internet Engineering Task Force. doi : 10.17487/RFC3717 . RFC 3717 .
- ^ Berkowitz, Howard (1999). OSPF Goodies for ISPs . North American Network Operators Group NANOG 17. Montreal. Archiviert vom Original am 12. Juni 2016.
- ^ Katz, Dave (2000). OSPF und IS-IS: Eine vergleichende Analyse . North American Network Operators Group NANOG 19. Albuquerque. Archiviert vom Original am 20. Juni 2018.
Weiterführende Literatur
- Colton, Andrew (Oktober 2003). OSPF für Cisco-Router . Rocket Science Press . ISBN 978-0972286213Die
- Doyle, Jeff; Carroll, Jennifer (2005). Routing TCP/IP . Band 1 (2. Aufl.). Cisco Press . ISBN 978-1-58705-202-6Die
- Moy, John T. (1998). OSPF: Anatomie eines Internet-Routing-Protokolls . Addison-Wesley . ISBN 978-0201634723Die
- Parkhurst, William R. (2002). Cisco OSPF Command and Configuration Handbook . Cisco Press. ISBN 978-1-58705-071-8Die
- Basu, Anindya; Riecke, Jon (2001). „Stabilitätsprobleme beim OSPF-Routing“. Konferenzbeitrag zur Konferenz „Anwendungen, Technologien, Architekturen und Protokolle für die Computerkommunikation“ (SIGCOMM '01) . S. 225–236 . CiteSeerX 10.1.1.99.6393 . doi : 10.1145/383059.383077 . ISBN 978-1-58113-411-7. S2CID 7555753 .
- Valadas, Rui (2019). OSPF und IS-IS: Von den Prinzipien des Link-State-Routings zu den Technologien . CRC Press. doi : 10.1201/9780429027543 . ISBN 9780429027543. S2CID 164731068 .


