Ein Uniform Resource Name ( URN ) ist ein Uniform Resource Identifier (URI), der das urnSchema verwendet . URNs sind global eindeutige, persistente Identifikatoren, die innerhalb definierter Namensräume vergeben werden und daher über einen langen Zeitraum verfügbar sind, selbst nachdem die Ressource, die sie identifizieren, nicht mehr existiert oder nicht mehr verfügbar ist. [ 1 ] URNs können nicht direkt zum Auffinden eines Elements verwendet werden und müssen nicht auflösbar sein, da sie lediglich Vorlagen darstellen, die ein anderer Parser zum Auffinden eines Elements verwenden kann.
URIs, URNs und URLs
URNs wurden ursprünglich als Teil einer dreiteiligen Informationsarchitektur für das Internet konzipiert, zusammen mit Uniform Resource Locators (URLs) und Uniform Resource Characteristics (URCs) , einem Metadaten- Framework. Wie in RFC 1737 [ 2 ] und später in RFC 2141 [ 3 ] beschrieben , unterscheiden sich URNs von URLs, die Ressourcen durch Angabe ihres Speicherorts im Kontext eines bestimmten Zugriffsprotokolls wie HTTP oder FTP identifizieren . Im Gegensatz dazu sind URNs als persistente , ortsunabhängige Identifikatoren konzipiert, die innerhalb definierter Namensräume vergeben werden , typischerweise von einer für den Namensraum verantwortlichen Instanz. Dadurch sind sie global eindeutig und über lange Zeiträume hinweg persistent, selbst nachdem die Ressource, die sie identifizieren, nicht mehr existiert oder nicht mehr verfügbar ist. [ 1 ]
URCs kamen nie über das Konzeptstadium hinaus [ 4 ] , und andere Technologien wie das Resource Description Framework traten später an ihre Stelle. Seit RFC 3986 [ 5 ] aus dem Jahr 2005 ist die Verwendung der Begriffe „Uniform Resource Name“ und „Uniform Resource Locator“ in technischen Standards zugunsten des Begriffs Uniform Resource Identifier (URI) veraltet, der beide umfasst. Diese Ansicht wurde 2001 von einer gemeinsamen Arbeitsgruppe des World Wide Web Consortium (W3C) und der Internet Engineering Task Force (IETF) vorgeschlagen. [ 4 ]
Ein URI (Unified Reference Index) ist eine Zeichenkette , die zur Identifizierung oder Benennung einer Ressource im Internet dient. URIs werden in vielen Internetprotokollen verwendet, um auf Informationsressourcen zuzugreifen. Zu den URI-Schemata gehören unter anderem die Protokolle `application/json` und `application/json` sowie Hunderte weiterer Protokolle. httpftp
Nach der sogenannten „zeitgenössischen Sichtweise“ identifizieren oder benennen alle URIs Ressourcen, möglicherweise eindeutig und dauerhaft, wobei einige von ihnen auch „Locators“ sind, die in Verbindung mit einem bestimmten Protokoll zu einer Repräsentation der Ressourcen aufgelöst werden können.
Andere URIs sind keine Locators und innerhalb der Systeme, in denen sie vorkommen, nicht unbedingt auflösbar. Diese URIs können als Namen oder Identifikatoren von Ressourcen dienen. Da Ressourcen verschoben werden können, ist es wahrscheinlicher, dass undurchsichtige Identifikatoren, die keine Locators sind und nicht an bestimmte Orte gebunden sind, über die Zeit eindeutig und persistent bleiben als Locators . Ob ein URI auflösbar ist, hängt jedoch von vielen betrieblichen und praktischen Details ab, unabhängig davon, ob er als „Name“ oder „Locator“ bezeichnet wird. Heutzutage gibt es keine klare Trennlinie mehr zwischen „Namen“ und „Locators“.
In Übereinstimmung mit dieser Denkweise wird die Unterscheidung zwischen Uniform Resource Names und Uniform Resource Locators in den formalen technischen Standards der Internet Engineering Task Force nicht mehr verwendet , obwohl der letztere Begriff, URL, im informellen Sprachgebrauch noch weit verbreitet ist.
Der Begriff „URN“ wird heute als eines von über hundert URI-„Schemata“ verwendet, urn:parallel http:zu ftp:anderen. URIs dieses urn:Schemas sind keine Locatoren, müssen keinem bestimmten Protokoll oder Zugriffsverfahren zugeordnet sein und müssen nicht auflösbar sein. Sie sollten durch ein Verfahren zugewiesen werden, das eine gewisse Gewähr dafür bietet, dass sie eindeutig bleiben und dieselbe Ressource über einen längeren Zeitraum hinweg zuverlässig identifizieren. Einige Namensräume dieses urn:Schemas, wie beispielsweise urn:uuid:URIs, weisen Kennungen auf eine Weise zu, die keine Registrierungsstelle erfordert, die meisten jedoch schon. Ein typischer URN-Namensraum ist URIs urn:isbnfür Internationale Standardbuchnummern. Diese Auffassung wird in RFC 8141 (2017) fortgeführt. [ 1 ]
Es gibt weitere URI-Schemata, wie zum Beispiel tag:, info:(heute weitgehend veraltet) und ni:[ 6 ] , die dem urn:Schema insofern ähnlich sind, als sie keine Locators sind und nicht mit bestimmten Auflösungs- oder Zugriffsprotokollen verbunden sind.
Syntax
Die Syntax eines urn:Schema-URI wird in der erweiterten Backus-Naur-Form wie folgt dargestellt: [ 5 ] [ 7 ]
namestring = assigned-name [ rq-components ] [ "#" f-component ] assigned-name = "urn" ":" NID ":" NSS NID = ( alphanum ) 0*30 ( ldh ) ( alphanum ) ldh = alphanum / "-" NSS = pchar * ( pchar / "/" ) rq-components = [ "?+" r-component ] [ "?=" q-component ] r-component = pchar * ( pchar / "/" / "?" ) q-component = pchar * ( pchar / "/" / "?" ) f-component = fragment; allgemeine URI-Syntaxregeln (RFC3986) fragment = * ( pchar / "/" / "?" ) pchar = unreserved / pct-encoded / sub-delims / ":" / "@" pct-encoded = "%" HEXDIG HEXDIG unreserved = ALPHA / DIGIT / "-" / "." / "_" / "~" sub-delims = "!" / "$" / "&" / " ' " / "(" / ")" / "*" / "+" / "," / ";" / "="alphanum = ALPHA / ZIFFER ; veraltet, Verwendung wird nicht mehr empfohlenoder, in Form eines Syntaxdiagramms , wie folgt:

- Das führende Schema (
urn:) unterscheidet nicht zwischen Groß- und Kleinschreibung. <NID>ist der Namensraumbezeichner und kann Buchstaben, Ziffern und Zeichen enthalten-.- Auf die NID folgt die namensraumspezifische Zeichenkette
<NSS>, deren Interpretation vom angegebenen Namespace abhängt. Die NSS kann ASCII-Buchstaben und -Ziffern sowie zahlreiche Satzzeichen und Sonderzeichen enthalten. Nicht zulässige ASCII- und Unicode- Zeichen können enthalten sein, sofern sie prozentkodiert sind .
Im Jahr 2017 wurde die Syntax für URNs aktualisiert: [ 1 ]
/Im NSS ist nun das Schrägstrichzeichen ( ) zulässig, um Namen darzustellen, die Schrägstriche aus Nicht-URN-Identifikationssystemen enthalten.- Die q-Komponente wurde hinzugefügt, um die Übergabe von Parametern an benannte Ressourcen zu ermöglichen.
- Die r-Komponente wurde hinzugefügt, um die Übergabe von Parametern an Resolver zu ermöglichen. Die aktualisierte Spezifikation weist jedoch darauf hin, dass sie erst verwendet werden sollte, wenn ihre Semantik durch weitere Standardisierung definiert ist.
Namensräume
Um die globale Eindeutigkeit von URN-Namensräumen zu gewährleisten, müssen deren Kennungen (NIDs) bei der IANA registriert werden . Registrierte Namensräume können „formal“ oder „informell“ sein. Eine Ausnahme von der Registrierungspflicht galt früher für „experimentelle Namensräume“ [ 8 ] , wurde jedoch durch RFC 8141 [ 1 ] aufgehoben.
Formell
Es wurden etwa sechzig formale URN-Namensraumkennungen registriert. Dies sind Namensräume, von deren Veröffentlichung Internetnutzer profitieren sollen [ 1 ] , und die mehreren Beschränkungen unterliegen. Sie müssen:
- Es darf sich nicht um eine bereits registrierte NID handeln.
- Nicht anfangen mit
urn- - Sei länger als zwei Buchstaben
- Nicht beginnend mit
XY-, wobei XY eine beliebige Kombination zweier ASCII- Buchstaben ist - Nicht beginnen mit
x-(siehe „Experimentelle Namensräume“, unten)
Informell
Informelle Namensräume werden bei der IANA registriert und erhalten eine von der IANA nach dem Prinzip „Wer zuerst kommt, mahlt zuerst“ vergebene Nummernfolge als Kennung [ 1 ] im folgenden Format:
"urn-" ⟨number⟩Informelle Namensräume sind vollwertige URN-Namensräume und können bei globalen Registrierungsdiensten registriert werden. [ 1 ]
Experimental
Eine Ausnahme von der Registrierungspflicht galt früher für „experimentelle Namensräume“. [ 8 ] Nach der Abschaffung der „X-“-Notation für neue Bezeichnernamen [ 9 ] wurden experimentelle URN-Namensräume jedoch in RFC 8141 [ 1 ] abgeschafft, was die Verwendung des Namensraums vorsieht, urn:examplewo dies angebracht ist. [ 10 ]
Beispiele
| URNE | entspricht |
|---|---|
urn:isbn:0451450523 | Das 1968 erschienene Buch „Das letzte Einhorn“ , identifiziert durch seine Internationale Standardbuchnummer . |
urn:isan:0000-0000-2CEA-0000-1-0000-0000-Y | Der Film Spider-Man aus dem Jahr 2002 , identifiziert durch seine Internationale Standard-Audiovisuelle Nummer . |
urn:ISSN:0167-6423 | Die wissenschaftliche Zeitschrift Science of Computer Programming , identifiziert durch ihre Internationale Standardseriennummer . |
urn:ietf:rfc:2648 | Der RFC 2648 der IETF . |
urn:mpeg:mpeg7:schema:2001 | Die Standard-Namensraumregeln für MPEG-7 -Videometadaten. |
urn:oid:2.16.840 | Die OID für die Vereinigten Staaten . |
urn:uuid:6e8bc430-9c3a-11d9-9669-0800200c9a66 | Eine UUID der Version 1 . |
urn:nbn:de:bvb:19-146642 | Eine Nationale Bibliographienummer für ein Dokument, die das Land ( de), das regionale Netzwerk ( bvb= Bibliotheksverbund Bayern ), die Bibliotheksnummer (19) und die Dokumentnummer angibt. |
urn:lex:eu:council:directive:2010-03-09;2010-19-UE | Eine Richtlinie der Europäischen Union , die den Lex-URN-Namensraum verwendet . |
urn:lsid:zoobank.org:pub:CDC8D258-8F57-41DC-B560-247E17D3DC8C | A Life Science Identifiers that may be resolved to http://zoobank.org/urn:lsid:zoobank.org:pub:CDC8D258-8F57-41DC-B560-247E17D3DC8C . |
urn:epc:class:lgtin:4012345.012345.998877 | Globale Artikelnummer ( GTI) mit Los-/Chargennummer. Gemäß Tag Data Standard [ 11 ] (TDS). Weitere Beispiele finden Sie unter EPC-Identifikationsschlüssel . |
urn:epc:id:sgtin:0614141.112345.400 | Globale Artikelnummer mit individueller Seriennummer |
urn:epc:id:sscc:0614141.1234567890 | Serienversandcontainer-Code |
urn:epc:id:sgln:0614141.12345.400 | Globale Rufnummer mit Durchwahl |
urn:epc:id:bic:CSQU3054383 | BIC- Code für intermodale Container gemäß ISO 6346 |
urn:epc:id:imovn:9176187 | IMO-Schiffsnummer der Seeschiffe |
urn:epc:id:gdti:0614141.12345.400 | Globaler Dokumenttypbezeichner einer Dokumentinstanz |
urn:mrn:iala:aton:us:1234.5 | Kennung für Seezeichen |
urn:mrn:iala:vts:ca:ecareg | Kennung für Schiffsverkehrsdienste |
urn:mrn:iala:wwy:us:atl:chba:potri | Kennung für Wasserwege |
urn:mrn:iala:pub:g1143 | Kennung für IALA -Veröffentlichungen |
urn:microsoft:adfs:claimsxray | Kennung für föderierte Identität; dieses Beispiel stammt aus Claims X-Ray [ 12 ] |
urn:eic:10X1001A1001A450 | Europäisches Netzwerk der Übertragungsnetzbetreiber für Elektrizität (ENTSO-E), erkennbar an seinem Energieidentifikationscode |
Siehe auch
- Archivressourcenschlüssel (ARK)
- .arpa – urn.arpa dient der dynamischen Erkennung
- Erweiterbarer Ressourcenidentifikator (XRI)
- Griffsystem
- Info-URI-Schema
- Life Science Identifiers (LSID)
- Das Magnet-URI-Schema , das URNs verwendet
- Persistenter Uniform Resource Locator (PURL)
- Das Tag-URI-Schema ist wie urn: insofern, als seine URIs keine Ressourcenlokalisierungen sind .
- Digitaler Objektidentifikator (DOI)
- EPC-Identifikationsschlüssel .
Referenzen
Zitate
- ^ a b c d e f g h i RFC 8141 (2017) .
- ^ RFC 1737 (1994) .
- ^ RFC 2141 (1997) .
- ^ a b W3C/IETF (2001) .
- ^ a b RFC 3986 (2005) .
- ^ RFC 6920 (2013) .
- ^ RFC 8141, Abschnitt 2 (2017) .
- ^ a b RFC 3406 (2002) .
- ^ RFC 6648 (2012) .
- ^ RFC 6963 (2013) .
- ^ „EPC Tag Data Standard, Version 1.13“ . GS1. Nov. 2019. Abgerufen am 7. März 2021 .
- ^ "Hilfe für Röntgenaufnahmen mit AD FS" .
{{cite web}}: CS1 maint: url-status ( link )
Quellen
- K. Sollins; L. Masinter (Dezember 1994). Funktionale Anforderungen an einheitliche Ressourcennamen . Network Working Group. doi : 10.17487/RFC1737 . RFC 1737 .Informativ.
- R. Moats (Mai 1997). P. Vixie (Hrsg.). URN Syntax . IETF Network Working Group. doi : 10.17487/RFC2141 . RFC 2141 .Vorgeschlagener Standard. Ersetzt durch RFC 8141 .
- L. Daigle; DW van Gulik; R. Iannella; P. Faltstrom (Oktober 2002). Uniform Resource Names (URN) Namespace Definition Mechanisms . Network Working Group. doi : 10.17487/RFC3406 . BCP 66. RFC 3406 .Best Current Practice 66. Ersetzt durch RFC 8141. Ersetzt RFC 2611 .
- T. Berners-Lee , R. Fielding , L. Masinter (Januar 2005). Uniform Resource Identifier (URI): Generische Syntax . Network Working Group. doi : 10.17487/RFC3986 . STD 66. RFC 3986 .Internetstandard 66. Ersetzt RFC 2732 , 2396 und 1808. Aktualisiert durch RFC 6874 , 7320 und 8820. Aktualisiert RFC 1738 .
- P. Saint-Andre; D. Crocker ; M. Nottingham (Juni 2012). Abschaffung des „X-“-Präfixes und ähnlicher Konstrukte in Anwendungsprotokollen . Internet Engineering Task Force . doi : 10.17487/RFC6648 . ISSN 2070-1721 . BCP 178. RFC 6648 .Aktuelle Best Practice 178.
- S. Farrell; D. Kutscher; C. Dannewitz; B. Ohlman; A. Keranen; P. Hallam-Baker (April 2013). Naming Things with Hashes . Internet Engineering Task Force . doi : 10.17487/RFC6920 . ISSN 2070-1721 . RFC 6920 .Vorgeschlagener Standard.
- P. Saint-Andre (Mai 2013). Ein Uniform Resource Name (URN)-Namensraum für Beispiele . Internet Engineering Task Force . doi : 10.17487/RFC6963 . ISSN 2070-1721 . BCP 183. RFC 6963 .Best Current Practice 183. Updates RFC 1930 .
- P. Saint-Andre; J. Klensin (April 2017). Uniform Resource Names (URNs) . Internet Engineering Task Force . doi : 10.17487/RFC8141 . ISSN 2070-1721 . RFC 8141 .Vorgeschlagener Standard. Ersetzt RFC 2141 und 3406 .
- P. Saint-Andre; J. Klensin (April 2017). Uniform Resource Names (URNs) . Internet Engineering Task Force . doi : 10.17487/RFC8141 . ISSN 2070-1721 . RFC 8141 .Vorgeschlagener Standard. Abschnitt 2. Ersetzt RFC 2141 und 3406. §
2. URN-Syntax
- P. Saint-Andre; J. Klensin (April 2017). Uniform Resource Names (URNs) . Internet Engineering Task Force . doi : 10.17487/RFC8141 . ISSN 2070-1721 . RFC 8141 .Vorgeschlagener Standard. Abschnitt 2. Ersetzt RFC 2141 und 3406. §
- „Factsheet: DOI System and Internet Identifier Specifications“ . International DOI Foundation. Oktober 2012. Abgerufen am 6. Dezember 2012 .
- W3C/IETF URI Planning Interest Group (21. September 2001). „URIs, URLs, and URNs: Clarifications and Recommendations 1.0“ . W3C . Abgerufen am 7. Dezember 2012 .
Externe Links
- Offizielles IANA-Register der URN-Namensräume
- Arbeitsgruppe für einheitliche Ressourcennamen bei der IETF
- URNs und bibliografische Zitate beim Web-Authoring
- Ein Beispiel für einen serverseitigen URN-Resolver ist in RFC 2169 beschrieben .