Carrier-Grade NAT

Carrier-Grade NAT ( CGN oder CGNAT ) (auch bekannt als Large-Scale NAT , LSN ) ist eine Art der Netzwerkadressübersetzung (NAT), die von Internetdienstanbietern (ISPs) im IPv4- Netzwerkdesign eingesetzt wird. Bei CGN werden Endgeräte, insbesondere in Heimnetzwerken, mit privaten Netzwerkadressen konfiguriert, die von im Netzwerk des Netzbetreibers integrierten Middlebox -Netzwerkadressübersetzern in öffentliche IPv4-Adressen übersetzt werden . Dies ermöglicht die gemeinsame Nutzung kleiner Pools öffentlicher Adressen durch viele Endnutzer. Im Wesentlichen entspricht dies der herkömmlichen NAT-Funktion beim Kunden auf ISP-Ebene.

Carrier-Grade NAT wird häufig zur Milderung der IPv4-Adressknappheit eingesetzt . [ 1 ]

Ein Anwendungsfall von CGN wurde als NAT444 bezeichnet [ 2 ] , da einige Kundenverbindungen zu Internetdiensten im öffentlichen Internet drei verschiedene IPv4-Adressierungsdomänen durchlaufen würden: das eigene private Netzwerk des Kunden, das private Netzwerk des Netzbetreibers und das öffentliche Internet.

Ein weiteres CGN-Szenario ist Dual-Stack Lite , bei dem das Netz des Anbieters IPv6 nutzt und somit nur zwei IPv4-Adressbereiche benötigt werden. CGN kann auch mithilfe von NAT64- Übersetzern auf ISP-Ebene in Kombination mit 464XLAT eingesetzt werden , wodurch IPv4 im Heimnetzwerk vollständig entfällt.

CGN-Verfahren wurden erstmals im Jahr 2000 eingesetzt, um den unmittelbaren Bedarf an einer großen Anzahl von IPv4-Adressen in GPRS-Mobilfunknetzen zu decken . Die geschätzte Anzahl der CGN-Implementierungen stieg von 1.200 im Jahr 2014 auf 3.400 im Jahr 2016, wobei 28,85 % der untersuchten Implementierungen in Mobilfunknetzen zu sein scheinen. [ 3 ]

Gemeinsamer Adressraum

Wenn ein ISP ein CGN einsetzt und den RFC  1918 -Adressraum zur Nummerierung der Kundengateways verwendet, entsteht das Risiko von Adresskollisionen und damit von Routingfehlern, wenn das Kundennetzwerk bereits einen RFC 1918- Adressraum verwendet.  

Dies veranlasste einige ISPs, innerhalb des American Registry for Internet Numbers (ARIN) eine Richtlinie zur Zuteilung neuer privater Adressräume für CGNs zu entwickeln. ARIN überließ die Umsetzung dieser Richtlinie jedoch der IETF , da es sich nicht um ein typisches Zuteilungsproblem, sondern um eine Reservierung von Adressen für technische Zwecke handelte (gemäß RFC 2860).

Die IETF veröffentlichte RFC 6598 , in dem ein gemeinsamer Adressraum für die Verwendung in ISP-CGN-Implementierungen detailliert beschrieben wird, der dieselben Netzwerkpräfixe sowohl auf eingehenden als auch auf ausgehenden Schnittstellen verarbeiten kann. ARIN gab den Adressraum für diese Zuteilung an die Internet Assigned Numbers Authority (IANA) zurück. [ 4 ] Der zugewiesene Adressblock ist 100.64.0.0/10, d. h. IP-Adressen von 100.64.0.0 bis 100.127.255.255. [ 5 ] 

Geräte, die prüfen, ob eine IPv4-Adresse öffentlich ist, müssen aktualisiert werden, um den neuen Adressraum zu erkennen. Die Zuweisung von mehr privatem IPv4-Adressraum für NAT-Geräte könnte den Übergang zu IPv6 hinauszögern.

Vorteile

  • Maximiert die Nutzung des begrenzten öffentlichen IPv4-Adressraums.

Nachteile

  • Wie jede Form von NAT verstößt es gegen das Ende-zu-Ende-Prinzip . [ 6 ]
  • Aufgrund seiner Zustandsbehaftetheit weist es erhebliche Sicherheits- und Zuverlässigkeitsprobleme auf .
  • Das Problem der IPv4-Adressknappheit wird dadurch nicht gelöst, wenn eine öffentliche IP-Adresse benötigt wird, beispielsweise beim Webhosting.
  • Dies kann zu einem Leistungsengpass führen, der die Skalierbarkeit einschränkt .
  • Dies verhindert üblicherweise, dass Kunden des Internetdienstanbieters Portweiterleitung nutzen können , da NAT in der Regel durch die Zuordnung von Ports der NAT-Geräte im Netzwerk zu anderen Ports der externen Schnittstelle implementiert wird. Dadurch kann der Router die Antworten dem richtigen Gerät zuordnen. In Carrier-Grade-NAT-Netzwerken blockiert der „Master-Router“ des Internetdienstanbieters, der das Carrier-Grade-NAT-Netzwerk (CGN) betreibt, die Portweiterleitung, selbst wenn der Router beim Kunden für diese konfiguriert ist, da der tatsächlich verwendete Port nicht dem vom Kunden konfigurierten Port entspricht. [ 7 ] Um diesen Nachteil zu beheben, wurde das Port Control Protocol (PCP) in RFC 6887 standardisiert; die Akzeptanz bei den Netzbetreibern verläuft jedoch schleppend .
  • Bei der Sperrung von Datenverkehr anhand von IP-Adressen kann ein System den Datenverkehr eines Spammers blockieren , indem es dessen IP-Adresse sperrt. Befindet sich dieser Nutzer hinter einem Carrier-Grade-NAT, werden dadurch unbeabsichtigt auch andere Nutzer mit derselben öffentlichen IP-Adresse blockiert. [ 7 ] Dies kann für Foren- und Wiki-Administratoren problematisch sein, die versuchen, die Störungen durch einen einzelnen, böswilligen Nutzer zu beheben, der sich eine IP-Adresse mit legitimen Nutzern teilt.
  • Streaming- Dienste betrachten CGN-Aktivitäten möglicherweise als gleichwertig mit VPN- oder Account-Sharing -Verkehr. Solche Dienste sperren oder bannen VPN-Nutzer häufig wegen Verstoßes gegen die Nutzungsbedingungen, da sie davon ausgehen, dass diese auf Inhalte aus einer günstigeren Region zugreifen, um Kosten zu sparen. Auch Account-Sharing-Verkehr wird blockiert, wenn mehrere Haushalte oder Nutzer mit nur einem Login auf die Inhalte zugreifen.
  • CGN stört die Funktionsfähigkeit mehrerer IPv6-Übergangsmechanismen .
  • Kritiker von CGN könnten argumentieren, dass der Einsatz von CGN Management- und technische Ressourcen bindet, die besser für die Förderung und Finanzierung der IPv6-Nutzung eingesetzt werden könnten.

Siehe auch

Referenzen

  1. ^ S. Jiang; D. Guo; B. Carpenter (Juni 2011), Ein inkrementelles Carrier-Grade NAT (CGN) für den IPv6-Übergang , ISSN 2070-1721 , RFC 6264  
  2. ^ Chris Grundemann (14.02.2011). „NAT444 (CGN/LSN) und was es kaputt macht“ .
  3. ^ Livadariu, Ioana; Benson, Karyn; Elmokashfi, Ahmed; Dhamdhere, Amogh; Dainotti, Alberto (2018). Ableitung der Carrier-Grade-NAT-Bereitstellung in freier Wildbahn (PDF) . IEEE INFOCOM 2018 – IEEE-Konferenz über Computerkommunikation . Honolulu. S.  2249–2257 . doi : 10.1109/INFOCOM.2018.8486223 . Abgerufen am 22. Juli 2021 .
  4. ^ „Re: Gemeinsamer Adressraum … Realität!“ . Archiviert vom Original am 7. Juni 2012. Abgerufen am 13. September 2012 .
  5. ^ Chris Grundemann (13.03.2012). "100.64.0.0/10 – Gemeinsamer Übergangsraum" .
  6. ^ RFC 7021 – Bewertung der Auswirkungen von Carrier-Grade NAT auf Netzwerkanwendungen 
  7. ^ a b InterConnect (15.04.2013). „MC/159-Bericht über die Auswirkungen von Carrier-Grade-Netzwerkadressübersetzern: Abschlussbericht“ . Ofcom . Archiviert vom Original am 27.10.2023 . Abgerufen am 17.10.2023 .