Übersicht der VPN-Konnektivität, die die verwendeten Intranet-Site-to-Site- und Remote-Work-Konfigurationen zeigt

Ein virtuelles privates Netzwerk ( VPN ) ist ein Overlay-Netzwerk , das Netzwerkvirtualisierung nutzt , um ein privates Netzwerk über ein öffentliches Netzwerk wie das Internet mittels Verschlüsselungs- und Tunnelprotokollen zu erweitern . [ 1 ] In einem VPN wird ein Tunnelprotokoll verwendet, um Netzwerk-Nachrichten von einem Netzwerk-Host zu einem anderen zu übertragen.

Host-to-Network-VPNs werden häufig von Unternehmen eingesetzt, um externen Nutzern einen sicheren Zugriff auf das Büronetzwerk über das Internet zu ermöglichen. [ 2 ] [ 3 ] Site-to-Site-VPNs verbinden zwei Netzwerke, beispielsweise ein Büronetzwerk und ein Rechenzentrum. Provider-VPNs isolieren Teile der Netzwerkinfrastruktur des Providers in virtuellen Segmenten, sodass die Inhalte jedes Segments gegenüber den anderen Segmenten privat bleiben. Auch Privatpersonen nutzen VPNs, um ihren Netzwerkverkehr zu verschlüsseln und zu anonymisieren . VPN-Dienste verkaufen dabei den Zugang zu ihren eigenen privaten Netzwerken.

VPNs können die Privatsphäre im Internet verbessern, indem sie verhindern, dass Internetanbieter auf die über das VPN ausgetauschten privaten Daten zugreifen können. Allerdings können der VPN-Anbieter und der über das VPN genutzte Online-Dienst die Aktivitäten des Nutzers einsehen. Durch Verschlüsselung erhöhen VPNs die Vertraulichkeit und verringern das Risiko erfolgreicher Datenabfangangriffe von außen .

Hintergrund

Ein Netzwerk ist eine Gruppe kommunizierender Computer , sogenannter Hosts , die mithilfe von Kommunikationsprotokollen und der Netzwerkhardware Daten untereinander austauschen . Innerhalb eines Computernetzwerks werden Computer durch Netzwerkadressen identifiziert , die es regelbasierten Systemen wie dem Internetprotokoll (IP) ermöglichen, Hosts zu lokalisieren und zu identifizieren. Hosts können auch Hostnamen besitzen – einprägsame Bezeichnungen für die Hostknoten , die nach der ersten Zuweisung nur selten geändert werden. Als Übertragungsmedium für den Informationsaustausch dienen kabelgebundene Medien wie Kupferkabel, Glasfasern und drahtlose Funkfrequenzmedien . Die Anordnung der Hosts und der Hardware innerhalb einer Netzwerkarchitektur wird als Netzwerktopologie bezeichnet . [ 4 ] [ 5 ]

Abgesehen von den physikalischen Übertragungsmedien umfassen Netzwerke Netzwerkknoten wie Netzwerkschnittstellencontroller , Repeater , Hubs , Bridges , Switches , Router und Modems :

  • Der Netzwerkcontroller (NIC) ist eine Computerhardware , die den Computer mit dem Netzwerkmedium verbindet . In Ethernet-Netzwerken verfügt jede NIC über eine eindeutige MAC-Adresse (Media Access Control) , die üblicherweise im permanenten Speicher des Controllers gespeichert ist.
  • Ein Repeater ist ein elektronisches Gerät, das ein Netzwerksignal empfängt , es von Störungen befreit und verstärkt. Das Signal wird mit höherer Leistung oder auf die andere Seite eines Hindernisses erneut gesendet , sodass es größere Entfernungen ohne Qualitätsverlust überbrücken kann.
  • Ein Ethernet-Repeater mit mehreren Ports wird als Ethernet-Hub bezeichnet . Neben der Aufbereitung und Verteilung von Netzwerksignalen unterstützt ein Hub die Kollisionserkennung und Fehlerisolierung im Netzwerk. Hubs und Repeater in LANs wurden durch moderne Netzwerk-Switches weitgehend ersetzt.
  • Im Gegensatz zu Hubs, die die Kommunikation an alle Ports weiterleiten, leiten Netzwerk-Switches Frames nur an die an der Kommunikation beteiligten Ports weiter. Switches verfügen üblicherweise über zahlreiche Ports, wodurch eine Sterntopologie für Geräte und die Kaskadierung weiterer Switches ermöglicht wird. Netzwerkbrücken sind analog zu einem Zwei-Port-Switch.
    • Bridges and switches operate at the data link layer of the OSI model and bridge traffic between two or more network segments to form a single local network. Both are devices that forward frames of data between ports based on the destination MAC address in each frame. Network segmentation through bridging and switching helps break down a large, congested network into an aggregation of smaller, more efficient networks.
  • A router is an internetworking device that forwards packets between networks by processing the addressing or routing information included in the packet.
  • Modems (modulator-demodulator) are used to connect network nodes via wire not originally designed for digital network traffic, or for wireless.

Network communication

A communication protocol is a set of rules for exchanging information over a network. Communication protocols have various characteristics, such as being connection-oriented or connectionless, or using circuit switching or packet switching.

In a protocol stack, often constructed per the OSI model, communications functions are divided into protocol layers, where each layer leverages the services of the layer below it until the lowest layer controls the hardware that sends information across the media. The use of protocol layering is ubiquitous across the field of computer networking. An important example of a protocol stack is HTTP, the World Wide Web protocol. HTTP runs over TCP over IP, the internet protocols, which in turn run over IEEE 802.11, the Wi-Fi protocol. This stack is used between a wireless router and a personal computer when accessing the web.

Most modern computer networks use protocols based on packet-mode transmission. A network packet is a formatted unit of data carried by a packet-switched network. Packets consist of two types of data: control information and user data (payload). The control information provides data the network needs to deliver the user data, for example, source and destination network addresses, error detection codes, and sequencing information. Typically, control information is found in packet headers and trailers, with payload data in between.

Die Internetprotokollfamilie , auch TCP/IP genannt, bildet die Grundlage aller modernen Netzwerke und definiert die Protokolle des Internets. Sie bietet verbindungslose und verbindungsorientierte Dienste über ein von Natur aus unzuverlässiges Netzwerk, das mittels Datagrammübertragung über das Internetprotokoll (IP) kommuniziert wird. Im Kern definiert die Protokollfamilie die Adressierungs-, Identifikations- und Routing-Spezifikationen für das Internetprotokoll Version 4 (IPv4) und für IPv6 , die nächste Generation des Protokolls mit deutlich erweiterter Adressierungsfähigkeit. [ 6 ]

Sicherheit

VPNs machen verbundene Nutzer nicht anonym oder unidentifizierbar gegenüber dem nicht vertrauenswürdigen Netzwerkbetreiber, wie beispielsweise einem Internetdienstanbieter (ISP). Sie können jedoch die Privatsphäre der Nutzer verbessern, indem sie verhindern, dass ein ISP auf die über das VPN ausgetauschten privaten Daten zugreifen kann. Durch Verschlüsselung erhöhen VPNs die Vertraulichkeit und reduzieren das Risiko erfolgreicher Datenabfangangriffe . Datenpakete, die über ein VPN übertragen werden, können zudem durch Manipulationsschutz mittels eines Message Authentication Code ( MAC) gesichert werden . Dies verhindert, dass die Nachricht verändert oder manipuliert wird, ohne verworfen zu werden, und erhöht so die Datenintegrität .

Es existieren verschiedene Implementierungen zur Authentifizierung der Verbindungspartner. Tunnelendpunkte können während der VPN-Zugriffsinitiierung auf unterschiedliche Weise authentifiziert werden, beispielsweise durch Whitelisting der Endpunkt -IP-Adresse . Die Authentifizierung kann auch nach dem Aufbau aktiver Tunnel erfolgen, beispielsweise über ein Web-Captive-Portal . Remote-Access-VPNs können zudem Passwörter , Biometrie , Zwei-Faktor-Authentifizierung oder andere kryptografische Verfahren nutzen. Site-to-Site-VPNs verwenden häufig Passwörter ( vorab vereinbarte Schlüssel ) oder digitale Zertifikate .

Split-Tunnelbau

Split-Tunneling ermöglicht es einem Benutzer , gleichzeitig über dieselbe oder unterschiedliche Netzwerkverbindungen auf verschiedene Sicherheitsdomänen zuzugreifen . [ 7 ] Dieser Verbindungszustand wird üblicherweise durch die gleichzeitige Nutzung einer LAN -Netzwerkkarte (NIC), einer Funk-Netzwerkkarte (Funk-NIC), einer WLAN-Netzwerkkarte (WLAN- NIC) und einer VPN-Client-Software realisiert. Split-Tunneling wird meist mithilfe eines Remote-Access-VPN-Clients konfiguriert, der es dem Benutzer ermöglicht, sich gleichzeitig mit einem nahegelegenen WLAN , Ressourcen in einem externen Unternehmensnetzwerk sowie Websites über das Internet zu verbinden.

Nicht jedes VPN unterstützt Split-Tunneling. [ 8 ] [ 9 ] [ 10 ] Zu den Vorteilen von Split-Tunneling zählen die Vermeidung von Engpässen , die Einsparung von Bandbreite (da der Internetverkehr nicht über den VPN-Server geleitet werden muss) und die Möglichkeit, dass sich Benutzer beim Fernzugriff auf Ressourcen nicht ständig neu verbinden müssen. Nachteile sind DNS-Leaks und die potenzielle Umgehung von Sicherheitsvorkehrungen auf Gateway-Ebene, die in der Unternehmensinfrastruktur implementiert sein können. [ 11 ]  Internetdienstanbieter nutzen Split-Tunneling häufig für DNS-Hijacking .

Einstufung

VPN-Klassifizierungsbaum, zuerst basierend auf der Topologie, dann auf der verwendeten Technologie

Topologie

Eine Host-zu-Netzwerk -Konfiguration ist vergleichbar mit dem Anschluss eines oder mehrerer Computer an ein Netzwerk, mit dem sie nicht direkt verbunden werden können. Diese Art der Erweiterung ermöglicht den Zugriff von Computern auf ein lokales Netzwerk (LAN) eines entfernten Standorts oder auf größere Unternehmensnetzwerke wie ein Intranet . Jeder Computer ist für die Aktivierung seines eigenen Tunnels zum gewünschten Netzwerk verantwortlich. Das verbundene Netzwerk kennt pro Tunnel nur einen einzigen entfernten Host. Dies kann für Remote-Mitarbeiter oder für den Zugriff auf private Heim- oder Firmenressourcen genutzt werden, ohne diese im öffentlichen Internet preiszugeben.

Eine Site-to-Site -Konfiguration verbindet zwei Netzwerke. Sie erweitert ein Netzwerk über geografisch getrennte Standorte hinweg. Die Tunnelung erfolgt ausschließlich zwischen Gateway-Geräten an den jeweiligen Netzwerkstandorten. Diese Geräte stellen den Tunnel dann anderen lokalen Netzwerk-Hosts zur Verfügung, die einen Host auf der anderen Seite erreichen möchten. Dies ist nützlich, um Standorte stabil miteinander zu verbinden, beispielsweise Büronetzwerke mit ihrer Zentrale oder ihrem Rechenzentrum. In diesem Fall kann jede Seite die Kommunikation initiieren, sofern sie die andere Seite erreichen kann. Im Kontext von Site-to-Site-Konfigurationen werden die Begriffe Intranet und Extranet verwendet, um zwei unterschiedliche Anwendungsfälle zu beschreiben. [ 12 ] Ein Intranet -Site-to-Site-VPN beschreibt eine Konfiguration, bei der die über das VPN verbundenen Standorte derselben Organisation angehören, während ein Extranet- Site-to-Site-VPN Standorte verschiedener Organisationen verbindet.

Eine Einschränkung herkömmlicher VPNs besteht darin, dass sie Punkt-zu-Punkt -Verbindungen darstellen und Broadcast-Domänen in der Regel nicht unterstützen . Daher werden Kommunikations-, Software- und Netzwerktechnologien, die auf Schicht 2 und Broadcast- Paketen basieren (wie beispielsweise NetBIOS in Windows-Netzwerken ), möglicherweise nicht so umfassend unterstützt wie in einem lokalen Netzwerk . VPN-Varianten wie Virtual Private LAN Service (VPLS) und Schicht-2-Tunneling-Protokolle wurden entwickelt, um diese Einschränkung zu überwinden. [ 13 ]

Vertrauenswürdige und sichere Liefernetzwerke

Vertrauenswürdige VPNs nutzen keine kryptografische Tunnelung; stattdessen verlassen sie sich auf die Sicherheit des Netzwerks eines einzelnen Anbieters, um den Datenverkehr zu schützen. [ 14 ] Multiprotocol Label Switching (MPLS) wird häufig über vertrauenswürdigen VPNs eingesetzt, oft mit QoS-Kontrolle über ein vertrauenswürdiges Bereitstellungsnetzwerk. Ein sicheres VPN vertraut entweder dem zugrunde liegenden Bereitstellungsnetzwerk oder gewährleistet Sicherheit durch einen internen Mechanismus. Sofern das vertrauenswürdige Bereitstellungsnetzwerk nicht ausschließlich zwischen physisch sicheren Standorten verläuft, benötigen sowohl vertrauenswürdige als auch sichere Modelle einen Authentifizierungsmechanismus, damit Benutzer Zugriff auf das VPN erhalten.

Typen

Mobiles VPN

Mobile virtuelle private Netzwerke (VPNs) werden in Umgebungen eingesetzt, in denen der VPN-Endpunkt nicht an eine feste IP-Adresse gebunden ist , sondern sich über verschiedene Netzwerke bewegt, beispielsweise über Mobilfunknetze oder zwischen mehreren WLAN- Zugangspunkten, ohne die sichere VPN-Sitzung oder Anwendungssitzungen zu unterbrechen. [ 15 ] Mobile VPNs finden breite Anwendung im Bereich der öffentlichen Sicherheit , wo sie Polizeibeamten Zugriff auf Anwendungen wie computergestützte Einsatzleitsysteme und Kriminaldatenbanken ermöglichen, [ 16 ] sowie in anderen Organisationen mit ähnlichen Anforderungen, wie etwa im Außendienstmanagement und im Gesundheitswesen. [ 17 ]

DMVPN

Dynamic Multipoint Virtual Private Network (DMVPN) [ 18 ] ist eine dynamische Tunneling- Form eines virtuellen privaten Netzwerks, das auf Cisco IOS -basierten Routern , Huawei AR G3 Routern [ 19 ] und Unix -ähnlichen Betriebssystemen unterstützt wird.

DMVPN ermöglicht die Erstellung eines dynamischen Mesh- VPN-Netzwerks, ohne dass alle möglichen Tunnelendpunkte, wie z. B. IPsec- und ISAKMP -Peers, statisch vorkonfiguriert werden müssen. [ 20 ] DMVPN wird initial als Hub-and-Spoke-Netzwerk konfiguriert, indem die Hubs (VPN-Headends) auf den Spokes statisch eingerichtet werden. Für die Aufnahme neuer Spokes ist keine Änderung der Hub-Konfiguration erforderlich. Mithilfe dieses initialen Hub-and-Spoke-Netzwerks werden Tunnel zwischen den Spokes dynamisch und bedarfsgesteuert aufgebaut, ohne dass zusätzliche Konfigurationen an den Hubs oder Spokes notwendig sind. Diese dynamische Mesh-Funktionalität entlastet den Hub von der Datenweiterleitung zwischen den Spoke-Netzwerken.

EVPN

Ethernet VPN (EVPN) ist eine Technologie zur Übertragung von Ethernet- Datenverkehr der OSI-Schicht 2 als virtuelles privates Netzwerk (VPN) unter Verwendung von Weitverkehrsnetzwerkprotokollen (WAN) . Zu den EVPN-Technologien gehören Ethernet über Multiprotocol Label Switching (MPLS) und Ethernet über Virtual Extensible LAN (VEL) . [ 21 ] [ 22 ]

MPLS-VPN

Multiprotocol Label Switching (MPLS) ist ein Routing-Verfahren in Telekommunikationsnetzen , das Daten anhand von Labels anstatt von Netzwerkadressen von einem Knoten zum nächsten leitet. [ 23 ] Während Netzwerkadressen Endpunkte identifizieren, kennzeichnen MPLS-Labels etablierte Pfade zwischen Endpunkten. MPLS kann Pakete verschiedener Netzwerkprotokolle kapseln .

In der Praxis wird MPLS hauptsächlich zur Weiterleitung von IP -Protokolldateneinheiten und Ethernet-Datenverkehr von VPN-Diensten verwendet . Wichtige Anwendungsgebiete von MPLS sind das Traffic Engineering in der Telekommunikation und MPLS-VPNs . MPLS arbeitet mit IP und dessen Routing-Protokollen, üblicherweise Interior Gateway Protocols (IGPs), zusammen und unterstützt die Erstellung dynamischer, transparenter virtueller Netzwerke mit Traffic Engineering, die Möglichkeit zum Transport von Layer-2-VPNs mit überlappenden Adressräumen sowie Layer-2- Pseudowires , die verschiedene Transportdaten ( IPv4 , IPv6 , ATM, Frame Relay usw.) übertragen können. [ 24 ] [ 25 ]

VPLS

Virtual Private LAN Service (VPLS) ist eine Technologie für virtuelle private Netzwerke, die Ethernet-basierte Punkt-zu-Punkt-Kommunikation über IP- oder MPLS- Netzwerke ermöglicht. Sie erlaubt geografisch verteilten Standorten die gemeinsame Nutzung einer Ethernet -Broadcast-Domäne durch die Verbindung von Servern und Clients über Pseudowires . [ 26 ] Als Pseudowire-Technologien können Ethernet over MPLS , L2TPv3 oder auch GRE verwendet werden . Zwei IETF -Standardisierungs- RFCs (RFC 4761 und RFC 4762) beschreiben den Aufbau von VPLS. Im Gegensatz zu L2TPv3, das nur Punkt-zu-Punkt -OSI-Layer-2- Tunnel zulässt, ermöglicht VPLS beliebige (Mehrpunkt-)Verbindungen. [ 27 ] [ 28 ]

PPVPN

Ein Provider-Provisioned VPN (PPVPN) ist ein virtuelles privates Netzwerk (VPN), das von einem Konnektivitätsdienstanbieter oder einem großen Unternehmen in einem von ihnen selbst betriebenen Netzwerk implementiert wird, im Gegensatz zu einem „Customer-Provisioned VPN“, bei dem das VPN vom Kunden implementiert wird, der den Konnektivitätsdienst zusätzlich zu den technischen Besonderheiten des Anbieters erwirbt.

Protokolle

Die Lebenszyklusphasen eines IPSec-Tunnels in einem virtuellen privaten Netzwerk

Ein virtuelles privates Netzwerk basiert auf einem Tunnelprotokoll und kann mit anderen Netzwerk- oder Anwendungsprotokollen kombiniert werden , um zusätzliche Sicherheit und Funktionalität zu bieten.

IPSec (1996)

Internet Protocol Security (IPsec) ist ein standardbasiertes Sicherheitsprotokoll, das ursprünglich von der Internet Engineering Task Force (IETF) für IPv6 entwickelt wurde und vor der Veröffentlichung von RFC 6434, die es lediglich zu einer Empfehlung machte, in allen standardkonformen IPv6-Implementierungen vorgeschrieben war. [ 29 ] Es wird auch häufig mit IPv4 verwendet .

Das Design von IPSec erfüllt die meisten Sicherheitsanforderungen: Verfügbarkeit, Integrität und Vertraulichkeit . IPsec verwendet Verschlüsselung, indem es ein IP-Paket in ein IPsec-Paket einkapselt . Die Entkapselung erfolgt am Ende des Tunnels, wo das ursprüngliche IP-Paket entschlüsselt und an sein Ziel weitergeleitet wird. IPsec wird häufig auch von Netzwerk-Hardwarebeschleunigern unterstützt [ 30 ] , was IPsec-VPN für Szenarien mit geringem Stromverbrauch, wie z. B. permanente VPN-Konfigurationen für den Fernzugriff, attraktiv macht. [ 31 ] [ 32 ]

IPsec-Tunnel werden über das Internet Key Exchange (IKE)-Protokoll eingerichtet . Mit IKE Version 1 erstellte IPsec-Tunnel (auch bekannt als IKEv1-Tunnel oder oft einfach nur „IPsec-Tunnel“) können allein zur Bereitstellung eines VPN verwendet werden, werden aber häufig mit dem Layer 2 Tunneling Protocol (L2TP) kombiniert, um bestehende L2TP-bezogene Implementierungen für flexiblere Authentifizierungsfunktionen (z. B. Xauth ) wiederzuverwenden .

IKE Version 2, entwickelt von Microsoft und Cisco, kann eigenständig IPsec-VPN-Funktionalität bereitstellen. Zu seinen Hauptvorteilen zählen die native Unterstützung der Authentifizierung über das Extensible Authentication Protocol (EAP) und die nahtlose Wiederherstellung des Tunnels bei einem Wechsel der IP-Adresse des zugehörigen Hosts, wie er typischerweise bei mobilen Endgeräten im Roaming auftritt, unabhängig davon, ob sie sich in 3G- oder 4G -LTE- Netzen befinden.

TLS/SSL (1999)

Transport Layer Security (SSL/TLS) kann den gesamten Netzwerkverkehr tunneln (wie beispielsweise im OpenVPN- und SoftEther-VPN- Projekt [ 33 ] ) oder eine einzelne Verbindung sichern. Zahlreiche Anbieter stellen VPN-Funktionen für den Fernzugriff über TLS bereit. Ein TLS-basiertes VPN kann Verbindungen von Standorten aus herstellen, an denen die übliche TLS-basierte Webnavigation ( HTTPS ) unterstützt wird, ohne dass zusätzliche Konfigurationen erforderlich sind.

OpenSSH (1999)

OpenSSH bietet VPN-Tunneling (nicht zu verwechseln mit Portweiterleitung ) zur Sicherung von Fernverbindungen zu einem Netzwerk, zu Verbindungen zwischen Netzwerken und zu entfernten Systemen. Der OpenSSH-Server unterstützt eine begrenzte Anzahl gleichzeitiger Tunnel. Die VPN-Funktion selbst unterstützt keine persönliche Authentifizierung. [ 34 ] SSH wird häufiger für Fernverbindungen zu Rechnern oder Netzwerken als für eine Site-to-Site-VPN-Verbindung verwendet.

OpenVPN (2001)

OpenVPN ist ein kostenloses Open-Source -VPN-Protokoll, das auf dem TLS-Protokoll basiert. Es unterstützt Perfect Forward Secrecy und die meisten modernen sicheren Verschlüsselungssuiten wie AES , Serpent , Twofish usw. Es wird derzeit von OpenVPN Inc., einer gemeinnützigen Organisation , die sichere VPN-Technologien anbietet, weiterentwickelt und aktualisiert.

SSTP (2007)

Das Secure Socket Tunneling Protocol (SSTP) ist eine Form des VPN-Tunnels, der einen Mechanismus zur Übertragung von Point-to-Point Protocol (PPP)-Datenverkehr über einen SSL/TLS- Kanal bietet.

Wireguard (2015)

WireGuard ist ein Protokoll, das im Vergleich zu OpenVPN ressourcenschonender sein soll. [ 35 ] Im Jahr 2020 wurde WireGuard in den Linux- [ 36 ] und Android- Kernel [ 37 ] integriert , wodurch es für VPN-Anbieter zugänglich wurde. Standardmäßig verwendet WireGuard das Curve25519- Protokoll für den Schlüsselaustausch und ChaCha20-Poly1305 für die Verschlüsselung und Nachrichtenauthentifizierung. Es bietet aber auch die Möglichkeit, einen symmetrischen Schlüssel vorab zwischen Client und Server auszutauschen . [ 38 ]

Andere

Native and third-party support

Desktop, smartphone and other end-user device operating systems usually support configuring remote access VPN from their graphical or command-line tools.[48][49][50] However, due to the variety of, often non standard, VPN protocols, there exist many third-party applications that implement additional protocols not yet or no longer natively supported by the OS. For instance, Android lacked native IPsec IKEv2 support until version 11,[51] and users needed to install third-party apps in order to connect that kind of VPN. Conversely, Windows does not natively support plain IPsec IKEv1 remote access native VPN configuration (commonly used by Cisco and Fritz!Box VPN solutions).

Netzwerkgeräte wie Firewalls verfügen häufig über VPN-Gateway-Funktionen für Fernzugriff oder Site-to-Site-Verbindungen. Ihre Verwaltungsschnittstellen ermöglichen die einfache Einrichtung virtueller privater Netzwerke mit einer Auswahl unterstützter Protokolle. In einigen Fällen, wie beispielsweise bei Open-Source-Betriebssystemen für Firewalls und Netzwerkgeräte (wie OpenWrt , IPFire , PfSense oder OPNsense ), lässt sich die Unterstützung für zusätzliche VPN-Protokolle durch die Installation fehlender Softwarekomponenten oder Drittanbieter-Apps erweitern.

Kommerzielle Geräte mit VPN-Funktionen, die auf proprietären Hardware- oder Softwareplattformen basieren, unterstützen in der Regel ein einheitliches VPN-Protokoll, erlauben jedoch keine Anpassungen außerhalb der implementierten Anwendungsfälle. Dies ist häufig der Fall bei Geräten, die auf Hardwarebeschleunigung von VPNs angewiesen sind, um einen höheren Durchsatz zu erzielen oder eine größere Anzahl gleichzeitig verbundener Benutzer zu unterstützen.

Gesellschaft und Kultur

Einzelnutzer

Laut einer Schätzung aus dem Jahr 2022 nutzen 3 % der chinesischen Internetnutzer VPNs, verglichen mit 8,5 % der Amerikaner. [ 52 ] [ 53 ] In China werden VPNs zunehmend blockiert, und unerlaubte Nutzung kann mit Geldstrafen und strafrechtlicher Verfolgung geahndet werden. [ 52 ] Basierend auf durchgesickerten Regierungsdokumenten schätzte ChinaFile für 2026, dass die VPN-Nachfrage in China im niedrigen einstelligen Bereich liegen würde. Zudem wurde festgestellt, dass ausländische Apps, die von der Großen Firewall blockiert werden, extrem geringe Zugriffszahlen aufweisen, insbesondere im Vergleich zu inländischen Apps; die fünf beliebtesten inländischen Apps verzeichneten 1.000-mal mehr Zugriffszahlen als die fünf beliebtesten ausländischen Apps. [ 54 ]

Im Jahr 2025 nutzten etwa 1,75 Milliarden Menschen VPNs. Bis 2027 wird ein Wachstum dieses Marktes auf 76 Milliarden US-Dollar prognostiziert. [ 55 ]

Angesichts der Internetbeschränkungen und -blockaden in Russland entwickelten Internetaktivisten 2020 im Rahmen eines von Roskomsvoboda organisierten Hackathons für digitale Rechte das VPN-Projekt Amnezia . Der Dienst erfreute sich unter russischen Nutzern großer Beliebtheit, da er den Zugang zu gesperrten Ressourcen ermöglichte und Funktionen zur Verbesserung der Anonymität und zum Schutz vor Verkehrsanalyse bot. [ 56 ] [ 57 ]

Siehe auch

Referenzen

  1. ^ „Virtuelles privates Netzwerk“ . Glossar des NIST Computer Security Resource Center . Archiviert vom Original am 2. Januar 2023. Abgerufen am 2. Januar 2023 .
  2. ^ „Was ist ein VPN? – Virtuelles privates Netzwerk“ . Cisco . Archiviert vom Original am 31. Dezember 2021. Abgerufen am 5. September 2021 .
  3. ^ Mason , Andrew G. (2002). Cisco Secure Virtual Private Network . Cisco Press. S.  7. ISBN 978-1-58705-033-6Die
  4. ^ Peterson, Larry; Davie, Bruce (2000). Computernetzwerke: Ein systemorientierter Ansatz . Singapur: Harcourt Asia. ISBN 978-981-4066-43-3Abgerufen am 24. Mai 2025 .
  5. ^ Anniss, Matthew (2015). Understanding Computer Networks . Vereinigte Staaten: Capstone. ISBN 978-1-4846-0907-1Die
  6. ^ Tanenbaum, Andrew S. (2003). Computernetzwerke (4. Aufl.). Prentice Hall .
  7. ^ „Was ist VPN Split Tunneling?“ . Fortinet . Abgerufen am 11. Juni 2025 .
  8. ^ „VPN-Split-Tunneling“ . NordVPN .
  9. ^ Long, Moe (22. Juli 2021). „Bestes VPN für Split-Tunneling“ . Tech Up Your Life . Abgerufen am 21. Oktober 2021 .
  10. ^ „Was ist VPN-Split-Tunneling? Alles, was Sie wissen müssen . “ Surfshark . Abgerufen am 11. Juni 2025 .
  11. ^ Remote Access VPN and a Twist on the Dangers of Split Tunneling , 10. Mai 2005 , abgerufen am 5. Dezember 2017
  12. ^ RFC 3809 – Allgemeine Anforderungen an von Anbietern bereitgestellte virtuelle private Netzwerke . IETF . Abschnitt 1.1. doi : 10.17487/RFC3809 . RFC 3809 .
  13. ^ Sowells, Julia (7. August 2017). „Virtual Private Network (VPN): Was ein VPN ist und wie es funktioniert“ . Hackercombat . Archiviert vom Original am 17. Juni 2022. Abgerufen am 7. November 2021 .
  14. ^ Cisco Systems, Inc. (2004). Internetworking Technologies Handbook . Networking Technology Series (4. Aufl.). Cisco Press. S. 233. ISBN 978-1-58705-119-7Abgerufen am 15. Februar 2013. [...] VPNs, die dedizierte Verbindungen wie Frame Relay nutzen, werden manchmal als vertrauenswürdige VPNs bezeichnet, da die Kunden darauf vertrauen , dass die von den Dienstanbietern betriebenen Netzwerkeinrichtungen nicht kompromittiert werden.
  15. ^ Phifer, Lisa. „Mobile VPN: Closing the Gap“ Archiviert am 6. Juli 2020 in der Wayback Machine , SearchMobileComputing.com , 16. Juli 2006.
  16. ^ Willett, Andy. „Solving the Computing Challenges of Mobile Officers“ Archiviert am 12. April 2020 in der Wayback Machine , www.officer.com , Mai 2006.
  17. ^ Cheng, Roger. „Lost Connections“ Archiviert am 28. März 2018 in der Wayback Machine , The Wall Street Journal , 11. Dezember 2007.
  18. ^ Cisco-Ingenieure. „Dynamische Multipoint-IPsec-VPNs (Skalierung von IPsec-VPNs mithilfe von Multipoint GRE/NHRP)“ . Cisco . Abgerufen am 24. September 2017 .
  19. ^ Huawei DSVPN-Konfiguration
  20. ^ Kurniadi, SH; Utami, E.; Wibowo, FW (Dezember 2018). „Aufbau eines dynamischen Mesh-VPN-Netzwerks mit MikroTik-Router“ . Journal of Physics: Konferenzreihe . 1140 012039. doi : 10.1088/1742-6596/1140/1/012039 . ISSN 1742-6596 . 
  21. ^ „EVPN-Übersicht – TechLibrary – Juniper Networks“ . www.juniper.net . Archiviert vom Original am 11. Mai 2017. Abgerufen am 19. Dezember 2019 .
  22. ^ „Understanding EVPN with VXLAN Data Plane Encapsulation - TechLibrary - Juniper Networks“ . www.juniper.net . Archiviert vom Original am 13. Mai 2017. Abgerufen am 19. Dezember 2019 .
  23. ^ Sturt, Robert; Rosencrance, Linda; Scarpati, Jessica (28. März 2023). „Was ist Multiprotocol Label Switching (MPLS)?“ . techtarget.com . Abgerufen am 21. Juli 2025 .
  24. ^ RFC 3031 
  25. ^ S. Bryant; P. Pate (Hrsg.). (März 2005). Pseudo Wire Emulation Edge-to-Edge (PWE3) Architecture . Network Working Group. doi : 10.17487/RFC3985 . RFC 3985 .Zur Information. Aktualisiert gemäß RFC  5462 .
  26. ^ H. Shah (Cisco Systems) (Januar 2015). „RFC 7436: IP‑Only LAN Service (IPLS)“ . IETF . Abgerufen am 7. August 2025 .
  27. ^ Rekhter, Yakov; Kompella, Kireeti (Januar 2007). Virtual Private LAN Service (VPLS) Using BGP for Auto-Discovery and Signaling (Bericht). Internet Engineering Task Force.
  28. ^ Lasserre, Marc; Kompella, Vach (Januar 2007). Virtual Private LAN Service (VPLS) Using Label Distribution Protocol (LDP) Signaling (Bericht). Internet Engineering Task Force.
  29. ^ E. Jankiewicz; J. Loughney; T. Narten (Dezember 2011). IPv6-Knotenanforderungen . Internet Engineering Task Force . doi : 10.17487/RFC6434 . ISSN 2070-1721 . RFC 6434 . Veraltet. S. 17. Ersetzt durch RFC  8504. Ersetzt RFC  4294. Zuvor schrieb IPv6 die Implementierung von IPsec vor und empfahl den Schlüsselverwaltungsansatz von IKE. Dieses Dokument aktualisiert diese Empfehlung, indem es die Unterstützung der IPsec-Architektur gemäß RFC 4301 für alle IPv6-Knoten als SOLLTE festlegt .
  30. ^ „Sicherheit für VPNs mit IPsec-Konfigurationsleitfaden, Cisco IOS Release 15S – VPN-Beschleunigungsmodul [Unterstützung]“ . Cisco . Abgerufen am 9. Juli 2024 .
  31. ^ „VPN-Übersicht für die Bereitstellung auf Apple-Geräten“ . Apple Support . Abgerufen am 9. Juli 2024 .
  32. ^ „Über Always On VPN für den Remotezugriff auf Windows Server“ . learn.microsoft.com . 22. Mai 2023. Abgerufen am 9. Juli 2024 .
  33. ^ „1. Ultimative, leistungsstarke VPN-Konnektivität“ . www.softether.org . SoftEther VPN-Projekt. Archiviert vom Original am 8. Oktober 2022. Abgerufen am 8. Oktober 2022 .
  34. ^ „ssh(1) – OpenBSD-Handbuchseiten“ . man.openbsd.org . Archiviert vom Original am 5. Juli 2022. Abgerufen am 4. Februar 2018 .
  35. ^ Preneel, Bart; Vercauteren, Frederik, Hrsg. (11. Juni 2018). Angewandte Kryptographie und Netzwerksicherheit . Springer. ISBN 978-3-319-93387-0Archiviert vom Original am 18. Februar 2019. Abgerufen am 25. Juni 2018 .
  36. ^ Salter, Jim (30. März 2020). „WireGuard VPN erreicht Version 1.0.0 – und wird im nächsten Linux-Kernel enthalten sein“ . Ars Technica . Archiviert vom Original am 31. März 2020. Abgerufen am 30. Juni 2020 .
  37. ^ "Diff - 99761f1eac33d14a4b1613ae4b7076f41cb2df94^! - kernel/common - Git at Google" . android.googlesource.com . Archiviert vom Original am 29. Juni 2022 . Abgerufen am 30. Juni 2020 .
  38. ^ Younglove, R. (Dezember 2000). „Virtuelle private Netzwerke – wie sie funktionieren“ . Computing & Control Engineering Journal . 11 (6): 260–262 . doi : 10.1049/cce:20000602 (inaktiv seit 12. Juli 2025). ISSN 0956-3385 . {{cite journal}}: CS1 Wartung: DOI inaktiv ab Juli 2025 ( Link )
    • Benjamin Dowling und Kenneth G. Paterson (12. Juni 2018). „Eine kryptographische Analyse des WireGuard-Protokolls“. Internationale Konferenz für Angewandte Kryptographie und Netzwerksicherheit . ISBN 978-3-319-93386-3Die
  39. ^ „OpenConnect“ . Archiviert vom Original am 29. Juni 2022. Abgerufen am 8. April 2013. OpenConnect ist ein Client für Ciscos AnyConnect SSL-VPN . [...] OpenConnect wird von Cisco Systems weder offiziell unterstützt noch steht es in irgendeiner Verbindung zu Cisco Systems. Es ist lediglich mit deren Geräten kompatibel.
  40. ^ „Warum TCP über TCP eine schlechte Idee ist“ . sites.inka.de . Archiviert vom Original am 6. März 2015. Abgerufen am 24. Oktober 2018 .
  41. ^ „Markenstatus & Dokumentenabruf“ . tarr.uspto.gov . Archiviert vom Original am 21. März 2012. Abgerufen am 8. Oktober 2022 .
  42. ^ Fuller, Johnray; Ha, John (2002). Red Hat Linux 9: Red Hat Linux Security Guide (PDF) . Vereinigte Staaten: Red Hat, Inc. S.  48–53 . Archiviert (PDF) vom Original am 14. Oktober 2022. Abgerufen am 8. September 2022 .
  43. ^ Titz, Olaf (20. Dezember 2011). „CIPE – Crypto IP Encapsulation“ . CIPE – Crypto IP Encapsulation . Archiviert vom Original am 18. Mai 2022. Abgerufen am 8. September 2022 .
  44. ^ Titz, Olaf (2. April 2013). „CIPE – verschlüsselte IP in UDP-Tunneln“ . SourceForge . Archiviert vom Original am 8. September 2022. Abgerufen am 8. September 2022 .
  45. ^ Layer Two Tunneling Protocol "L2TP" (Archiviert am 30. Juni 2022 in der Wayback Machine , RFC 2661 , W. Townsley et al. , August 1999) 
  46. ^ IP-basierte virtuelle private Netzwerke, archiviert am 9. Juli 2022 in der Wayback Machine , RFC 2341 , A. Valencia et al. , Mai 1998 
  47. ^ Point-to-Point Tunneling Protocol (PPTP) , archiviert am 2. Juli 2022 in der Wayback Machine , RFC 2637 , K. Hamzeh et al. , Juli 1999 
  48. ^ „Verbindung zu einem VPN unter Windows herstellen – Microsoft Support“ . support.microsoft.com . Abgerufen am 11. Juli 2024 .
  49. ^ „Verbindung zu einem virtuellen privaten Netzwerk (VPN) auf Android herstellen“ . Abgerufen am 11. Juli 2024 .
  50. ^ „VPN-Einstellungen – Übersicht für Apple-Geräte“ . Apple Support . Abgerufen am 11. Juli 2024 .
  51. ^ „IPsec/IKEv2-Bibliothek“ . Android Open Source Project . Abgerufen am 11. Juli 2024 .
  52. ^ a b Batke, Jessica; Edelson, Laura (30. Juni 2025). „Das Locknet: Wie China sein Internet kontrolliert und warum das wichtig ist“ . ChinaFile . Asia Society . Abgerufen am 7. Juli 2025 .
  53. ^ Edwards, David (21. Juli 2022). „Wichtige VPN-Statistiken: Was sagen uns die Zahlen?“ . Robotics & Automation News . Abgerufen am 17. Mai 2026 .
  54. ^ Batke, Jessica; Edelson, Laura (2. Juni 2026). „Durchgesickerte Dokumente belegen den Erfolg von Chinas Vorgehen gegen VPNs“ . ChinaFile . Asia Society . Abgerufen am 2. Juni 2026 .
  55. ^ Hooson, Mark (3. März 2025). „VPN-Statistiken“ . Forbes UK . Abgerufen am 19. März 2025 .
  56. ^ Borak, Masha (7. April 2023). „Das Open-Source-VPN umgeht die russische Zensur“ . Wired . Abgerufen am 28. April 2026 .
  57. ^ Gill, Mark (27. März 2026). „Amnezia VPN-Test 2026“ . TechRadar . Abgerufen am 28. April 2026 .

Weiterführende Literatur