Die Hosts- Datei ist eine Betriebssystemdatei, die Hostnamen IP -Adressen zuordnet . Es handelt sich um eine einfache Textdatei . Ursprünglich wurde eine Datei namens HOSTS.TXT manuell gepflegt und vom Stanford Research Institute über eine Dateifreigabe für die ARPANET- Mitglieder bereitgestellt. Sie enthielt die von den Mitgliedsorganisationen beigesteuerten Hostnamen und Adressen. Das Domain Name System (DNS) , erstmals 1983 beschrieben und 1984 implementiert [ 1 ] , automatisierte die Veröffentlichung und ermöglichte die sofortige und dynamische Auflösung von Hostnamen im schnell wachsenden Netzwerk. In modernen Betriebssystemen dient die Hosts-Datei weiterhin als alternativer Namensauflösungsmechanismus und kann häufig im Rahmen von Funktionen wie dem Name Service Switch ( NSS) entweder als primäre oder als Ausweichmethode konfiguriert werden.

Zweck

Die Hosts-Datei ist eine von mehreren Systemfunktionen, die bei der Adressierung von Netzwerkknoten in einem Computernetzwerk helfen. Sie ist ein üblicher Bestandteil der Internetprotokoll- Implementierung (IP) eines Betriebssystems und dient dazu, für Menschen lesbare Hostnamen in numerische Protokolladressen, sogenannte IP-Adressen , zu übersetzen , die einen Host in einem IP-Netzwerk identifizieren und lokalisieren.

In einigen Betriebssystemen wird der Inhalt der Hosts-Datei anderen Namensauflösungsmethoden wie dem Domain Name System (DNS) vorgezogen. Viele Systeme bieten jedoch Namensdienst- Switches, z. B. nsswitch.conf für Linux und Unix , um individuelle Anpassungen zu ermöglichen. Im Gegensatz zu entfernten DNS-Resolvern unterliegt die Hosts-Datei der direkten Kontrolle des lokalen Computeradministrators. [ 2 ]

Dateiinhalt

Die Hosts-Datei enthält Textzeilen, die jeweils aus einer IP-Adresse im ersten Textfeld und einem oder mehreren Hostnamen bestehen. [ 3 ] Die Hostnamen sind den IP-Adressen zugeordnet, nicht umgekehrt. Die einzelnen Felder sind durch Leerzeichen getrennt – Tabulatoren werden aus historischen Gründen oft bevorzugt, Leerzeichen sind aber ebenfalls möglich. Kommentarzeilen können eingefügt werden; sie werden durch ein Oktett (#) am Zeilenanfang gekennzeichnet. Vollständig leere Zeilen in der Datei werden ignoriert. [ 4 ] Eine typische Hosts-Datei könnte beispielsweise Folgendes enthalten:

127.0.0.1 localhost loopback ::1 localhost 

Dieses Beispiel enthält lediglich Einträge für die Loopback-Adressen des Systems und deren Hostnamen – ein typischer Standardinhalt der Hosts-Datei. Es verdeutlicht, dass eine IP-Adresse mehrere Hostnamen haben kann (z. B. localhost und loopback ) und dass ein Hostname sowohl IPv4- als auch IPv6 -Adressen zugeordnet sein kann , wie in der ersten bzw. zweiten Zeile dargestellt.

Speicherort im Dateisystem

Der Speicherort der Hosts-Datei in der Dateisystemhierarchie variiert je nach Betriebssystem. Sie heißt üblicherweise hosts , ohne Dateiendung.

Betriebssystem Version(en) Standort
Unix , Unix-ähnlich , POSIX/etc/hosts [ 5 ]
Microsoft Windows 3.1%WinDir% \HOSTS
95 , 98 , ME%WinDir% \hosts [ 6 ]
NT , 2000 , XP , [ 7 ] 2003 , Vista , 2008 , 7 , 2012 , 8 , 10 , 11%SystemRoot% \System32\drivers\etc\hosts [ 8 ]
Windows Mobile , Windows PhoneRegistrierungsschlüssel unter HKEY_LOCAL_MACHINE\Comm\Tcpip\Hosts
Apple Macintosh9 Jahre und früher Einstellungen oder Systemordner
Mac OS X 10.0–10.1.5 [ 9 ](Hinzugefügt über NetInfo oder niload)
Mac OS X 10.2 und neuer /etc/hosts (ein symbolischer Link zu /private/etc/hosts ) [ 9 ]
Novell NetWareSYS:etc\hosts
OS/2 , eComStation , ArcaOS"bootdrive":\mptn\etc\
SymbianSymbian OS 6.1–9.0 C:\system\data\hosts
Symbian OS 9.1+C:\private\10000882\hosts
MorphOSNetStack ENVARC:sys/net/hosts
AmigaOS< 4 AmiTCP:db/hosts
4 DEVS:Internet/hosts
AROSENVARC:AROSTCP/db/hosts
Android/etc/hosts (ein symbolischer Link zu /system/etc/hosts )
iOSiOS 2.0 und neuer /etc/hosts (ein symbolischer Link zu /private/etc/hosts )
TOPS-20SYSTEM:HOSTS.TXT
Plan 9/lib/ndb/hosts
BeOS/boot/beos/etc/hosts [ 10 ]
Haiku/system/settings/network/hosts [ 11 ]
OpenVMSUCX UCX$HOST
TCPwareTCPIP$HOST
RISC OS3,7, 5 !Boot.Resources.!Internet.files.Hosts
spätere Bootsequenz !Boot.Choices.Hardware.Disabled.Internet.Files.Hosts [ 12 ]

Geschichte

Das ARPANET , der Vorläufer des Internets , besaß keine verteilte Hostnamendatenbank. Jeder Netzwerkknoten verwaltete seine eigene Karte der Netzwerkknoten nach Bedarf und vergab ihnen für die Systemnutzer einprägsame Namen. Es gab keine Möglichkeit sicherzustellen, dass alle Verweise auf einen bestimmten Knoten im Netzwerk denselben Namen verwendeten, noch konnte man die Hosts-Datei eines anderen Computers auslesen, um automatisch eine Kopie zu erhalten.

Die geringe Größe des ARPANET hielt den Verwaltungsaufwand für die Pflege einer korrekten Hosts-Datei gering. Netzwerkknoten hatten typischerweise eine Adresse und konnten mehrere Namen haben. Mit der zunehmenden Verbreitung lokaler TCP/IP- Computernetzwerke wurde die Pflege der Hosts-Dateien jedoch zu einer größeren Belastung für Systemadministratoren, da immer häufiger Netzwerke und Netzwerkknoten hinzugefügt wurden.

Der erste Versuch zur Standardisierung der Hostnamenvergabe wurde 1971 von Peggy Karp von MITRE unternommen . Sie veröffentlichte RFC 226, in dem sie einen Standard für Hostnamen-Mnemoniken definierte, die Netzwerkadressen lesbaren Namen zuordneten. [ 13 ] Karps Liste gilt als die erste hosts.txt-Datei und Vorläufer der heutigen Root-Datei. [ 14 ] Spätere Standardisierungsbemühungen, wie die Formatspezifikation der Datei HOSTS.TXT in RFC 952 und Verteilungsprotokolle, z. B. der in RFC 953 beschriebene Hostname-Server, trugen zwar zur Lösung dieser Probleme bei, doch die zentralisierte und monolithische Natur der Hosts-Dateien machte schließlich die Entwicklung des verteilten Domain Name Systems (DNS) notwendig.

Auf einigen älteren Systemen existiert eine Datei namens networks, die einer Hosts-Datei ähnelt und die Namen von Netzwerken enthält. [ 15 ]

Erweiterte Anwendungen

Die Hosts-Datei dient der Auflösung von Hostnamen und kann verwendet werden, um beliebige Hostnamen oder Domänennamen für die Verwendung im lokalen System zu definieren.

Umleitung lokaler Domänen
Einige Entwickler und Administratoren von Webdiensten und Intranets definieren lokal definierte Domänen in einem LAN für verschiedene Zwecke, beispielsweise um auf interne Ressourcen des Unternehmens zuzugreifen oder um lokale Websites in der Entwicklung zu testen. [ 16 ]
Internetressourcenblockierung
Einträge in der Hosts-Datei können verwendet werden, um Online-Werbung oder die Domains bekannter schädlicher Ressourcen und Server, die Spyware , Adware und andere Malware enthalten, zu blockieren . Dies kann erreicht werden, indem Einträge für diese Websites hinzugefügt werden, um Anfragen an eine nicht existierende Adresse oder an ein harmloses Ziel wie den lokalen Rechner umzuleiten . [ 17 ] Kommerzielle Softwareanwendungen können verwendet werden, um die Hosts-Datei automatisch mit Einträgen bekannter unerwünschter Internetressourcen zu füllen. Darüber hinaus sind öffentlich zugängliche, von Benutzern erstellte Hosts-Dateien verfügbar, die störende Server blockieren. [ 18 ] [ 19 ]
Fravia beschrieb diese Dateien in seinen Anti-Werbung-Seiten, wo diese Verwendung des Begriffs „Host“ erstmals veröffentlicht wurde, unter anderem als „Schriftrollen“, „wertvoll“ und „mächtig“. [ 19 ]
Softwarepiraterie
Einige Raubkopien von Software nutzen eine modifizierte Hosts-Datei, um zu verhindern, dass die Software die Aktivierungsserver des Herausgebers kontaktiert , obwohl Aktivierungsserver manchmal auch in allgemeinen Hosts-Dateien enthalten sind. [ 20 ]

Sicherheitsprobleme

Die Hosts-Datei kann eine Einfallstor für Schadsoftware darstellen. Sie kann beispielsweise von Adware , Computerviren oder Trojanern manipuliert werden , um den Datenverkehr vom eigentlichen Ziel auf Webseiten mit schädlichen oder unerwünschten Inhalten umzuleiten. [ 21 ] Der weit verbreitete Computerwurm Mydoom.B blockierte den Zugriff von Nutzern auf Webseiten zum Thema Computersicherheit und Antivirensoftware und beeinträchtigte zudem den Zugriff des infizierten Computers auf die Microsoft Windows Update- Website.

In einigen Fällen hat Schadsoftware die Bibliothek, die für das Laden der Hosts-Datei zuständig ist, so verändert, dass sie diese auf eine Datei umleitet, die sie frei kontrollieren kann. [ 22 ]

Siehe auch

Referenzen

  1. ^ Internet Systems Consortium. „Die am weitesten verbreitete Nameserver-Software: BIND“ . Geschichte von BIND . Abgerufen am 1. Juli 2017 .
  2. ^ Cisco Networking Academy Program: First-Year Companion Guide (2. Aufl.). Cisco Systems. 2002. S. 676. ISBN 1-58713-025-4Die
  3. ^ Penetration Testing: Ein Überlebensleitfaden . Packt Publishing Ltd. 18. Januar 2017. ISBN 978-1-78728-988-8Die
  4. ^ "Hosts(5) - Linux-Handbuchseite" .
  5. ^ „Linux Network Administrators Guide: Writing hosts and networks files“ . Abgerufen am 16. Mai 2010 .
  6. ^ „Hosts-Datei“ . Archiviert vom Original am 20. Juli 2011. Abgerufen am 10. August 2011 .
  7. ^ „Microsoft KB Q314053: TCP/IP- und NBT-Konfigurationsparameter für Windows XP“ . Abgerufen am 28. August 2010 .
  8. ^ „Microsoft KB 972034 Revision 2.0: Standard-Hosts-Dateien“ . Abgerufen am 28. August 2010 .
  9. ^ a b „Mac OS X: Wie man Hosts zur lokalen Hosts-Datei hinzufügt“ . Archiviert vom Original am 05.01.2012 . Abgerufen am 28.08.2010 .
  10. ^ „Der Haiku/BeOS-Tippserver“ . Archiviert vom Original am 28. Januar 2013. Abgerufen am 30. November 2012 .
  11. ^ „Haiku UserGuide:Network“ . Abgerufen am 17. Januar 2019 .
  12. ^ RISC OS 6.14
  13. ^ Karp, Peggy M. (September 1971). „Standardisierung von Host-Mnemotechniken“ (RFC 226). IETF.
  14. ^ Froomkin, A. Michael (Februar 2001). „Die Kollision von Markenrechten, Domainnamen und Rechtsstaatlichkeit im Cyberspace“. Communications of the ACM . 44 (2): 91–97 . doi : 10.1145/359205.359236 .
  15. ^ „Schreiben von Host- und Netzwerkdateien“ . tldp.org . Abgerufen am 2. März 2021 .
  16. ^ „Erstellen/Testen über die Hosts-Datei“ . Webhosting der Ohio State University . OCIO. 9. Oktober 2015. Abgerufen am 5. August 2018 .
  17. ^ Gordon; -Tx. „Gordon und -Tx erklären die Verwendung der Hosts-Datei von Gordon“ . Web Searchlores . +Fravia. Archiviert vom Original am 26. Dezember 2018. Abgerufen am 5. August 2018 .
  18. ^ Hofstetter, Constantin. „/etc/hosts zum Blockieren von Schockseiten usw.“ GitHub . Abgerufen am 5. August 2018 .
  19. ^ a b Vianello, Francesco "Fravia". "Antiadvertisement Lab" . Web Searchlores . +Fravia. Archiviert vom Original am 15. Mai 2009. Abgerufen am 5. August 2018 .
  20. ^ "yhosts" . GitHub . Abgerufen am 21. Juni 2021 .
  21. ^ „Trojan.Qhosts entfernen“ . Symantec . Archiviert vom Original am 21. Oktober 2007. Abgerufen am 16. Mai 2010 .
  22. ^ Arntz, Pieter (21. September 2016). „Hosts-Datei-Hijacking“ . Malwarebytes Labs . Abgerufen am 5. August 2018 .