Ein vollqualifizierter Domänenname ( FQDN ), manchmal auch absoluter Domänenname genannt [ 1 ], ist ein Domänenname, der seine genaue Position in der Baumhierarchie des Domain Name Systems (DNS) angibt . Er spezifiziert alle Domänenebenen, einschließlich der Top-Level-Domain und der Root-Zone. [ 2 ] Ein vollqualifizierter Domänenname zeichnet sich durch seine eindeutige DNS- Zonenposition in der Hierarchie der DNS-Bezeichnungen aus: Er kann nur auf eine Weise interpretiert werden.
Definition

Ein vollqualifizierter Domänenname .( FQDN ) wird üblicherweise als Liste von Domänenbezeichnungen geschrieben, die durch Punkte getrennt sind . Die oberste Domänenhierarchie eines FQDN beginnt mit der Bezeichnung ganz rechts. Beispielsweise ist im FQDN eine Bezeichnung direkt unter der Root-Zone, ist unter verschachtelt und schließlich ist unter verschachtelt . [ 3 ]somehost.example.comcomexamplecomsomehostexample.com
Die oberste Ebene jedes Domainnamens ist die DNS-Root-Zone . Sie wird als leeres Label dargestellt und kann in einem FQDN mit einem abschließenden Punkt abgebildet werden, z. B. „example.com“ somehost.example.com.. Ein abschließender Punkt wird üblicherweise implizit vorausgesetzt und von den meisten Anwendungen weggelassen. Nachgestellte Punkte sind jedoch im Standardformat für DNS- Zonendateien erforderlich und dienen der Unterscheidung von Fällen, in denen ein FQDN keine weiteren Label-Trennzeichen enthält, wie beispielsweise die FQDNs der Root-Zone selbst und einer Top-Level-Domain . [ 4 ]
Die Länge jedes Labels muss zwischen 1 und 63 Oktetten liegen , und der vollständige Domainname ist auf 255 Oktette begrenzt, Punkte eingeschlossen. [ 3 ]
Relative Domainnamen
Ein relativer Domänenname ist ein Domänenname, der nicht alle Bezeichnungen enthält. [ 5 ] Er wird auch als partiell qualifizierter Domänenname (PQDN) bezeichnet. [ 6 ] Hostnamen können als relative Domänennamen verwendet werden.
Verwendung
Durch Punkte getrennte, vollqualifizierte Domainnamen sind die primär verwendete Form für die lesbare Darstellung eines Domainnamens. Sie werden nicht in der internen Darstellung von Bezeichnungen in einer DNS-Nachricht verwendet [ 7 ] , dienen aber zur Referenzierung von Domains in einigen TXT-Einträgen und können in Resolver- Konfigurationen, System- Hosts-Dateien und URLs vorkommen .
Webadressen verwenden typischerweise FQDNs zur Darstellung des Hosts, da dies sicherstellt, dass die Adresse in jedem Netzwerk identisch interpretiert wird. Relative Hostnamen sind von einigen Protokollen, darunter HTTP , erlaubt, von anderen, wie dem Simple Mail Transfer Protocol (SMTP), jedoch nicht. [ 8 ]
Referenzen
- ^ Mockapetris, Paul. Domain names – Implementation and Specification . IETF . doi : 10.17487/RFC1035 . RFC 1035 .
- ^ April N. Marine; Joyce K. Reynolds; Gary Scott Malkin (März 1994). „Fragen zum Domain Name System“ . Antworten auf häufig gestellte Fragen von „neuen Internetnutzern“ . IETF . Abschnitt 5. doi : 10.17487/RFC1594 . RFC 1594. Abgerufen am 29. April 2013. Stellt man sich das DNS als Baumstruktur vor, in der jeder Knoten eine eigene Bezeichnung hat, so besteht der vollqualifizierte Domainname eines bestimmten Knotens aus dessen Bezeichnung ,
gefolgt von den Bezeichnungen aller anderen Knoten zwischen diesem Knoten und der Wurzel des Baums.
- ^ a b R. Elz; R. Bush (Juli 1997). Klarstellungen zur DNS-Spezifikation . IETF . doi : 10.17487/RFC2181 . RFC 2181. Abgerufen am 27. November 2024 .
- ^ Fisher, Tim. „FQDN“ . About.com. Archiviert vom Original am 3. April 2013. Abgerufen am 20. März 2013 .
- ^ Gavron, Ehud (Oktober 1993). „Ein Sicherheitsproblem und ein Lösungsvorschlag bei weit verbreiteter DNS-Software“ . Archiviert vom Original am 17. Oktober 2020. Abgerufen am 1. Oktober 2020 .
- ^ „Vollqualifizierter Domainname (FQDN) und teilweise qualifizierter Domainname (PQDN)“ . Archiviert vom Original am 16. März 2015. Abgerufen am 23. März 2015 .
- ^ „Wireshark Q&A“ . osqa-ask.wireshark.org . Archiviert vom Original am 13. April 2021. Abgerufen am 13. April 2021 .
- ^ Klensin, John C. (21. Mai 1998). „Definition von Domainnamen im Simple Mail Transfer Protocol“ . Tools.ietf.org. Archiviert vom Original am 30. Dezember 2013. Abgerufen am 8. Januar 2014 .
Externe Links
- RFC 1123 : Anforderungen an Internet-Hosts – Anwendung und Unterstützung
- RFC 1535 : Ein Sicherheitsproblem und ein Lösungsvorschlag bei weit verbreiteter DNS-Software
- RFC 2181 : Klarstellungen zur DNS-Spezifikation
- RFC 4703 : Auflösung von Konflikten bei vollqualifizierten Domänennamen (FQDN) zwischen DHCP-Clients (Dynamic Host Configuration Protocol)