Oblivious HTTP ( OHTTP ) ist ein IETF -Netzwerkprotokoll, das anonyme HTTP- Transaktionen über das Internet ermöglicht . [ 1 ] Ziel ist es, Nutzern das Senden von HTTP-Anfragen an Webserver zu erlauben , ohne dass Dritte den Inhalt der Anfrage oder die IP-Adresse des Absenders einsehen können , da die IP-Adresse mit der Identität des Absenders verknüpft werden könnte. [ 2 ] OHTTP ist in RFC 9458 dokumentiert , der im Januar 2024 von Autoren von Mozilla und Cloudflare veröffentlicht wurde . [ 3 ] Im RFC heißt es: „Oblivious HTTP ist einfacher und kostengünstiger als robustere Systeme wie Prio oder Tor , die zwar höhere Sicherheitsgarantien bieten, aber mit höheren Betriebskosten verbunden sind.“ [ 3 ]
Einige Technologieunternehmen und andere Online-Dienstleister haben OHTTP implementiert, um den Datenschutz im Internet zu verbessern , typischerweise für spezifische Anwendungsfälle wie die Erfassung von Softwaremetriken von Clientgeräten, die Sammlung von Nutzerdaten für zielgerichtete Werbung oder die Verarbeitung von Clientanfragen zur Nutzung von KI -Diensten. Die Datenschutzmechanismen des OHTTP-Protokolls basieren darauf, dass zwei separate Instanzen unterschiedliche Aspekte jeder Clientanfrage bearbeiten. Daher arbeiten Dienstanbieter, die OHTTP einsetzen möchten, in der Regel mit verschiedenen Partnern zusammen. Beispielsweise bieten Cloudflare und Fastly OHTTP-Relay-Dienste an, und Apple , Google , Meta und Mozilla kooperieren für ihre OHTTP-Implementierungen mit einem oder beiden Relay-Diensten.
Mechanismus
HTTP bildet die Grundlage der Kommunikation im World Wide Web . Standardmäßig übermittelt HTTP die IP-Adresse eines Website-Nutzers an den Website-Betreiber, wodurch dieser unter Umständen ein Nutzerprofil erstellen kann . [ 3 ] OHTTP ist eines von mehreren Protokollen, die die Privatsphäre von Nutzern schützen sollen, die Anfragen an Webserver senden. Es nutzt das Prinzip der Privacy Partitioning (auch Entkopplung genannt), um IP-Adressen zu verbergen. [ 4 ] [ 5 ] OHTTP ist für einfache Transaktionen wie das Senden von Webanalysedaten konzipiert und nicht für allgemeines Web-Browsing. [ 6 ] [ 7 ] Die meisten OHTTP-Implementierungen verwenden eine Anwendung , beispielsweise eine mobile App , die vorkonfiguriert ist, um für eine bestimmte Art von Transaktion einen OHTTP-Dienst zu kontaktieren. [ 8 ]

OHTTP schützt die Privatsphäre der Nutzer durch die Kombination von Nachrichtenverschlüsselung und speziell entwickelten Proxy-Servern . Zunächst verschlüsselt der Client den Inhalt einer HTTP-Anfrage mittels hybrider Public-Key-Verschlüsselung (HPKE) . [ 9 ] Anschließend sendet der Client die verschlüsselte Anfrage an ein Relay, das zwar die IP-Adresse des Clients ermitteln, die Nachricht aber nicht entschlüsseln kann. [ 3 ] Das Relay leitet die verschlüsselte Nachricht an ein Gateway weiter, das die Nachricht entschlüsseln, aber die IP-Adresse des Clients nicht ermitteln kann. [ 3 ] Das Gateway sendet die entschlüsselte Anfrage zur Verarbeitung an einen Server. [ 3 ] Der gesamte Datenverkehr zwischen Quelle, Relay, Gateway und Zielserver wird über HTTPS übertragen , um zu verhindern, dass Dritte die Nachrichteninhalte analysieren oder abfangen. [ 10 ]
Da weder Relay noch Gateway die Quell-IP-Adresse und den Inhalt einer Anfrage kennen, müssten Relay und Gateway zusammenarbeiten, um Nachrichten zuzuordnen und zu de-anonymisieren. [ 9 ] Ist einer der Betreiber vertrauenswürdig, bleibt die Privatsphäre gewahrt. Arbeiten jedoch beide Betreiber zusammen, können die Datenschutzgarantien von OHTTP gefährdet werden. [ 9 ] Gateway und Zielserver werden üblicherweise von derselben Organisation betrieben, während das Relay in der Regel von einer anderen Organisation betrieben wird, um Absprachen zu verhindern. [ 11 ] Eine Analyse einer OHTTP-Implementierung durch die NCC Group stellte zudem fest, dass zur Reduzierung des Risikos von Verkehrsanalyse und anderen Angriffen „die Implementierung von OHTTP ein sorgfältiges Management von Schlüsselrotation , Ratenbegrenzung und Toleranzen gegenüber Netzwerkverzögerungen erfordert.“ [ 12 ]
Clientanwendungen, die für die Verwendung von OHTTP konfiguriert sind, wie beispielsweise Anwendungen, die OHTTP für bestimmte API- Aufrufe nutzen , müssen nicht prüfen, ob ein Server OHTTP unterstützt. [ 8 ] In anderen Fällen, wenn ein Serverbetreiber Clients mitteilen möchte, dass ein Dienst OHTTP unterstützt, definiert RFC 9540 (Februar 2024) einen optionalen DNS-Ressourceneintragsparameter . [ 8 ] Dieser Mechanismus ermöglicht es einem Client, nach dem Senden einer DNS-Anfrage festzustellen, dass er OHTTP-Anfragen senden kann, obwohl die ursprüngliche DNS-Anfrage die IP-Adresse des Clients dem Server offenlegen könnte, sofern diese nicht anderweitig verborgen ist. [ 8 ]
Einsätze
Cloudflare veröffentlichte 2022 einen OHTTP-Relay-Dienst namens Privacy Gateway. [ 13 ] [ 9 ] Flo , eine App zur Zyklusverfolgung , nutzt den OHTTP-Dienst von Cloudflare, um einen „Anonymen Modus“ anzubieten, der die Dateneingabe in Flo ermöglicht, ohne personenbezogene Daten preiszugeben . [ 14 ]
Google beauftragte 2023 Fastly mit der Bereitstellung eines OHTTP-Relays zur Implementierung seiner experimentellen Technologie für anonyme Werbung. [ 15 ] [ 16 ] Konkret nutzte Google OHTTP, um die k -Anonymität für seine Privacy Sandbox- Initiative sicherzustellen . [ 17 ] Google verwendet ein Fastly-OHTTP-Relay auch im Rahmen seines Dienstes „Google Safe Browsing “. [ 18 ] [ 19 ] Google bietet eine Safe Browsing Oblivious HTTP Gateway API an, die es Client-Anwendungen wie Webbrowsern ermöglicht , zu prüfen, ob eine URL auf Googles Liste unsicherer Websites steht, ohne die IP-Adresse des Anfragenden an Google preiszugeben. [ 20 ]
Im Jahr 2023 begann Mozilla , den OHTTP-Relay-Dienst von Fastly im Rahmen der Erfassung von Firefox- Leistungsmetriken zu nutzen, ohne dabei identifizierende Informationen über einzelne Benutzer zu sammeln. [ 21 ] [ 22 ]
Seit 2024 nutzt Apple OHTTP in seiner Private Cloud Compute-Plattform, um die IP-Adressen von Anfragen an Apple Intelligence- Tools zu verschleiern. [ 23 ] Ebenfalls 2024 veröffentlichte Apple die Unterstützung für OHTTP in seiner Programmiersprache Swift . [ 24 ] 2025 gab Apple bekannt, dass die erweiterte visuelle Suche OHTTP im Rahmen ihrer Anonymisierungsstrategie verwendet. [ 25 ] [ 26 ]
Die Internet Security Research Group integriert ein OHTTP-Gateway in Divvi Up , einen Dienst, der es Abonnenten ermöglicht, Softwaremetriken von Benutzergeräten zu erfassen und dabei nur minimale identifizierende Informationen über die Benutzer zu sammeln. [ 11 ]
Ab 2025 nutzt Meta Platforms OHTTP in seiner Funktion „Private Verarbeitung“ für Meta-KI- Tools, unter anderem um WhatsApp- Nutzern die Möglichkeit zu geben, Zusammenfassungen von Nachrichten anzufordern, ohne die IP-Adresse des Anfragenden an Meta preiszugeben. [ 27 ] Hierfür wird der OHTTP-Relay-Dienst von Fastly verwendet. [ 12 ]
Verwandte Technologien
| Internet- Sicherheitsprotokolle |
|---|
| Schlüsselmanagement |
| Anwendungsschicht |
| Domain Name System |
| Internetschicht |
Eine IETF-Arbeitsgruppe, Oblivious HTTP Application Intermediation (OHAI), ist für die Arbeit an OHTTP-Standards und die Zusammenarbeit mit Gruppen zuständig, die an verwandten Protokollen arbeiten. [ 1 ]
Das Oblivious DNS over HTTPS (ODoH)-Protokoll ermöglicht die Durchführung von Domain Name System (DNS) -Anfragen unter Verwendung ähnlicher Architekturprinzipien wie OHTTP ( RFC 9230 , Juni 2022). [ 10 ]
Manche nutzen VPN-Dienste (Virtual Private Network), um Datenschutzbedenken zu begegnen. Dies ermöglicht es jedoch einer einzelnen Instanz, identifizierende Informationen über den Nutzer und dessen gesamte über das VPN laufende Aktivitäten einzusehen. [ 4 ] Tor ist eine separate Technologie zum Schutz der Privatsphäre von Nutzern im Internet, die den Sender und Empfänger durch mindestens drei Zwischenstationen entkoppelt. [ 4 ]
MASQUE (Multiplexed Application Substrate over QUIC Encryption) ist ein anderes Protokoll zur Verbesserung der Privatsphäre von Nutzern bei Webanfragen. [ 28 ] Es kann zum Surfen im Web verwendet werden. [ 7 ] Beispielsweise nutzt Apples iCloud Private Relay- Dienst MASQUE. [ 29 ]
Siehe auch
Referenzen
- ^ a b „Oblivious HTTP Application Intermediation (ohai)“ . Internet Engineering Task Force (IETF) Datatracker . 19.03.2025 . Abgerufen am 20.09.2025 .
- ^ Sengupta, Jayasree; Dey, Debasmita; Ferlin-Reiter, Simone; Ghosh, Nirnay; Bajpai, Vaibhav (2025-07-01). „Wie widerstandsfähig ist QUIC gegenüber Sicherheits- und Datenschutzangriffen?“. arXiv : 2401.06657 [ cs.CR ].
- ^ a b c d e f Thomson, Martin; Wood, Christopher A. (Januar 2024). „RFC 9458: Oblivious HTTP“ . IETF . ISSN 2070-1721 . Abgerufen am 18. August 2025 .
- Schmitt , Paul; Iyengar, Jana; Wood, Christopher; Raghavan, Barath (14.11.2022). „ Das Entkopplungsprinzip : Ein praktisches Datenschutzframework“ . Proceedings of the 21st ACM Workshop on Hot Topics in Networks . HotNets '22. New York, NY, USA: Association for Computing Machinery. S. 213–220 . doi : 10.1145/3563766.3564112 . ISBN 978-1-4503-9899-2Die
- ^ Kühlewind, Mirja; Pauly, Tommy; Wood, Christopher A. (31.07.2024). „RFC 9614: Partitionierung als Architektur für Datenschutz“ . Internet Engineering Task Force (IETF) Datatracker . Abgerufen am 20.09.2025 .
- ^ Huston, Geoff (23.03.2023). „Hinter Masken verstecken“ . APNIC-Blog . Abgerufen am 20.09.2025 .
- ^ a b McFadden, Mark (2024-07-02). „Der Aufstieg der Intermediäre“ . DNS Research Federation . Abgerufen am 2025-09-20 .
- ^ a b c d Pauly, Tommy; Reddy.K, Tirumaleswar (2024-02-21). "RFC 9540: Discovery of Oblivious Services via Service Binding Records" . Internet Engineering Task Force.
- ^ a b c d Wood, Christopher; Hoyland, Jonathan (27.10.2022). „Stärker als ein Versprechen: Der Nachweis der Datenschutzeigenschaften von Oblivious HTTP“ . Cloudflare . Abgerufen am 18. August 2025 .
- ^ a b „Oblivious HTTP (OHTTP) explained“ . Mozilla Support . Januar 2025. Abgerufen am 18. August 2025 .
- ^ a b Geoghegan, Tim (2024-07-25). „Oblivious HTTP now available on Divvi Up“ . Divvi Up . Internet Security Research Group . Abgerufen am 20.09.2025 .
- ^ a b „Sicherheits- und Datenschutzbewertung: WhatsApp-Nachrichtenzusammenfassungsdienst“ (PDF) . NCC Group . 26.08.2025. S. 8, 12–14 , 25–26 . Abgerufen am 20.09.2025 .
- ^ Galicer, Mari; Wood, Christopher (27.10.2022). „Privacy Gateway: Ein datenschutzfreundlicher Proxy, der auf Internetstandards basiert“ . Der Cloudflare-Blog . Abgerufen am 20.09.2025 .
- ^ Wetsman, Nicole; Faife, Corin (14.09.2022). „Flo-Zyklus-Tracker führt „Anonymen Modus“ ein, um Bedenken hinsichtlich des Datenschutzes bei Abtreibungen entgegenzuwirken“ . The Verge . Abgerufen am 20.09.2025 .
- ^ „Fastly sichert sich wichtigen Google-Deal vor dem Ende der Cookie-Ära“ . The Stack . 15.03.2023 . Abgerufen am 04.03.2025 .
- ^ Kuhn, Simon (15.03.2023). „Datenschutz im Internet mit Oblivious HTTP ermöglichen“ . Fastly . Abgerufen am 19.08.2025 .
- ^ Lee, Philip (15.03.2023). „Partnerschaft mit Fastly – Unauffälliges HTTP-Relay für den k-Anonymitätsserver von FLEDGE“ . Chrome for Developers Blog . Abgerufen am 20.09.2025 .
- ^ Bawa, Jasika; Lu, Xinghui; Li, Jonathan; Wozniak, Alex (14. März 2024). „Echtzeit-URL-Schutz unter Wahrung der Privatsphäre“ . Google Online Security Blog . Abgerufen am 19. August 2025 .
- ^ Amadeo, Ron (15.03.2024). „Google sagt, dass der neue Echtzeit-URL-Scanner von Chrome Ihre Privatsphäre nicht verletzt“ . Ars Technica . Abgerufen am 19.08.2025 .
- ^ „Safe Browsing Oblivious HTTP Gateway API“ . Google für Entwickler . 18.09.2024 . Abgerufen am 20.09.2025 .
- ^ Holley, Bobby (12. Oktober 2023). „Für Datenschutz entwickelt: Partnerschaft zur Einführung von Oblivious HTTP und Prio in Firefox“ . Mozilla Distilled . Abgerufen am 19. August 2025 .
- ^ Iyengar, Jana (12.10.2023). „Firefox und Fastly unternehmen einen weiteren Schritt hin zu mehr Datenschutz im Internet“ . Fastly . Abgerufen am 20.09.2025 .
- ^ „Leitfaden zur Sicherheit privater Cloud-Computing-Systeme: Anforderungsablauf“ . Apple Security Research . 2024. Archiviert vom Original am 06.06.2025 . Abgerufen am 20.09.2025 .
- ^ Benfield, Cory (21.08.2024). „Einführung der Oblivious-HTTP-Unterstützung in Swift“ . Swift . Apple . Abgerufen am 19.08.2025 .
- ^ „Informationen zur erweiterten visuellen Suche in Fotos“ . Apple Support . 12. Februar 2025. Abgerufen am 4. März 2025 .
- ^ Claburn, Thomas (03.01.2025). „Apple aktiviert automatisch die KI-gestützte Analyse von Fotos nach Sehenswürdigkeiten für alle Nutzer“ . The Register . Abgerufen am 21.09.2025 .
- ^ „Aufbau privater Verarbeitung für KI-Tools auf WhatsApp“ . Engineering bei Meta . 29.04.2025 . Abgerufen am 20.09.2025 .
- ^ Schinazi, David (07.07.2025). „Der MASQUE-Proxy“ . Internet Engineering Task Force (IETF) Datatracker . Abgerufen am 20.09.2025 .
- ^ Nottingham, Mark (30.12.2022). „Der Status von HTTP im Jahr 2022“ . Der Cloudflare-Blog . Abgerufen am 20.09.2025 .