Pulscodemodulation ( PCM ) ist ein Verfahren zur digitalen Darstellung analoger Signale . Sie ist der Standard für digitale Audioübertragung in Computern, CDs , digitaler Telefonie und anderen digitalen Audioanwendungen. In einem PCM- Datenstrom wird die Amplitude des analogen Signals in gleichmäßigen Abständen abgetastet und jede Abtastung auf den nächstliegenden Wert innerhalb eines Bereichs digitaler Schritte quantisiert . Claude Shannon , Bernard Oliver und John Pierce wurden für ihr 1952 erteiltes PCM-Patent in die National Inventors Hall of Fame aufgenommen. [ 6 ] [ 7 ] [ 8 ] [ 9 ]
Lineare Pulscodemodulation ( LPCM ) ist eine spezielle Art der PCM, bei der die Quantisierungsstufen linear gleichmäßig sind. [ 5 ] Dies steht im Gegensatz zu PCM-Codierungen, bei denen die Quantisierungsstufen als Funktion der Amplitude variieren (wie beim A-Gesetz-Algorithmus oder dem μ-Gesetz-Algorithmus ). Obwohl PCM ein allgemeinerer Begriff ist, wird er häufig verwendet, um als LPCM codierte Daten zu beschreiben.
Ein PCM-Stream besitzt zwei grundlegende Eigenschaften, die die Wiedergabetreue des Streams gegenüber dem ursprünglichen analogen Signal bestimmen: die Abtastrate , d. h. die Anzahl der Abtastungen pro Sekunde; und die Bittiefe , d. h. die Anzahl der möglichen digitalen Werte, die zur Darstellung jeder Abtastung verwendet werden können.
Geschichte
Die Anfänge der elektrischen Kommunikation begannen mit der Abtastung von Signalen, um Abtastwerte mehrerer Telegrafenquellen zu multiplexen und über ein einziges Telegrafenkabel zu übertragen. Der amerikanische Erfinder Moses G. Farmer entwickelte bereits 1853 das Telegrafen -Zeitmultiplexverfahren (TDM). Der Elektroingenieur W. M. Miner nutzte 1903 einen elektromechanischen Kommutator für das Zeitmultiplexverfahren mehrerer Telegrafensignale und wandte diese Technologie auch in der Telefonie an . Er erzielte verständliche Sprachqualität mit Abtastraten über 3500–4300 Hz; niedrigere Raten erwiesen sich als unbefriedigend.
Im Jahr 1920 nutzte das Bartlane-Kabelbildübertragungssystem die Telegrafensignalisierung von in Lochstreifen gestanzten Zeichen, um in fünf Stufen quantisierte Bildproben zu senden . [ 10 ] 1926 patentierte Paul M. Rainey von Western Electric ein Faxgerät , das sein Signal mittels 5-Bit-PCM übertrug, codiert durch einen optomechanischen Analog-Digital-Wandler . [ 11 ] Das Gerät ging nicht in Serie. [ 12 ]
Der britische Ingenieur Alec Reeves , der keine Kenntnis von früheren Arbeiten hatte, entwickelte 1937 während seiner Tätigkeit für International Telephone and Telegraph in Frankreich die Idee, PCM für die Sprachkommunikation zu nutzen. Er beschrieb die Theorie und ihre Vorteile, doch es kam zu keiner praktischen Anwendung. Reeves meldete 1938 ein französisches Patent an, und sein US-Patent wurde 1943 erteilt. [ 13 ] Zu diesem Zeitpunkt hatte Reeves bereits eine Tätigkeit am Telecommunications Research Establishment aufgenommen . [ 12 ]
Die erste Sprachübertragung mittels digitaler Verfahren, das SIGSALY- Verschlüsselungssystem, diente der Kommunikation auf höchster Ebene der Alliierten während des Zweiten Weltkriegs . 1949 entwickelte Ferranti Canada für das DATAR -System der kanadischen Marine ein funktionsfähiges PCM-Funksystem, das digitalisierte Radardaten über große Entfernungen übertragen konnte. [ 14 ]
In den späten 1940er und frühen 1950er Jahren verwendete die Phasenwechseltechnik (PCM) eine Kathodenstrahlröhre mit einer Plattenelektrode , die Codierungsperforationen aufwies. [ 15 ] Ähnlich wie bei einem Oszilloskop wurde der Strahl horizontal mit der Abtastrate abgelenkt, während die vertikale Ablenkung durch das analoge Eingangssignal gesteuert wurde. Dadurch durchlief der Strahl höhere oder niedrigere Bereiche der perforierten Platte. Die Platte sammelte den Strahl oder ließ ihn durch, wodurch Stromschwankungen im Binärcode, Bit für Bit, erzeugt wurden. Anstelle des natürlichen Binärcodes war das Gitter der späteren Goodall-Röhre perforiert, um einen störungsfreien Gray-Code zu erzeugen . Alle Bits wurden gleichzeitig mithilfe eines Fächerstrahls anstelle eines Abtaststrahls erzeugt. [ 16 ]
In den Vereinigten Staaten wurden Bernard M. Oliver [ 17 ] und Claude Shannon [ 18 ] von der National Inventors Hall of Fame als Erfinder der Pulscodemodulation (PCM) [ 19 ] geehrt . Diese wurde in der US-Patentschrift „Communication System Employing Pulse Code Modulation“ ( US-Patent 2,801,281) beschrieben , die 1946 und 1952 eingereicht und 1956 erteilt wurde. Ein weiteres Patent mit demselben Titel wurde 1945 von John R. Pierce eingereicht und 1948 erteilt: US-Patent 2,437,707 . Die drei veröffentlichten 1948 das Werk „The Philosophy of PCM“ [ 20 ].
Das 1961 eingeführte T-Träger -System nutzt zwei verdrillte Doppeladerleitungen zur Übertragung von 24 PCM- Telefongesprächen mit einer Abtastrate von 8 kHz und einer Auflösung von 8 Bit. Diese Entwicklung verbesserte die Kapazität und die Gesprächsqualität im Vergleich zu den vorherigen Frequenzmultiplexverfahren .
Im Jahr 1973 wurde die adaptive differentielle Pulscodemodulation (ADPCM) von P. Cummiskey, Nikil Jayant und James L. Flanagan entwickelt . [ 21 ]
Digitale Audioaufnahmen
1967 wurde in den Forschungseinrichtungen des japanischen Rundfunksenders NHK der erste PCM-Recorder entwickelt . [ 22 ] Das 30-kHz-12-Bit-Gerät nutzte einen Kompander (ähnlich der DBX-Rauschunterdrückung ) zur Erweiterung des Dynamikbereichs und speicherte die Signale auf einem Videobandgerät . 1969 erweiterte NHK die Systemfunktionen auf 2-Kanal -Stereo und eine Auflösung von 32 kHz und 13 Bit. Im Januar 1971 fertigten Ingenieure von Denon mit dem PCM-Aufnahmesystem von NHK die ersten kommerziellen Digitalaufnahmen an. [ Anmerkung 1 ] [ 22 ]
1972 stellte Denon den ersten 8-Kanal-Digitalrekorder, den DN-023R, vor. Dieser nutzte einen 4-Kopf-Spulen-Videorekorder für Broadcast-Videoaufnahmen mit 47,25 kHz und 13-Bit-PCM-Audio. [ Anmerkung 2 ] 1977 entwickelte Denon das tragbare PCM-Aufnahmesystem DN-034R. Wie der DN-023R zeichnete auch dieses 8 Kanäle mit 47,25 kHz auf, verwendete jedoch 14 Bit, was 15,5 Bit entspricht . [ 22 ]
1979 wurde das erste digitale Popalbum, Bop till You Drop , aufgenommen. Es wurde in 50 kHz, 16-Bit linearem PCM mit einem digitalen 3M-Bandgerät aufgenommen. [ 23 ]
Mit der Einführung der Compact Disc (CD) im Jahr 1982 hielt PCM Einzug in die Welt der Consumer-Audio-Anwendungen. Die CD nutzt eine Abtastfrequenz von 44.100 Hz und eine Auflösung von 16 Bit und speichert bis zu 80 Minuten Stereo-Audio pro Disc.
Digitale Telefonie
Die rasante Entwicklung und weite Verbreitung der digitalen PCM-Telefonie wurde durch die Anfang der 1970er Jahre entwickelte MOS - Schaltkondensator -Technologie ermöglicht. [ 24 ] Dies führte Ende der 1970er Jahre zur Entwicklung von PCM-Codec-Filter-Chips. [ 24 ] [ 25 ] Der 1980 von David A. Hodges und WC Black entwickelte Silizium-Gate -CMOS -PCM-Codec-Filter-Chip (komplementärer MOS) [ 24 ] gilt seither als Industriestandard für die digitale Telefonie. [ 24 ] [ 25 ] In den 1990er Jahren wurden Telekommunikationsnetze wie das öffentliche Telefonnetz (PSTN) weitgehend digitalisiert , wobei CMOS-PCM-Codec-Filter in sehr großer Integrationsstufe (VLSI) zum Einsatz kamen. Diese wurden in elektronischen Vermittlungssystemen für Telefonzentralen , Endbenutzermodems und einer Vielzahl digitaler Übertragungsanwendungen wie dem ISDN ( Integrated Services Digital Network ), schnurlosen Telefonen und Mobiltelefonen eingesetzt . [ 25 ]
Implementierungen
PCM ist das üblicherweise für unkomprimierte digitale Audiosignale verwendete Codierungsverfahren. [ Anmerkung 3 ]
- Die 4ESS-Vermittlungsanlage führte 1976 die Zeitmultiplex-Vermittlung in das US-amerikanische Telefonsystem ein und basierte auf der Technologie mittelintegrierter Schaltungen. [ 26 ]
- LPCM wird für die verlustfreie Codierung von Audiodaten im Compact Disc Red Book Standard (informell auch als Audio-CD bekannt ) verwendet, der 1982 eingeführt wurde.
- AES3 (spezifiziert 1985, worauf S/PDIF basiert) ist ein spezielles Format, das LPCM verwendet.
- LaserDiscs mit digitalem Ton verfügen über eine LPCM-Spur auf dem digitalen Kanal.
- Auf PCs bezeichnen PCM und LPCM häufig das Format, das in den Audio-Containerformaten WAV (definiert 1991) und AIFF (definiert 1988) verwendet wird. LPCM-Daten können auch in anderen Formaten wie AU , dem Rohaudioformat (Datei ohne Header) und verschiedenen Multimedia- Containerformaten gespeichert werden .
- LPCM ist seit 1995 Bestandteil der DVD- und seit 2006 der Blu-ray- Standards. [ 27 ] [ 28 ] [ 29 ] Es ist außerdem Bestandteil verschiedener digitaler Video- und Audiospeicherformate (z. B. DV seit 1995, [ 30 ] AVCHD seit 2006 [ 31 ] ).
- LPCM wird von HDMI (definiert im Jahr 2002) verwendet , einer digitalen Audio-/Video-Schnittstelle mit nur einem Kabel zur Übertragung unkomprimierter digitaler Daten.
- Das RF64- Containerformat (definiert im Jahr 2007) verwendet LPCM und ermöglicht auch die Speicherung von Nicht-PCM-Bitstreams: Verschiedene Komprimierungsformate, die in der RF64-Datei als Datenpakete enthalten sind (Dolby E, Dolby AC3, DTS, MPEG-1/MPEG-2 Audio), können als lineares PCM „tarnt“ werden. [ 32 ]
Modulation

Im Diagramm wird eine Sinuswelle (rote Kurve) für die Phasenumwandlung (PCM) abgetastet und quantisiert. Die Abtastung der Sinuswelle erfolgt in regelmäßigen Abständen, dargestellt durch vertikale Linien. Für jede Abtastung wird einer der verfügbaren Werte (auf der y-Achse) ausgewählt. Die PCM-Umwandlung wird üblicherweise auf einem integrierten Schaltkreis , dem sogenannten Analog-Digital-Wandler (ADC), implementiert. Dieser erzeugt eine vollständig diskrete Darstellung des Eingangssignals (blaue Punkte), die sich leicht als digitale Daten für die Speicherung oder Weiterverarbeitung kodieren lässt. Mehrere PCM-Ströme können auch zu einem größeren aggregierten Datenstrom gemultiplext werden , typischerweise zur Übertragung mehrerer Ströme über eine einzige physikalische Verbindung. Ein Verfahren hierfür ist das Zeitmultiplexverfahren (TDM), das weit verbreitet ist, insbesondere im modernen öffentlichen Telefonsystem.
Demodulation
Die Elektronik zur Erzeugung eines präzisen analogen Signals aus den diskreten Daten ähnelt derjenigen zur Erzeugung des digitalen Signals. Es handelt sich dabei um Digital-Analog-Wandler (DACs). Sie erzeugen je nach Typ eine Spannung oder einen Strom , der dem Wert an ihren digitalen Eingängen entspricht. Dieses Ausgangssignal wird anschließend in der Regel gefiltert und verstärkt.
Um das ursprüngliche Signal aus den abgetasteten Daten wiederherzustellen, kann ein Demodulator das Modulationsverfahren in umgekehrter Reihenfolge anwenden. Nach jeder Abtastperiode liest der Demodulator den nächsten Wert und ändert das Ausgangssignal entsprechend. Aufgrund dieser Übergänge enthält das Signal aufgrund von Abbildungseffekten einen signifikanten Anteil an hochfrequenter Energie. Um diese unerwünschten Frequenzen zu entfernen, leitet der Demodulator das Signal durch einen Rekonstruktionsfilter , der Energien außerhalb des erwarteten Frequenzbereichs (oberhalb der Nyquist-Frequenz ) unterdrückt. [ Anmerkung 4 ]
Standardgenauigkeit und -raten der Probenahme
Gängige Abtasttiefen für LPCM sind 8, 16, 20 oder 24 Bit pro Abtastwert. [ 1 ] [ 2 ] [ 3 ] [ 33 ]
LPCM kodiert einen einzelnen Tonkanal. Die Unterstützung von Mehrkanal-Audio hängt vom Dateiformat ab und erfordert die Synchronisierung mehrerer LPCM-Streams. [ 5 ] [ 34 ] Obwohl zwei Kanäle (Stereo) das gängigste Format sind, können Systeme bis zu acht Audiokanäle (7.1 Surround) [ 2 ] [ 3 ] oder mehr unterstützen.
Gängige Abtastfrequenzen sind 48 kHz , wie sie bei DVD -Videos verwendet werden, oder 44,1 kHz, wie sie bei CDs üblich sind. Abtastfrequenzen von 96 kHz oder 192 kHz können bei einigen Geräten eingesetzt werden, deren Vorteile jedoch umstritten sind . [ 35 ]
Einschränkungen
Das Nyquist-Shannon-Abtasttheorem zeigt, dass PCM-Bauelemente innerhalb ihrer vorgesehenen Frequenzbänder verzerrungsfrei arbeiten können, wenn sie eine Abtastfrequenz liefern, die mindestens doppelt so hoch ist wie die höchste Frequenz des Eingangssignals. Beispielsweise liegt in der Telefonie der nutzbare Sprachfrequenzbereich zwischen etwa 300 und 3400 Hz . [ 36 ] Für eine effektive Rekonstruktion des Sprachsignals verwenden Telefonieanwendungen daher typischerweise eine Abtastfrequenz von 8000 Hz, die mehr als doppelt so hoch ist wie die höchste nutzbare Sprachfrequenz.
Ungeachtet dessen birgt jedes PCM-System potenzielle Fehlerquellen:
- Die Wahl eines diskreten Wertes, der nahe am, aber nicht exakt am Pegel des analogen Signals liegt, führt für jede Abtastung zu Quantisierungsfehlern . Wird Dithering zur Kompensation dieses Fehlers eingesetzt, entsteht zusätzliches Rauschen. [ Anmerkung 5 ]
- Zwischen den Abtastwerten wird keine Messung des Signals durchgeführt; das Abtasttheorem garantiert eine eindeutige Darstellung und Wiederherstellung des Signals nur dann, wenn es bei einer Frequenz von f s /2 oder höher (der Hälfte der Abtastfrequenz, bekannt als Nyquist-Frequenz ) keine Energie besitzt; höhere Frequenzen werden nicht korrekt dargestellt oder wiederhergestellt und fügen dem Signal unterhalb der Nyquist-Frequenz Aliasing-Verzerrungen hinzu.
- Da die Abtastwerte zeitabhängig sind, ist für eine genaue Wiedergabe ein präziser Taktgeber erforderlich. Ist der Taktgeber für die Codierung oder Decodierung nicht stabil, wirken sich diese Ungenauigkeiten direkt auf die Ausgabequalität des Geräts aus. [ Anmerkung 6 ]
Verarbeitung und Codierung
Einige PCM-Verfahren kombinieren Signalverarbeitung mit Codierung. Ältere Versionen dieser Systeme nutzten die Verarbeitung im analogen Bereich als Teil der Analog-Digital-Wandlung; neuere Implementierungen führen sie im digitalen Bereich durch. Diese einfachen Techniken wurden weitgehend durch moderne, transformationsbasierte Audiokompressionsverfahren wie die modifizierte diskrete Kosinustransformation (MDCT) verdrängt.
- Lineares PCM (LPCM) ist PCM mit linearer Quantisierung. [ 5 ]
- Differential-PCM (DPCM) kodiert die PCM-Werte als Differenz zwischen dem aktuellen und dem vorhergesagten Wert. Ein Algorithmus sagt den nächsten Wert basierend auf den vorherigen Werten voraus, und der Encoder speichert nur die Differenz zwischen dieser Vorhersage und dem tatsächlichen Wert. Ist die Vorhersage plausibel, können weniger Bits zur Darstellung derselben Information verwendet werden. Bei Audio reduziert diese Kodierungsart die Anzahl der benötigten Bits pro Abtastwert im Vergleich zu PCM um etwa 25 %.
- Die adaptive differentielle Pulscodemodulation (ADPCM) ist eine Variante der DPCM, bei der die Größe des Quantisierungsschritts variiert wird, um eine weitere Reduzierung der erforderlichen Bandbreite für ein gegebenes Signal-Rausch-Verhältnis zu ermöglichen .
- Die Delta-Modulation ist eine Form der DPCM, bei der pro Abtastwert ein Bit verwendet wird, um anzuzeigen, ob das Signal im Vergleich zum vorherigen Abtastwert zu- oder abnimmt.
In der Telefonie wird ein Standard-Audiosignal für ein einzelnes Telefongespräch mit 8.000 Abtastungen pro Sekunde à 8 Bit codiert. Dies ergibt ein digitales Signal mit 64 kbit/s, bekannt als DS0 . Die Standard -Signalkomprimierung für DS0 ist entweder μ-Law- PCM (Nordamerika und Japan) oder A-Law -PCM (Europa und der Großteil der übrigen Welt). Dabei handelt es sich um logarithmische Kompressionsverfahren, bei denen eine 12- oder 13-Bit-Abtastzahl des linearen PCM auf einen 8-Bit-Wert abgebildet wird. Dieses System ist im internationalen Standard G.711 beschrieben .
Bei hohen Leitungskosten und akzeptablem Qualitätsverlust kann eine weitere Komprimierung des Sprachsignals sinnvoll sein. Ein ADPCM-Algorithmus wandelt eine Folge von 8-Bit-μ-Law- oder A-Law-PCM-Abtastwerten in eine Folge von 4-Bit-ADPCM-Abtastwerten um. Dadurch verdoppelt sich die Leitungskapazität. Das Verfahren ist im Standard G.726 detailliert beschrieben.
Zur weiteren Komprimierung wurden Audiocodierungsformate und Audiocodecs entwickelt. Einige dieser Verfahren wurden standardisiert und patentiert. Fortschrittliche Komprimierungsverfahren wie die modifizierte diskrete Kosinustransformation (MDCT) und die lineare prädiktive Codierung (LPC) finden heute breite Anwendung in Mobiltelefonen , Voice over IP (VoIP) und Streaming-Medien .
Kodierung für serielle Übertragung
PCM kann entweder Return-to-Zero (RZ) oder Non-Return-to-Zero (NRZ) sein. Damit ein NRZ-System mithilfe von In-Band-Informationen synchronisiert werden kann, dürfen keine langen Sequenzen identischer Symbole, wie z. B. Einsen oder Nullen, vorhanden sein. Bei binären PCM-Systemen wird die Dichte der Einsen als Einsendichte bezeichnet . [ 37 ]
Die Einsendichte wird häufig durch Vorcodierungsverfahren wie die Lauflängenbegrenzungscodierung gesteuert . Dabei wird der PCM-Code vor der Modulation in den Kanal zu einem etwas längeren Code mit garantierter Einsendichte erweitert. In anderen Fällen werden dem Datenstrom zusätzliche Rahmenbits hinzugefügt, wodurch zumindest gelegentliche Symbolübergänge gewährleistet werden.
Eine weitere Technik zur Kontrolle der Einsendichte ist die Verwendung eines Scramblers , der den Datenstrom in einen scheinbar zufälligen Strom umwandelt. Die Daten lassen sich jedoch mithilfe eines komplementären Descramblers exakt wiederherstellen. In diesem Fall sind zwar längere Sequenzen von Nullen oder Einsen im Ausgangssignal weiterhin möglich, gelten aber als so unwahrscheinlich, dass eine zuverlässige Synchronisierung gewährleistet ist.
In anderen Fällen ist der langfristige Gleichstromwert des modulierten Signals wichtig, da sich eine Gleichstromvorspannung aufbauend dazu neigt, Kommunikationsschaltungen außerhalb ihres Betriebsbereichs zu bewegen. In diesem Fall werden spezielle Maßnahmen ergriffen, um die kumulative Gleichstromvorspannung zu erfassen und die Codes gegebenenfalls so anzupassen, dass die Gleichstromvorspannung stets gegen null tendiert.
Viele dieser Codes sind bipolare Codes , bei denen die Impulse positiv, negativ oder fehlend sein können. Im typischen alternierenden Markierungsinversionscode wechseln sich positive und negative Impulse ab. Diese Regeln können verletzt werden, um spezielle Symbole für die Rahmung oder andere spezielle Zwecke zu erzeugen.
Nomenklatur
Der Begriff „Puls“ in Pulscodemodulation ( PCM ) bezieht sich auf die in der Übertragungsleitung auftretenden Impulse. Dies ist vermutlich eine natürliche Folge der Entwicklung dieser Technik parallel zu zwei analogen Verfahren, der Pulsweitenmodulation (PWM) und der Pulspositionsmodulation (PPM) , bei denen die zu kodierende Information durch diskrete Signalimpulse mit variierender Breite bzw. Position dargestellt wird. Insofern weist PCM wenig Ähnlichkeit mit diesen anderen Formen der Signalkodierung auf, außer dass alle im Zeitmultiplexverfahren eingesetzt werden können und die Nummern der PCM-Codes als elektrische Impulse dargestellt werden.
Siehe auch
- Beta-Encoder
- Äquivalentes Pulscodemodulationsrauschen
- Signal-zu-Quantisierungsrauschen-Verhältnis (SQNR), eine Methode zur Messung des Quantisierungsfehlers
Erläuterungen
- ^ Zu den ersten Aufnahmen gehörte Uzu: The World Of Stomu Yamash'ta 2 von Stomu Yamashta .
- ^ Die erste Aufnahme mit diesem neuen System wurde in Tokio vom 24. bis 26. April 1972 gemacht.
- ^ Es gibt auch andere Methoden, wie zum Beispiel die Pulsdichtemodulation, die auch bei Super Audio CDs verwendet wird .
- Einige Systeme nutzen digitale Filter , um Aliasing-Effekte zu reduzieren. Dabei wird das Signal mit einer höheren Abtastrate von digital in analog umgewandelt, wodurch der analoge Anti-Aliasing-Filter deutlich einfacher wird. In manchen Systemen wird gar keine explizite Filterung angewendet. Da kein System ein Signal mit unendlicher Bandbreite reproduzieren kann, kompensieren systembedingte Verluste die Artefakte – oder das System benötigt schlicht keine hohe Präzision.
- Der Quantisierungsfehler schwankt zwischen -q / 2 und q /2. Im Idealfall (bei einem vollständig linearen ADC und einem Signalpegel >> q ) ist er gleichmäßig über dieses Intervall verteilt, mit einem Mittelwert von Null und einer Varianz von q² / 12.
- Ein geringfügiger Unterschied zwischen den Taktfrequenzen für Codierung und Decodierung ist im Allgemeinen unproblematisch; ein kleiner, konstanter Fehler ist nicht wahrnehmbar. Taktfehler werden jedoch zu einem gravierenden Problem, wenn der Takt signifikanten Jitter aufweist .
Referenzen
- ^ a b c Alvestrand, Harald Tveit; Salsman, James (Mai 1999). „RFC 2586 – Der Audio/L16 MIME-Inhaltstyp“ . The Internet Society. doi : 10.17487/RFC2586 . Abgerufen am 16. März 2010 .
{{cite journal}}: Zeitschrift zitieren erfordert|journal=( Hilfe ) - Casner , S. (März 2007). „ RFC 4856 – Registrierung von Nutzdatenformaten im RTP-Profil für Audio- und Videokonferenzen – Registrierung des Medientyps audio/L8“ . The IETF Trust. doi : 10.17487/RFC4856 . Abgerufen am 16. März 2010 .
{{cite journal}}: Zeitschrift zitieren erfordert|journal=( Hilfe ) - ^ a b c d Bormann, C.; Casner, S.; Kobayashi, K.; Ogawa, A. (Januar 2002). „RFC 3190 – RTP Payload Format for 12-bit DAT Audio and 20- and 24-bit Linear Sampled Audio“ . The Internet Society. doi : 10.17487/RFC3190 . Abgerufen am 16. März 2010 .
{{cite journal}}: Zeitschrift zitieren erfordert|journal=( Hilfe ) - ^ „Audio Media Types“ . Internet Assigned Numbers Authority . Abgerufen am 16. März 2010 .
- ^ a b c d „Linear Pulse Code Modulated Audio (LPCM)“ . Library of Congress . 19. April 2022. Abgerufen am 5. September 2022 .
- ^ Noll, A. Michael (1997). Highway of Dreams: A Critical View Along the Information Superhighway . Telekommunikation (Überarbeitete Ausgabe). Mahwah, NJ: Erlbaum. S. 50. ISBN 978-0-8058-2557-2Die
- ^ Leibson, Steven (7. September 2021). „Eine kurze Geschichte des Ein-Chip-DSP, Teil I“ . EEJournal . Abgerufen am 19. September 2024 .
- ^ Barrett, G. Douglas (2023). Experimenting the Human: Art, Music, and the Contemporary Posthuman . Chicago/London: The University of Chicago Press . S. 102. ISBN 978-0-226-82340-9Die
- ^ Haykin, Simon; Moher, Michael (2010). Kommunikationssysteme . John Wiley & Sons, Inc. S. 260–266 . ISBN 9788126521517Die
- ^ „Das Bartlane-Übertragungssystem“ . DigicamHistory.com. Archiviert vom Original am 10. Februar 2010. Abgerufen am 7. Januar 2010 .
- ^ US-Patentnummer 1.608.527; siehe auch S. 8, Datenkonvertierungshandbuch , herausgegeben von Walter Allan Kester, Newnes, 2005, ISBN 0-7506-7841-0Die
- ^ a b John Vardalas (Juni 2013), Pulscodemodulation: Alles begann vor 75 Jahren mit Alec Reeves , IEEE
- ^ US 2272070
- ^ Porter, Arthur (2004). So Many Hills to Climb . Beckham Publications Group. ISBN 9780931761188Die
- ^ Sears, RW (Januar 1948). „Elektronenstrahlablenkröhre für Pulscodemodulation“ . Bell System Technical Journal . 27. Bell Labs : 44–57 . Bibcode : 1948BSTJ...27...44S . doi : 10.1002/j.1538-7305.1948.tb01330.x . Abgerufen am 14. Mai 2017 .
- ^ Goodall, W. M. (Januar 1951). „Fernsehen mittels Pulscodemodulation“ . Bell System Technical Journal . 30. Bell Labs : 33–49 . Bibcode : 1951BSTJ...30...33G . doi : 10.1002 /j.1538-7305.1951.tb01365.x . Abgerufen am 14. Mai 2017 .
- ^ „Bernard Oliver“ . National Inventor's Hall of Fame . Archiviert vom Original am 5. Dezember 2010. Abgerufen am 6. Februar 2011 .
- ^ „Claude Shannon“ . National Inventor's Hall of Fame . Archiviert vom Original am 6. Dezember 2010. Abgerufen am 6. Februar 2011 .
- ^ „National Inventors Hall of Fame gibt die Erfinder des Jahres 2004 bekannt“ . Science Blog . 11. Februar 2004. Abgerufen am 6. Februar 2011 .
- ^ BM Oliver; JR Pierce & CE Shannon (November 1948). „Die Philosophie der PCM“. Proceedings of the IRE . 36 (11): 1324–1331 . Bibcode : 1948PIRE...36.1324O . doi : 10.1109/JRPROC.1948.231941 . ISSN 0096-8390 . S2CID 51663786 .
- ^ P. Cummiskey, NS Jayant und JL Flanagan, „Adaptive quantization in differential PCM coding of speech“, Bell Syst. Tech. J., Bd. 52, S. 1105–1118, Sept. 1973.
- ^ a b c Thomas Fine (2008). „Der Beginn der kommerziellen digitalen Aufnahmetechnik“ (PDF) . ARSC Journal . 39 (1): 1–17 .
- ^ Roger Nichols. „I Can't Keep Up With All The Formats II“ . Archiviert vom Original am 20. Oktober 2002.
Das Album „Bop Till You Drop“ von Ry Cooder war das erste digital aufgenommene Popalbum.
- ^ a b c d Allstot, David J. (2016). „Schaltkondensatorfilter“ (PDF) . In: Maloberti, Franco; Davies, Anthony C. (Hrsg.). Eine kurze Geschichte von Schaltungen und Systemen: Von grünen, mobilen, allgegenwärtigen Netzwerken bis hin zu Big-Data-Computing . IEEE Circuits and Systems Society . S. 105–110 . ISBN 9788793609860Archiviert vom Original (PDF) am 30. September 2021. Abgerufen am 29. November 2019 .
- Floyd , Michael D.; Hillman, Garth D. (8. Oktober 2018) [Erstveröffentlichung 2000]. „ Pulse - Code Modulation Codec-Filters“ . The Communications Handbook (2. Aufl.). CRC Press . S. 26–1 , 26–2 , 26–3 . ISBN 9781420041163Die
- ^ Cambron, G. Keith (17. Oktober 2012). Globale Netzwerke: Entwicklung, Betrieb und Design . John Wiley & Sons. S. 345.
- ^ Blu-ray Disc Association (März 2005), Whitepaper Blu-ray Disc Format – 2.B Audio Visual Application Format Specifications for BD-ROM (PDF) , abgerufen am 26. Juli 2009
- ^ „Technische Hinweise zur DVD (DVD-Video – „Buch B“) – Spezifikationen der Audiodaten“ . 21. Juli 1996. Archiviert vom Original am 10. Februar 2014. Abgerufen am 16. März 2010 .
- ^ Jim Taylor. „DVD Frequently Asked Questions (and Answers) – Audio details of DVD-Video“ . Abgerufen am 20. März 2010 .
- ^ „Wie DV funktioniert“ . Archiviert vom Original am 6. Dezember 2007. Abgerufen am 21. März 2010 .
- ^ „AVCHD-Informationswebsite – Übersicht der AVCHD-Formatspezifikation“ . Abgerufen am 21. März 2010 .
- ^ EBU (Juli 2009), EBU Tech 3306 – MBWF / RF64: Ein erweitertes Dateiformat für Audio (PDF) , archiviert vom Original (PDF) am 22. November 2009 , abgerufen am 19. Januar 2010
- ^ Mostafa, Mohamed; Kumar, Rajesh (Mai 2001). „RFC 3108 – Konventionen für die Verwendung des Session Description Protocol (SDP) für ATM-Bearer-Verbindungen“ . doi : 10.17487/RFC3108 . Abgerufen am 16. März 2010 .
{{cite journal}}: Zeitschrift zitieren erfordert|journal=( Hilfe ) - ^ „PCM, Pulse Code Modulated Audio“ . Library of Congress. 6. April 2022. Abgerufen am 5. September 2022 .
- ^ Christopher, Montgometry. „24/192 Musik-Downloads und warum sie keinen Sinn ergeben“ . Chris „Monty“ Montgomery. Archiviert vom Original am 6. September 2014. Abgerufen am 16. März 2013 .
- ^ https://www.its.bldrdoc.gov/fs-1037/dir-039/_5829.htm
- ^ Stallings, William, Digitale Signaltechniken , Dezember 1984, Band 22, Nr. 12, IEEE Communications Magazine
Weiterführende Literatur
- Franklin S. Cooper ; Ignatius Mattingly (1969). „Computergesteuertes PCM-System zur Untersuchung der dichotischen Sprachwahrnehmung“ . Journal of the Acoustical Society of America . 46 (1A): 115. Bibcode : 1969ASAJ...46..115C . doi : 10.1121/1.1972688 .
- Ken C. Pohlmann (1985). Grundlagen der digitalen Audiotechnik (2. Aufl.). Carmel, Indiana: Sams/Prentice-Hall Computer Publishing. ISBN 978-0-672-22634-2Die
- DH Whalen , ER Wiley, Philip E. Rubin und Franklin S. Cooper (1990). „Das Pulscodemodulationssystem (PCM) der Haskins Laboratories“ . Behavior Research Methods, Instruments, and Computers . 22 (6): 550–559 . doi : 10.3758/BF03204440 .
{{cite journal}}: CS1 Wartung: Mehrere Namen: Autorenliste ( Link ) - Bill Waggener (1995). Pulse-Code-Modulationstechniken (1. Aufl.). New York, NY: Van Nostrand Reinhold. ISBN 978-0-442-01436-0Die
- Bill Waggener (1999). Entwurf von Pulscodemodulationssystemen (1. Aufl.). Boston, MA: Artech House. ISBN 978-0-89006-776-5Die
Externe Links
- PCM-Beschreibung auf MultimediaWiki
- Ralph Miller und Bob Badgley erfanden unabhängig voneinander im Rahmen ihrer Arbeit bei den Bell Labs an SIGSALY die Multi-Level-PCM : US-Patent 3,912,868, eingereicht im Jahr 1943: N-äre Pulscodemodulation.
- Informationen zu PCM : Eine Beschreibung von PCM mit Links zu Informationen über Subtypen dieses Formats (z. B. lineare Pulscodemodulation ) und Verweisen auf deren Spezifikationen.
- Zusammenfassung von LPCM – Enthält Links zu Informationen über Implementierungen und deren Spezifikationen.
- Steuerung interner/externer Hardware über die Media Control Interface von Microsoft – Enthält Informationen und Spezifikationen zur Implementierung von LPCM in WAV-Dateien.
- RFC 4856 – Medientypregistrierung von Nutzdatenformaten im RTP-Profil für Audio- und Videokonferenzen – audio/L8 und audio/L16 (März 2007)
- RFC 3190 – RTP-Payload-Format für 12-Bit-DAT-Audio und 20- und 24-Bit-Linear-Sampling-Audio (Januar 2002)
- RFC 3551 – RTP-Profil für Audio- und Videokonferenzen mit minimaler Steuerung – L8 und L16 (Juli 2003)